LINUX.ORG.RU

[debian sid] Что-то сломал, и не могу удалить пакет adobe-flashplugin


0

0

sudo aptitude purge adobe-flashplugin
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях... Готово
Инициализация состояний пакетов... Готово
Запись информации расширенных состояний... Готово
Чтение описаний задач... Готово
Следующие пакеты будут УДАЛЕНЫ:
  adobe-flashplugin{p}
0 пакетов обновлено, 0 установлено новых, 1 пакетов отмечено для удаления, и 5 пакетов не обновлено.
Необходимо получить 0B архивов. После распаковки освободится 10,4M байт.
Хотите продолжить? [Y/n/?]
Запись информации расширенных состояний... Готово
dpkg: не удалось обработать параметр adobe-flashplugin (--purge):
 Пакет абсолютно неработоспособен -- перед удалением его
 следует переустановить.
При обработке следующих пакетов произошли ошибки:
 adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)
Не удалось установить пакет. Попытка восстановить:
Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях... Готово
Инициализация состояний пакетов... Готово
Запись информации расширенных состояний... Готово
Чтение описаний задач... Готово



[debian sid] Что-то сломал, и не могу удалить пакет adobe-flashplugin

Сегодня утром точно такое же знакомому фиксил на бегу.

Скачал с оффсайта корявый пакет?

Просто sudo dpkg -i kak-on-tam.deb && sudo aptitude purge adobe-flashplugin

Если не помогло - правишь ручками prerm файл, дописав exit 0 в начало файла.

Как-то так.

t184256 ★★★★★ ()

[debian sid] Что-то сломал, и не могу удалить пакет adobe-flashplugin

> Пакет абсолютно неработоспособен — перед удалением его

следует переустановить.

намекает, что именно так.

t184256 ★★★★★ ()

[debian sid] Что-то сломал, и не могу удалить пакет adobe-flashplugin

Так пробовал же.


sudo dpkg -i ./install_flash_player_10_linux.deb
[sudo] password for georg:
Выбор ранее не выбранного пакета adobe-flashplugin.
(Чтение базы данных ... на данный момент установлено 142283 файлов и каталогов.)
Подготовка к замене пакета adobe-flashplugin 10.0.32.18-1 (используется файл .../install_flash_player_10_linux.deb) ...
update-alternatives: error: нет альтернатив для iceape-flashplugin.
update-alternatives: error: нет альтернатив для iceape-flashplugin.
dpkg: предупреждение: старый сценарий pre-removal возвратил код ошибки 2
dpkg: попытка использовать сценарий из нового пакета ...
update-alternatives: error: нет альтернатив для iceape-flashplugin.
update-alternatives: error: нет альтернатив для iceape-flashplugin.
dpkg: не удалось обработать параметр ./install_flash_player_10_linux.deb (--install):
 подпроцесс новый сценарий pre-removal возвратил код ошибки 2
postinst called with argument `abort-upgrade'
dpkg: ошибка при очистке -
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
При обработке следующих пакетов произошли ошибки:
 ./install_flash_player_10_linux.deb


правишь ручками prerm файл

Можно подробнее?

ShTH ()

[debian sid] Что-то сломал, и не могу удалить пакет adobe-flashplugin

Ну у меня нет никаких флешей, но в чем сейчас проблема - у каждого пакета есть скрипт, который исполняется перед удалением, в твоем случае это /var/lib/dpkg/info/adobe-flashplugin.

В идеале надо разобраться, что в нем неправильно выполняется и пофиксить. В реале достаточно же вставить перед проблемным куском (читай в самом начале) строку 'exit 0'. Тогда с точки зрения dpkg скрипт выполнился успешно и проблема устранена. Но скрипт-то тот был не зря и хвосты за ним в идеале еще подчистить надо ручками.

Удачи.

t184256 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.