LINUX.ORG.RU

Установка 1C. Не хватает GLIBC


0

0

Установка 1C (rpm пакеты) на Fedora Core 6 идет нормально (как i386 так и x86_64).

На Fedora11x86_64 1Cx86_64 тоже ставится.

При попытке установить на Fedora11x86_64 1Ci386 ошибки:

libc.so.6 нужен для 1C_Enterprise-common-8.1.14-72.i386 libc.so.6(GLIBC_2.0) нужен для 1C_Enterprise-common-8.1.14-72.i386 libc.so.6(GLIBC_2.1) нужен для 1C_Enterprise-common-8.1.14-72.i386 libc.so.6(GLIBC_2.1.2) нужен для 1C_Enterprise-common-8.1.14-72.i386 libc.so.6(GLIBC_2.1.3) нужен для 1C_Enterprise-common-8.1.14-72.i386 libc.so.6(GLIBC_2.2) нужен для 1C_Enterprise-common-8.1.14-72.i386 libc.so.6(GLIBC_2.2.3) нужен для 1C_Enterprise-common-8.1.14-72.i386 libc.so.6(GLIBC_2.3) нужен для 1C_Enterprise-common-8.1.14-72.i386 libdl.so.2 нужен для 1C_Enterprise-common-8.1.14-72.i386 libdl.so.2(GLIBC_2.0) нужен для 1C_Enterprise-common-8.1.14-72.i386 libdl.so.2(GLIBC_2.1) нужен для 1C_Enterprise-common-8.1.14-72.i386 libgcc_s.so.1 нужен для 1C_Enterprise-common-8.1.14-72.i386 libgcc_s.so.1(GCC_3.0) нужен для 1C_Enterprise-common-8.1.14-72.i386 libgcc_s.so.1(GCC_3.3) нужен для 1C_Enterprise-common-8.1.14-72.i386 libgcc_s.so.1(GLIBC_2.0) нужен для 1C_Enterprise-common-8.1.14-72.i386 libm.so.6 нужен для 1C_Enterprise-common-8.1.14-72.i386 libm.so.6(GLIBC_2.0) нужен для 1C_Enterprise-common-8.1.14-72.i386 libm.so.6(GLIBC_2.1) нужен для 1C_Enterprise-common-8.1.14-72.i386 libpthread.so.0 нужен для 1C_Enterprise-common-8.1.14-72.i386 libpthread.so.0(GLIBC_2.0) нужен для 1C_Enterprise-common-8.1.14-72.i386 libpthread.so.0(GLIBC_2.1) нужен для 1C_Enterprise-common-8.1.14-72.i386 libpthread.so.0(GLIBC_2.2) нужен для 1C_Enterprise-common-8.1.14-72.i386 librt.so.1 нужен для 1C_Enterprise-common-8.1.14-72.i386 librt.so.1(GLIBC_2.2) нужен для 1C_Enterprise-common-8.1.14-72.i386

Нашел на pbone.net

glibc-2.0.7-32.i386.rpm glibc-2.1.3-23.i386.rpm

Пытался их установить, но устанавливаются только с --nodeps (и --force кажется)

После этого перестаёт работать rpm

Подскажите пожалуйста что и как нужно доставить?

Установка 1C. Не хватает GLIBC

> glibc-2.0.7-32.i386.rpm glibc-2.1.3-23.i386.rpm
> Пытался их установить, но устанавливаются только с --nodeps (и --force кажется)

> После этого перестаёт работать rpm


1000 и 1 способ угробить линух, способ №436 :) glibc уже была, а ты её перезаписал другой, несовместимой версией.

anonymous ()

Установка 1C. Не хватает GLIBC

> Подскажите пожалуйста что и как нужно доставить?

А пакетов 1C, рассчитанных на более новую систему, нет?

anonymous ()
Ответ на: Установка 1C. Не хватает GLIBC от anonymous

Установка 1C. Не хватает GLIBC

Ставлю самую последнюю версию 1C. Существует только один дистрибутив 1C под любые(на которые сможет поставиться) линуксы.

На Fedora 10 та же ошибка. Более старые дистрибутивы линукса не ставятся на моё новое железо.

AndreyCherkasky ()

Установка 1C. Не хватает GLIBC

Попробуй:

Распакуй пакеты с нужными файлами куда-нибудь, а потом пробуй LD_PRELOAD="<glibc траляля>" сам 1С

linux4ever ()
Ответ на: Установка 1C. Не хватает GLIBC от linux4ever

Установка 1C. Не хватает GLIBC

Фееричный костыль, учитывая что этих либ полтора десятка нужно будет. LD_LIBRARY_PATH надо исправлять.

tensai_cirno ★★★★★ ()

Установка 1C. Не хватает GLIBC

Используй CentOS и не парь мозг. Там точно встанет и простоит ещё лет пять со всеми апдейтами.

Lumi ★★★★★ ()

Установка 1C. Не хватает GLIBC

А что 1С наконецто портировали?

static ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.