LINUX.ORG.RU

E: Internal Error, Could not perform immediate configuration (2) on libc6


0

0

Использую дистрибутив Runtu 2.0.1. Имеются две проблеммы. 1)Не могу скачась с интернета ни одну прогу. Что бы я ни качал пишет "E: Internal Error, Could not perform immediate configuration (2) on libc6" использовал следующие репозитории "# Stable: deb http://se.archive.ubuntu.com/ubuntu intrepid main restricted deb http://se.archive.ubuntu.com/ubuntu intrepid universe multiverse deb http://security.ubuntu.com/ubuntu intrepid-security main restricted deb http://security.ubuntu.com/ubuntu intrepid-security universe multiverse

deb http://se.archive.ubuntu.com/ubuntu intrepid-updates main restricted deb http://se.archive.ubuntu.com/ubuntu intrepid-updates universe multiverse deb http://se.archive.ubuntu.com/ubuntu intrepid-backports main restricted deb http://se.archive.ubuntu.com/ubuntu intrepid-backports universe multiverse

# proposed - unstable #deb http://se.archive.ubuntu.com/ubuntu intrepid-proposed main restricted #deb http://se.archive.ubuntu.com/ubuntu intrepid-proposed multiverse universe

## Source based install, mostly unnecessary #deb-src http://se.archive.ubuntu.com/ubuntu intrepid main restricted #deb-src http://se.archive.ubuntu.com/ubuntu intrepid universe multiverse #deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted #deb-src http://security.ubuntu.com/ubuntu intrepid-security universe multiverse # #deb-src http://se.archive.ubuntu.com/ubuntu intrepid-updates main restricted #deb-src http://se.archive.ubuntu.com/ubuntu intrepid-updates universe multiverse #deb-src http://se.archive.ubuntu.com/ubuntu intrepid-backports main restricted #deb-src http://se.archive.ubuntu.com/ubuntu intrepid-backports universe multiverse" репозитории конечно от убунту но и на рунту должны работать под рутом я ни разу не заходил и не делал ничего неправельного

2)клавиатура не печатает русскую точку и запятую а вместо них "/""?" соответственно, мне как-то надоело менять раскладку когда нужно точку напечатать.

Если кто что может посоветовать напишите, но пишите пожалуйста поподробнее, что нажимать или печатать т.к. линукс у меня неделю всего лишь стоит и я только учусь.

Re: E: Internal Error, Could not perform immediate configuration (2) on libc6

> Что бы я ни качал пишет "E: Internal Error, Could not perform immediate configuration (2) on libc6"

Сообщение с ошибкой вылетает до того как пакет скачивается, или после (когда пытается его установить)? Потому что гугл говорит что это происходит чаще всего именно во время попытки установить пакет, а не во время скачивания. Можешь лог кинуть?

drull ★☆☆☆ ()

Re: E: Internal Error, Could not perform immediate configuration (2) on libc6

> 2)клавиатура не печатает русскую точку и запятую а вместо них "/""?" соответственно, мне как-то надоело менять раскладку когда нужно точку напечатать.

ну я так понимаю что надо переназначить клавиши через xmodmap

drull ★☆☆☆ ()

Re: E: Internal Error, Could not perform immediate configuration (2) on libc6

Что касается точки в русской раскладке — нужно включить вариант раскладки winkeys. Как это делается через xorg.conf — я помню ("us,ru(winkeys)" в XkbLayout либо ",winkeys" в XkbVariant), но у вас скорее всего это сделано через какую-нибудь дребедень типа hal.

nnz ★★★★ ()

Re: E: Internal Error, Could not perform immediate configuration (2) on libc6

nikita@nikita-desktop:~$ sudo apt-get install keep [sudo] password for nikita: Чтение списков пакетов... Готово Построение дерева зависимостей Reading state information... Готово Следующие пакеты были установлены автоматически но более не требуются: libopenexr2c2a libtalloc1 libarchive1 libparted1.8-9 libsnmp15 libconvert-asn1-perl libdjvulibre21 smbldap-tools libbtctl4 libnet-ssleay-perl cupsddk libbeagle1 compiz-wrapper libarts1-akode ubuntu-system-service libunicode-maputf8-perl libx11-xcb1 libgvfscommon0 libsoup2.4-1 libnet-ldap-perl pptp-linux libcdio7 policykit libcrypt-smbhash-perl guile-1.8-libs libelf1 libakode2 libexempi3 libgmp3c2 python-imaging libdigest-md4-perl libijs-0.35 libunicode-map-perl perl-suid libpolkit-gnome0 python-usb libpoppler3 libpolkit-dbus2 libcanberra-gtk0 libbluetooth3 libwbclient0 vpnc cupsddk-drivers libcdio-paranoia0 libunicode-string-perl libcanberra0 libxklavier12 libgucharmap7 libjcode-pm-perl libio-socket-ssl-perl openvpn python-cupshelpers evolution-data-server-common libpolkit-grant2 libopenobex1 libltdl7 libdigest-sha1-perl libunicode-map8-perl Используйте команду 'apt-get autoremove' для их удаления. Будут установлены следующие дополнительные пакеты: acpi-support apt apt-utils aptitude compiz-wrapper consolekit cups-bsd cups-client cups-common cupsddk cupsddk-drivers cupsys-bsd cupsys-client cupsys-common dbus dbus-x11 doc-base dpkg dpkg-dev evolution-data-server-common findutils gconf2-common gdebi-core gtk2-engines-pixbuf guile-1.8-libs hplip-data kdelibs-data kdelibs4c2a libarchive1 libarts1c2a libartsc0 libasound2 libatspi1.0-0 libbeagle1 libbluetooth3 libc6 libc6-dev libc6-i686 libcairo-perl libcairo2 libcairomm-1.0-1 libcanberra-gtk0 libcanberra0 libcdio-paranoia0 libcdio7 libck-connector0 libcups2 libcupsimage2 libcwidget3 libdatrie0 libdb4.6 libdb4.7 libdebian-installer4 libdigest-md4-perl libdigest-sha1-perl libdjvulibre21 libelf1 libept0 libexempi3 libgadu3 libgcrypt11 libgdiplus libgdl-1-0 libgdl-1-common libgif4 libglib-perl libglib2.0-0 libglib2.0-cil libglibmm-2.4-1c2a libgmp3c2 libgnome-keyring0 libgnome-menu2 libgnome2-canvas-perl libgnomecanvas2-0 libgnomecups1.0-1 libgnomeprint2.2-0 libgnomeprint2.2-data libgnomeui-common libgnutls26 libgs8 libgtk2-perl libgtk2.0-0 libgtkhtml2-0 libgtkmm-2.4-1c2a libgucharmap7 libgutenprint2 libgvfscommon0 libhal1 libhtml-parser-perl libijs-0.35 libilmbase6 libkrb53 liblaunchpad-integration1 liblocale-gettext-perl libltdl7 libmldbm-perl libmono-corlib1.0-cil libmono-corlib2.0-cil libmono-data-tds2.0-cil libmono-security2.0-cil libmono-sqlite2.0-cil libmono-system-data2.0-cil libmono-system-web2.0-cil libmono-system1.0-cil libmono-system2.0-cil libmono0 libmono2.0-cil libnautilus-extension1 libncurses5 libncursesw5 libnet-dbus-perl libnet-ssleay-perl libnss3-1d libopenexr6 liborbit2 libpango1.0-0 libpango1.0-common libpangomm-1.4-1 libparted1.8-9 libperl5.10 libpixman-1-0 libpolkit-dbus2 libpolkit-gnome0 libpolkit-grant2 libpolkit2 libpoppler3 libpopt0 libpurple0 librsync1 libselinux1 libsilc-1.1-2 libsnmp-base libsnmp15 libsoup2.4-1 libsqlite0 libsqlite3-0 libssl0.9.8 libtalloc1 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libtimedate-perl libungif4g libunicode-map-perl libunicode-map8-perl libunicode-string-perl libuuid-perl libvte9 libwbclient0 libwnck22 libx11-xcb1 libxapian15 libxcb-render-util0 libxcb-render0 libxcb1 libxi6 libxklavier12 libxml-parser-perl lsb-base lzma mono-common mono-gac mono-jit mono-runtime perl perl-base perl-modules perl-suid pidgin-data policykit python-apt python-central python-cups python-cupshelpers python-imaging python-support python-usb rdiff-backup splix synaptic tzdata ubuntu-system-service util-linux util-linux-locales x11-apps x11-session-utils x11-utils x11-xfs-utils x11-xkb-utils x11-xserver-utils xbase-clients xinit xutils Предлагаемые пакеты: apt-doc aptitude-doc-en aptitude-doc debtags kdeprint gtklp cups-pt xpp debian-keyring libasound2-plugins glibc-doc manpages-dev libcwidget-dev djvulibre-desktop rng-tools monodoc-gtk2.0-manual gnutls-bin libgtk2-perl-doc gutenprint-locales krb5-doc krb5-user libgda2-3 libmono-winforms2.0-cil libmono-winforms1.0-cil ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp libparted1.8-dev libparted1.8-i18n tcl8.4 tk8.4 xapian-tools iso-cods libterm-readline-gnu-perl libterm-readline-perl-perl policykit-gnome python-apt-dbg python-imaging-doc python-imaging-dbg dwww deborphan Рекомендуемые пакеты: libparse-debianchangelog-perl libpam-ck-connector cups libcanberra-gtk-module libglib2.0-data libfreezethaw-perl libmono-i18n1.0-cil libmono-i18n2.0-cil ca-certificates libpurple-bin python-pylibacl python-pyxattr apt-xapian-index

nihttoter ()

Re: E: Internal Error, Could not perform immediate configuration (2) on libc6

Пакеты, которые будут УДАЛЕНЫ: alacarte appres aptoncd apturl bitmap bluez-cups bluez-gnome brasero bug-buddy capplets-data compiz compiz-gnome contact-lookup-applet cups-pdf cupsys cupsys-driver-gutenprint deskbar-applet editres eog evince fast-user-switch-applet file-roller firefox-gnome-support foomatic-db-hpijs fstobdf gcalctool gconf-editor gconf2 gdebi gdm gdm-themes gedit gksu gnochm gnome-about gnome-app-install gnome-applets gnome-applets-data gnome-bluetooth gnome-btdownload gnome-commander gnome-control-center gnome-games gnome-games-data gnome-keyring-manager gnome-media gnome-media-common gnome-mount gnome-netstatus-applet gnome-nettool gnome-orca gnome-panel gnome-panel-data gnome-pilot gnome-pilot-conduits gnome-power-manager gnome-screensaver gnome-session gnome-spell gnome-system-monitor gnome-system-tools gnome-terminal gnome-terminal-data gnome-user-guide gnome-utils gnome-volume-manager gparted gstreamer0.10-gnomevfs gstreamer0.10-plugins-good gthumb gtkhtml3.14 gucharmap hal-cups-utils hal-device-manager hpijs hplip hwdb-client-gnome iceauth libbonoboui2-0 libcamel1.2-10 libcompizconfig-backend-gconf libcupsys2 libdeskbar-tracker libebook1.2-9 libecal1.2-7 libedata-book1.2-2 libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8 libeel2-2 libegroupwise1.2-13 libexchange-storage1.2-3 libgail-common libgail-gnome-module libgail18 libgconf2-4 libgconf2.0-cil libgdl-gnome-1-0 libgksu2-0 libgnome-desktop-2 libgnome-media0 libgnome-vfs2.0-cil libgnome-window-settings1 libgnome2-0 libgnome2-common libgnome2-perl libgnome2-vfs-perl libgnome2.0-cil libgnomebt0 libgnomekbd-common libgnomekbd1 libgnomekbdui1 libgnomeui-0 libgnomevfs2-0 libgnomevfs2-bin libgnomevfs2-common libgnomevfs2-extra libgtkhtml2.0-cil libgtkhtml3.14-19 libgtkhtml3.8-15 libgucharmap6 liblpint-bonobo0 libmetacity0 libpanel-applet2-0 libperl5.8 libtotem-plparser7 listres metacity metacity-common nautilus nautilus-cd-burner nautilus-data nautilus-gksu nautilus-open-terminal nautilus-sendto nautilus-wallpaper network-manager-gnome network-manager-openvpn network-manager-pptp network-manager-vpnc notification-daemon oclock onboard pidgin python-gconf python-gnome2 python-gnome2-desktop python-gnome2-extras rhythmbox runtu-default-settings samba screenlets seahorse sessreg smproxy software-properties-gtk sound-juicer soundconverter startupmanager thunderbird-gnome-support tomboy totem totem-gstreamer totem-mozilla tracker-search-tool ubiquity ubiquity-frontend-gtk ubufox ubuntu-docs update-manager update-notifier viewres vino x11perf xbiff xcalc xclipboard xclock xconsole xcursorgen xditview xdpyinfo xdriinfo xev xeyes xfd xfontsel xgamma xgc xhost xkbutils xkill xload xlogo xlsatoms xlsclients xlsfonts xmag xman xmessage xmodmap xmore xprop xrandr xrdb xrefresh xrgb xset xsetmode xsetpointer xsetroot xsm xstdcmap xtrap xvidtune xvinfo xwd xwininfo xwud yelp НОВЫЕ пакеты, которые будут установлены: compiz-wrapper cups-bsd cups-client cups-common cupsddk cupsddk-drivers dbus-x11 evolution-data-server-common guile-1.8-libs keep libarchive1 libbeagle1 libbluetooth3 libcanberra-gtk0 libcanberra0 libcdio-paranoia0 libcdio7 libck-connector0 libcups2 libcwidget3 libdb4.6 libdb4.7 libdjvulibre21 libelf1 libept0 libexempi3 libgdiplus libgif4 libgmp3c2 libgnutls26 libgucharmap7 libgvfscommon0 libijs-0.35 libilmbase6 liblaunchpad-integration1 libltdl7 libmldbm-perl libnss3-1d libopenexr6 libpangomm-1.4-1 libparted1.8-9 libperl5.10 libpixman-1-0 libpolkit-dbus2 libpolkit-gnome0 libpolkit-grant2 libpolkit2 libpoppler3 librsync1 libsilc-1.1-2 libsnmp15 libsoup2.4-1 libsqlite0 libtalloc1 libtimedate-perl libuuid-perl libwbclient0 libx11-xcb1 libxapian15 libxcb-render-util0 libxcb-render0 libxcb1 libxklavier12 lzma policykit python-cupshelpers python-imaging python-usb rdiff-backup ubuntu-system-service x11-apps x11-session-utils x11-utils x11-xfs-utils x11-xkb-utils x11-xserver-utils Пакеты, которые будут обновлены: acpi-support apt apt-utils aptitude consolekit cupsys-bsd cupsys-client cupsys-common dbus doc-base dpkg dpkg-dev findutils gconf2-common gdebi-core gtk2-engines-pixbuf hplip-data kdelibs-data kdelibs4c2a libarts1c2a libartsc0 libasound2 libatspi1.0-0 libc6 libc6-dev libc6-i686 libcairo-perl libcairo2 libcairomm-1.0-1 libcupsimage2 libdatrie0 libdebian-installer4 libdigest-md4-perl libdigest-sha1-perl libgadu3 libgcrypt11 libgdl-1-0 libgdl-1-common libglib-perl libglib2.0-0 libglib2.0-cil libglibmm-2.4-1c2a libgnome-keyring0 libgnome-menu2 libgnome2-canvas-perl libgnomecanvas2-0 libgnomecups1.0-1 libgnomeprint2.2-0 libgnomeprint2.2-data libgnomeui-common libgs8 libgtk2-perl libgtk2.0-0 libgtkhtml2-0 libgtkmm-2.4-1c2a libgutenprint2 libhal1 libhtml-parser-perl libkrb53 liblocale-gettext-perl libmono-corlib1.0-cil libmono-corlib2.0-cil libmono-data-tds2.0-cil libmono-security2.0-cil libmono-sqlite2.0-cil libmono-system-data2.0-cil libmono-system-web2.0-cil libmono-system1.0-cil libmono-system2.0-cil libmono0 libmono2.0-cil libnautilus-extension1 libncurses5 libncursesw5 libnet-dbus-perl libnet-ssleay-perl liborbit2 libpango1.0-0 libpango1.0-common libpopt0 libpurple0 libselinux1 libsnmp-base libsqlite3-0 libssl0.9.8 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl libungif4g libunicode-map-perl libunicode-map8-perl libunicode-string-perl libvte9 libwnck22 libxi6 libxml-parser-perl lsb-base mono-common mono-gac mono-jit mono-runtime perl perl-base perl-modules perl-suid pidgin-data python-apt python-central python-cups python-support splix synaptic tzdata util-linux util-linux-locales xbase-clients xinit xutils обновлено 118, установлено 76 новых пакетов, для удаления отмечено 220 пакетов, и 858 пакетов не обновлено. Необходимо скачать 0B/100MB архивов. После распаковки объем занятого дискового пространства уменьшится на 525MB. Хотите продолжить [Д/н]? д E: Internal Error, Could not perform immediate configuration (2) on libc6 nikita@nikita-desktop:~$

он какое-то время качал, а потом написа "E: Internal Error, Could not perform immediate configuration (2) on libc6", я попробовал повторить "$ sudo apt-get install keep" на этот раз уже не качал. как я понял архивы он скачал и сохранил вот сдесь "/var/cache/apt/archives/" но распаковать не может. там и лежит преславутая libc6. вот адрес странички в которой говорится об этом "http://onorua.in.ua/archives/category/unix" но в отличии от них, я ничего не обновлял.

nihttoter ()

Re: E: Internal Error, Could not perform immediate configuration (2) on libc6

проблему с клавиатурой излечил при помощи этого скрипта: "nikita@nikita-desktop:~$ setxkbmap -layout us,ru -option grp:caps_toggle,grp_led:scroll -variant ,winkeys"

nihttoter ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.