LINUX.ORG.RU

samba 3.0, проблемы с LinNeighborhood


0

0

RH9. Обновил самбу до 3.0, rpm'ы брал с RawHide. Samba 3 не хочет распознавать параметры character set и client code page в smb.conf, но это мелочи: у меня и без них всё прекрасно работает с русскими именами. Хуже то, что теперь не работает LinNeighborhood 0.6.5 (самокомпилированный уже после апгрейда самбы). Сеть сканирует нормально, но при попытке смонтировать ресурс выдаёт окошечко с "Can't resolve address". В логи, зараза, ничего не пишет. Командой "mount -t smbfs" всё по-прежнему прекрасно монтируется, так что проблема не жизненно важная. Но - всё равно неприятно. Кстати, демонтирует LinNeighborhood нормально - я имею в виду, те шары, которые через mount были привинчены. Пробовал колдовать с его настройками - без особого успеха.

# rpm -qa|grep samba samba-3.0.0-15 samba-common-3.0.0-15 redhat-config-samba-1.1.1-1 samba-client-3.0.0-15

★★★

samba 3.0, проблемы с LinNeighborhood

Сам уже разобрался. Он пытается в строке монтирования указать ip машины, но вычислить сам ip почему-то не в состоянии. Поэтому получается белиберда в стиле

smbmount network_path mount_point -o username=name,password=password,fmask=644,dmask=755,uid=0,gid=0,ip=,debug=0

Разумеется, при виде "ip=," mount начинает тошнить.
Пришлось ковырять smbmount.c и забивать там на фиг все ip=%s
Может, оно и медленнее от этого работает, но зато хоть вообще работает, а не плюётся без толку :)

yozhhh ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.