LINUX.ORG.RU

Проблема с обновлением Fedora 11 + rpm-fusion: «Error: Missing Dependency».


0

0

Установлена Russian Fedora 11. Пытаюсь обновить и получаю (началось сегодня утром):

# yum update
Loaded plugins: fastestmirror, presto, refresh-packagekit, remove-with-leaves
Loading mirror speeds from cached hostfile
 * fedora: mirror.svk.su
 * rpmfusion-free: download1.rpmfusion.org
 * rpmfusion-free-updates: download1.rpmfusion.org
 * rpmfusion-nonfree: download1.rpmfusion.org
 * rpmfusion-nonfree-updates: download1.rpmfusion.org
 * russianfedora-fixes: updates.msiu.ru
 * russianfedora-fixes-updates: updates.msiu.ru
 * russianfedora-free: updates.msiu.ru
 * russianfedora-free-updates: updates.msiu.ru
 * russianfedora-nonfree: updates.msiu.ru
 * russianfedora-nonfree-updates: updates.msiu.ru
 * updates: mirror.svk.su
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package kmod-VirtualBox-OSE-2.6.29.6-217.2.8.fc11.x86_64.x86_64 0:3.0.4-2.fc11.3 set to be updated
--> Processing Dependency: VirtualBox-OSE-kmod-common >= 3.0.4 for package: kmod-VirtualBox-OSE-2.6.29.6-217.2.8.fc11.x86_64-3.0.4-2.fc11.3.x86_64
--> Finished Dependency Resolution
kmod-VirtualBox-OSE-2.6.29.6-217.2.8.fc11.x86_64-3.0.4-2.fc11.3.x86_64 from rpmfusion-free-updates has depsolving problems
  --> Missing Dependency: VirtualBox-OSE-kmod-common >= 3.0.4 is needed by package kmod-VirtualBox-OSE-2.6.29.6-217.2.8.fc11.x86_64-3.0.4-2.fc11.3.x86_64 (rpmfusion-free-updates)
Error: Missing Dependency: VirtualBox-OSE-kmod-common >= 3.0.4 is needed by package kmod-VirtualBox-OSE-2.6.29.6-217.2.8.fc11.x86_64-3.0.4-2.fc11.3.x86_64 (rpmfusion-free-updates)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

И вот тут я начинаю что-то не понимать: откуда взялось "---> Package kmod-VirtualBox-OSE-2.6.29.6-217.2.8.fc11.x86_64.x86_64 0:3.0.4-2.fc11.3 set to be updated", если kmod-VirtualBox-OSE у меня не установлен? Вместо него стоит akmod-VirtualBox-OSE:

# rpm -qi kmod-VirtualBox-OSE
пакет kmod-VirtualBox-OSE не установлен

# rpm -qi akmod-VirtualBox-OSE
Name        : akmod-VirtualBox-OSE         Relocations: (not relocatable)
Version     : 3.0.2                             Vendor: RPM Fusion
Release     : 1.fc11                        Build Date: Срд 15 Июл 2009 21:04:22
Install Date: Пнд 24 Авг 2009 11:49:24      Build Host: fusionbuilder64
Group       : System Environment/Kernel     Source RPM: VirtualBox-OSE-kmod-3.0.2-1.fc11.src.rpm
Size        : 6067                             License: GPLv2 or CDDL
Signature   : RSA/8, Чтв 16 Июл 2009 13:49:55, Key ID ad2708448fcff4da
Packager    : <http://nonfree.rpmfusion.org/>
URL         : http://www.virtualbox.org/wiki/VirtualBox
Summary     : Akmod package for VirtualBox-OSE kernel module(s)
Description :
This package provides the akmod package for the VirtualBox-OSE kernel modules.
Почему yum решил обновить неустановленный пакет?

Так же непонятна причина поломанной зависимости. Это я что-то сделал не так или проблема на зеркале (частично обновилось? у мейнтейнера руки не из плеч? что-то другое?).

Прошу помощи у знатоков Fedora.

Deleted

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

Так, проблема с пропавшей зависимостью похоже была из-за зеркала, т.к. сейчас всё исправилось. Но осталось непонятным, откуда взялась зависимость от kmod? Теперь пытаются "обновиться" не только kmod-VirtualBox-OSE, но и kmod-nvidia. Причём и то и то у меня стоит в версии akmod, т.е. они пересобираются автоматически при обновлении ядра.

Как посмотреть, что именно их тащит по зависимости или почему их так хочет поставить yum? И почему они идут как update, а не install, ведь они _не_установлены_ в системе?!

$ sudo yum upgrade
Loaded plugins: fastestmirror, presto, refresh-packagekit, remove-with-leaves
Loading mirror speeds from cached hostfile
 * fedora: mirror.svk.su
 * rpmfusion-free: download1.rpmfusion.org
 * rpmfusion-free-updates: download1.rpmfusion.org
 * rpmfusion-nonfree: download1.rpmfusion.org
 * rpmfusion-nonfree-updates: download1.rpmfusion.org
 * russianfedora-fixes: updates.msiu.ru
 * russianfedora-fixes-updates: updates.msiu.ru
 * russianfedora-free: updates.msiu.ru
 * russianfedora-free-updates: updates.msiu.ru
 * russianfedora-nonfree: updates.msiu.ru
 * russianfedora-nonfree-updates: updates.msiu.ru
 * updates: mirror.svk.su
Setting up Upgrade Process
Resolving Dependencies
--> Running transaction check
---> Package VirtualBox-OSE.x86_64 0:3.0.4-3.fc11 set to be updated
---> Package VirtualBox-OSE-guest.x86_64 0:3.0.4-3.fc11 set to be updated
---> Package VirtualBox-OSE-kmodsrc.x86_64 0:3.0.4-3.fc11 set to be updated
---> Package akmod-VirtualBox-OSE.x86_64 0:3.0.4-2.fc11 set to be updated
---> Package gstreamer-plugins-bad.x86_64 0:0.10.13-6.fc11 set to be updated
--> Processing Dependency: libmimic.so.0()(64bit) for package: gstreamer-plugins-bad-0.10.13-6.fc11.x86_64
---> Package gstreamer-plugins-ugly.x86_64 0:0.10.12-2.fc11 set to be updated
--> Processing Dependency: libopencore-amrwb.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.12-2.fc11.x86_64
--> Processing Dependency: libopencore-amrnb.so.0()(64bit) for package: gstreamer-plugins-ugly-0.10.12-2.fc11.x86_64
---> Package kmod-VirtualBox-OSE-2.6.29.6-217.2.8.fc11.x86_64.x86_64 0:3.0.4-2.fc11.3 set to be updated
---> Package kmod-nvidia-2.6.29.6-217.2.8.fc11.x86_64.x86_64 0:185.18.14-1.fc11.6 set to be updated
--> Running transaction check
---> Package libmimic.x86_64 0:1.0.4-3.fc11 set to be updated
---> Package opencore-amr.x86_64 0:0.1.1-1.fc11 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================
 Package                                   Арх.    Версия              Repository                  Size
========================================================================================================
Updating:
 VirtualBox-OSE                            x86_64  3.0.4-3.fc11        rpmfusion-free-updates      41 M
 VirtualBox-OSE-guest                      x86_64  3.0.4-3.fc11        rpmfusion-free-updates     5.5 M
 VirtualBox-OSE-kmodsrc                    x86_64  3.0.4-3.fc11        rpmfusion-free-updates     350 k
 akmod-VirtualBox-OSE                      x86_64  3.0.4-2.fc11        rpmfusion-free-updates      10 k
 gstreamer-plugins-bad                     x86_64  0.10.13-6.fc11      rpmfusion-free-updates     1.2 M
 gstreamer-plugins-ugly                    x86_64  0.10.12-2.fc11      rpmfusion-free-updates     361 k
 kmod-VirtualBox-OSE-2.6.29.6-217.2.8.fc11.x86_64
                                           x86_64  3.0.4-2.fc11.3      rpmfusion-free-updates     199 k
 kmod-nvidia-2.6.29.6-217.2.8.fc11.x86_64  x86_64  185.18.14-1.fc11.6  rpmfusion-nonfree-updates  3.1 M
Installing for dependencies:
 libmimic                                  x86_64  1.0.4-3.fc11        rpmfusion-free-updates      31 k
 opencore-amr                              x86_64  0.1.1-1.fc11        rpmfusion-free-updates     171 k

Transaction Summary
========================================================================================================
Install      2 Package(s)         
Update       8 Package(s)         
Remove       0 Package(s)         

Total download size: 52 M
Выполнить [y/N]: n
Exiting on user Command
Complete!

Deleted ()

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

Читай updated как installed. У меня в последнее время тоже никогда installed не говорит.
А так сейчас сам пытаюсь поставить virtualbox, а у них под моё ядро нет kmod-а.

Оно, кстати, обновилось. 30 в updates-testing.

Breton ()

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

> А так сейчас сам пытаюсь поставить virtualbox, а у них под моё ядро нет kmod-а.

Для этого федоровцы изобрели akmod'ы. Там устанавливается скрипт, который при загрузке системы проверяет наличие скомпилированных модулей под текущее ядро, и если модулей нет, то он их пересобирает. У меня стоят akmod'ы с драйвером nvidia и модулями virtualbox. Это мне и непонятно: зачем кроме установленных akmod'ов yum пытается поставить ещё и обычные уже собранные kmod'ы. В чём смысл?

Deleted ()

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

По правде говоря,rpmfusion странно работает. У меня иногда пытается что-то вытащить из директории для 10 федоры (/testing/10/i386/), хотя у меня 11.

Breton ()

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

У меня вот на что ругается:

Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package ktorrent.i586 0:3.2.3-1.fc11 set to be updated
--> Processing Dependency: kdelibs4(x86-32) >= 4.3.00 for package: ktorrent-3.2.3-1.fc11.i586
--> Finished Dependency Resolution
ktorrent-3.2.3-1.fc11.i586 from updates has depsolving problems
--> Missing Dependency: kdelibs4(x86-32) >= 4.3.00 is needed by package ktorrent-3.2.3-1.fc11.i586 (updates)
Error: Missing Dependency: kdelibs4(x86-32) >= 4.3.00 is needed by package ktorrent-3.2.3-1.fc11.i586 (updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest


test* не подключены

wdtae ()

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

Аналогичное починилось переустановкой пакетов rpmfusion-ской конфигурации или чисткой кеша или отключением -rawhide и -testing. Что именно -- не помню уже.

DonkeyHot ★★★★★ ()

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

> если kmod-VirtualBox-OSE у меня не установлен? Вместо него стоит akmod-VirtualBox-OSE:

akmod собирает и устанавливает kmod по необходимости. так-то.

другое дело - зачем у вас akmod? вы пользуетесь левыми ядрами или сидите на rawhide?

atrus ★★★★★ ()

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

> Это мне и непонятно: зачем кроме установленных akmod'ов yum пытается поставить ещё и обычные уже собранные kmod'ы. В чём смысл?

Затем что akmod - это спасательный круг. Он просто пытается собрать пакет под неизвестное ядро. А вдруг для стабильности нужны какие-то патчи? akmod этого не знает. Поэтому его пакеты менее приоритетны, чем собранные под контролем разработчиков.

Если считаете, что akmod вам хватит, то заэкслудьте соответсвующий kmod в конфигах yum.

atrus ★★★★★ ()

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

> akmod собирает и устанавливает kmod по необходимости. так-то.

Разве? Я думал, что akmod при загрузке просто распаковывает исходники, собирает и копирует модуль ведра в /lib/modules, без заворачивания в rpm-пакеты.

> другое дело - зачем у вас akmod? вы пользуетесь левыми ядрами или сидите на rawhide?


Ни то, ни другое. Просто в прошлые выходные, когда я ставил федору, kmod'ы зависели от более старого ядра, чем то, которое установилось (ставил с подключенным интернетом и сразу включенными репозиториями с обновлениями). Так что не было выбора =).

Deleted ()

Re: Проблема с обновлением Fedora 11 + rpm-fusion: "Error: Missing Dependency".

> Затем что akmod - это спасательный круг. Он просто пытается собрать пакет под неизвестное ядро. А вдруг для стабильности нужны какие-то патчи? akmod этого не знает. Поэтому его пакеты менее приоритетны, чем собранные под контролем разработчиков.

Теперь более-менее понятно, но всё равно такая логика мне непривычна 8).

> Если считаете, что akmod вам хватит, то заэкслудьте соответсвующий kmod в конфигах yum.


Да ладно, пусть уж стоят. Только один вопрос: при следующем обновлении ядра, если мейнтейнеры rpmfusion не успеют обновить под него kmod'ы, будет ли yum ругаться на неудовлетворённые зависимости при обновлении?

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.