LINUX.ORG.RU

Проблемы...


0

0

Такая вот фигня:
у меня rh9 ,не могу настроить нормально русский язык.
Перечитал много обсуждений этой проблемы но так и не решил ее :(
Хочу оставить utf-8,переключать раскладку ВЕЗДЕ через shift+alt(на крайняк ctrl+shift).
Проблемы такие:
1)В kde не работает нормальная раскладка.На русский переключается через ctrl+alt+k,
а обратно вообще не получилось.Поменять не удалось
2)поствил fluxbox 0.1.14 --там в меню configure все пункты кроме antialias -пустые,
точно также на главной панели какие-то пункты не видны.
Добавил пункт в меню с русскими буквами -- он прекрасно появился.
Пробовал менять шрифт в стиле на -cronyx-helvetica-medium-r-normal--12-*-*-*-*-*-koi8-r
-тоже самое
Названия рабочих столов тоже на русском.
Там-же в xterme вообще никак на русский не переключается...
Вот мои конф-файлы:
/etc/sysconfig/i18n

LANG="ru_RU.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en:ru_RU.UTF-8:ru_RU:ru"
SYSFONT="latarcyrheb-sun16"

/etc/sysconfig/keyboard

KEYBOARDTYPE="pc"
KEYTABLE="ua-utf"

и кусок из /etc/X11/XF86Config

Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "en-ru"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"

Заранее благодарен.

Re: Проблемы...

попробуй в /etc/X11/XF86Config

Option "XkbLayout" "us, ru" 

должно заработать =)





anonymous ()

Re: Проблемы...

блин простегал столько раз правил его,даже не заметил благодарю ,но вторая проблема осталсь: насчет меню во fluxbox'е а также в xterme при переключении на русский место букв идут пробелы и еще вспомнил одну проблему --как примонтировать fat раздел с учетом utf,всмысле iocharset и codepage?

Greencasper ()

Re: Проблемы...

mount -t vfat -o codepage=866,iocharset=utf8,umask=0000 /dev/hda1 /mnt/win_c

wildhoney ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.