LINUX.ORG.RU

Не работает apt


0

0

Блин, не могу поставить ни одну программу -

user@debian:~$ sudo aptitude install lynx
[sudo] password for user: 
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Чтение информации о состоянии... Готово
Чтение информации о расширенных состояниях       
Инициализация состояний пакетов... Готово          
Запись информации расширенных состояний... Готово
Чтение описаний задач... Готово                                         
Следующие НОВЫЕ пакеты будут установлены:
  lynx lynx-cur{a} 
0 пакетов обновлено, 2 установлено новых, 0 пакетов отмечено для удаления, и 1 пакетов не обновлено.
Необходимо получить 0B архивов. После распаковки 4518kB будет занято.
Хотите продолжить? [Y/n/?] y
E: Не удалось обнаружить файл пакета fglrx-driver. Это может означать, что вам придётся вручную исправить этот пакет.
Запись информации расширенных состояний... Готово
E: Не удалось обнаружить файл пакета fglrx-driver. Это может означать, что вам придётся вручную исправить этот пакет.
E: Внутренняя ошибка: не удалось создать список пакетов для загрузки
Но я хз как вручную исправить пакет. Что скажете?

Ответ на: Re: Не работает apt от Lumi

Re: Не работает apt

Чтение списков пакетов... Готово
Построение дерева зависимостей
Чтение информации о состоянии... Готово
Пакеты, которые будут УДАЛЕНЫ:
fglrx-driver
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
После данной операции, объём занятого дискового пространства уменьшится на 36,4MB.
Хотите продолжить [Д/н]? y
(Чтение базы данных... на данный момент установлено 149128 файлов и каталогов.)
Удаляется пакет fglrx-driver...
Нет отклонения `diversion of /usr/lib/libGL.so.1 to /usr/lib/fglrx/diversions/libGL.so.1 by fglrx-driver', ничего не удалено
Нет отклонения `diversion of /usr/lib/libGL.so.1.2 to /usr/lib/fglrx/diversions/libGL.so.1.2 by fglrx-driver', ничего не удалено
rmdir: failed to remove `/usr/lib/fglrx/diversions': Каталог не пуст
rmdir: failed to remove `/usr/lib/fglrx': Каталог не пуст
Удаляется `diversion of /usr/lib/xorg/modules/extensions/libdri.so to /usr/lib/fglrx/diversions/libdri.so by fglrx-driver'
dpkg-divert: переименование вызовет перезапись `/usr/lib/xorg/modules/extensions/libdri.so'
другим файлом `/usr/lib/fglrx/diversions/libdri.so', что не разрешено
dpkg: не удалось обработать параметр fglrx-driver (--remove):
подпроцесс post-removal script возвратил код ошибки 2
При обработке следующих пакетов произошли ошибки:
fglrx-driver
E: Sub-process /usr/bin/dpkg returned an error code (1)

alg0rythm ()
Ответ на: Re: Не работает apt от alg0rythm

Re: Не работает apt

Правь руками /var/lib/dpkg/status: в районе "Package: fglrx-driver" "Status" меняешь на 'install ok installed' если пакет все еще нужен, если нет, то просто удаляешь секцию и входящие в пакет файлы.

as33 ★☆☆ ()
Ответ на: Re: Не работает apt от alg0rythm

Re: Не работает apt

> Все также. Я уже не знаю, что делать.

echo "#!/bin/sh"> /var/lib/dpkg/info/fglrx-driver.postrm, хоть это и грязный хак.

Потом придётся сделать aptitude reinstall libgl1-mesa-glx.

И советую сообщить о баге при удалении (через reportbug).

gaa ★★ ()
Ответ на: Re: Не работает apt от err0r

Re: Не работает apt

> очисть кэш apta. я правда не помню где.. но найдешь гуглем. ну а потом apt-get update и тд

/var/cache/apt . Но это в данном случае не поможет.

gaa ★★ ()
Ответ на: Re: Не работает apt от gaa

Re: Не работает apt

Вот так правильнее:

echo "#!/bin/sh"> /var/lib/dpkg/info/fglrx-driver.postrm, хоть это и грязный хак.

dpkg --purge --force-all fglrx-driver

Потом придётся сделать aptitude reinstall libgl1-mesa-glx.

gaa ★★ ()

Re: Не работает apt

Всем спасибо за помощь!

alg0rythm ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.