LINUX.ORG.RU

2.6.0-test1 и framebuffer


0

0

Всем доброго времени суток. Скомпилял ядро 2.6.0-test1 с CONFIG_FB=y CONFIG_FB_VESA=y в конфиге лило опции ядру append="hdd=ide-scsi video=vesafb:mtrr,ywrap" при этом после загрузки никаким фреймбуфером в консоли даже не пахнет. Что я делаю неправильно?

anonymous

Re: 2.6.0-test1 и framebuffer

Установить режим VESA пробовал? Например, для 1024х768@16bpp пропиши vga=0x317 в lilo.conf (не в append).

rihad ()

Re: 2.6.0-test1 и framebuffer

Если не сработает, video mode selection support тоже ключи в ядре.

rihad ()

Re: 2.6.0-test1 и framebuffer

режим установлен, vga=791 (что соответствует 1024*768*16) - буду пробовать. 10х anyway

anonymous ()

Re: 2.6.0-test1 и framebuffer

нда. iptables умерли, НАТ перестал работать, пересборка iptables не идёт :) откатился на 2.4.21-ck3

anonymous ()

Re: Интервью с разработчиками OpenBSD

>Всем доброго времени суток. Скомпилял ядро 2.6.0-test1 с CONFIG_FB=y >CONFIG_FB_VESA=y в конфиге лило опции ядру append="hdd=ide-scsi >video=vesafb:mtrr,ywrap" при этом после загрузки никаким фреймбуфером в >консоли даже не пахнет. Что я делаю неправильно?

Забыл вкомпилять консоль ? ;)

CONFIG_FRAMEBUFFER_CONSOLE=y


Проверь еще вот на предмет вот этого 

> CONFIG_VT=y
> CONFIG_VT_CONSOLE=y
> CONFIG_FB=y
> CONFIG_FB_VESA=y
> CONFIG_VIDEO_SELECT=y
> CONFIG_VGA_CONSOLE=y
ну и до кучи
> CONFIG_LOGO=y
> CONFIG_LOGO_LINUX_MONO=y
> CONFIG_LOGO_LINUX_VGA16=y
> CONFIG_LOGO_LINUX_CLUT224=y


PS: пока что у 2.6.0 конфигурялка с изгибами ;)

пользуй oldconfig, он вроде бы работал ...

sS ★★★★★ ()

Re: 2.6.0-test1 и framebuffer

iptables живее всех живых, кстати.
Только вчера собрал это ядро.
Вот nscd....

jackill ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.