LINUX.ORG.RU

pulseaudio-9999.ebuild


0

0

Помогите кто умеет писать ебилды, нужет такой-вот live ebuild.Пробовал сам сделать не получилось. В обычном ебилде заменил SRC_URI на EGIT_REPO_URI="bla_bla", в inherit eutils libtool autotools flag-o-matic git autotools.
Вылетает на
* git update start -->
* repository: git://0pointer.de/pulseaudio.git
* local clone: /usr/portage/distfiles/git-src/pulseaudio
* committish: master
>>> Unpacked to /var/tmp/portage/media-sound/pulseaudio-9999/work/pulseaudio-9999
* Running eautoreconf in '/var/tmp/portage/media-sound/pulseaudio-9999/work/pulseaudio-9999' ...
* Running aclocal ... [ ok ]
* Running libtoolize --copy --force --install --automake ... [ ok ]
* Running aclocal ... [ ok ]
* Running autoconf ... [ ok ]
* Running autoheader ... [ ok ]
* Running automake --add-missing --copy --foreign ... [ !! ]

* Failed Running automake !
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/media-sound/pulseaudio-9999/temp/automake-22944.out

*
* ERROR: media-sound/pulseaudio-9999 failed.
* Call stack:
* ebuild.sh, line 49: Called src_unpack
* environment, line 3029: Called eautoreconf
* environment, line 989: Called eautomake
* environment, line 963: Called autotools_run_tool 'automake' '--add-missing' '--copy' '--foreign'
* environment, line 456: Called die
* The specific snippet of code:
* die "Failed Running $1 !";
* The die message:
* Failed Running automake !

less /var/tmp/portage/media-sound/pulseaudio-9999/temp/automake-22944.out
***** automake *****
***** automake --add-missing --copy --foreign

configure.ac:87: installing `./compile'
configure.ac:440: required file `./config.rpath' not found
configure.ac:32: installing `./missing'
src/Makefile.am:149: foreach f,$(PREOPEN_LIBS: non-POSIX variable name
src/Makefile.am:149: (probably a GNU make extension)
src/Makefile.am:151: foreach f,$(PREOPEN_LIBS: non-POSIX variable name
src/Makefile.am:151: (probably a GNU make extension)
src/Makefile.am: installing `./depcomp'

anonymous

Re: pulseaudio-9999.ebuild

С этим разобрался-тупо вписал в
src_unpack()
перед eautoreconf
elibtoolize

touch config.rpath

зато теперь другая трабла
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for LIBSNDFILE... yes
checking for LIBSPEEX... configure: error: Package requirements ( speexdsp >= 1.2 ) were not met:

No package 'speexdsp' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables LIBSPEEX_CFLAGS
and LIBSPEEX_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.