LINUX.ORG.RU

Глюк с раскладками. Не переключаются.


0

0

Странно, по каким-то причинам с клавиатуры (по нажатию комбинаций клавиш) не переключается раскладка.

Настраивал так:

Центр управления - Региональные и специальные возможности - Раскладка клавиатуры - Параметры ХКВ - Использовать переключатели ХКВ - Layout switching - Ctrl+Shift.

В строке команда отображается:
setxkbmap -option -option grp:lctrl_lshift_toggle,grp:ctrl_shift_toggle

В чем может быть проблема?

★★★

Re: Глюк с раскладками. Не переключаются.

P.S. Когда тыкаю на значок флага в трее, то раскладка переключается. Дистр - Mandriva 2008 Spring. Какие бы комбинации не выбирал, все равно такая конитель.

VirRaa ★★★ ()

Re: Глюк с раскладками. Не переключаются.

Ооо, нашел. Дело в том, что при нажатии Shift+Ctrl раскладка переключается, но вот при последовательном нажатии Ctrl+Shift - не работает =)

VirRaa ★★★ ()

Re: Глюк с раскладками. Не переключаются.

проверь в xorg.conf

Section "ServerFlags"
Option "AutoAddDevices" "false"
EndSection

или отключи Driver "evdev", откатись на Driver "kdb"

см. http://bbs.archlinux.org/viewtopic.php?id=44311

anonymous ()

Re: Глюк с раскладками. Не переключаются.

раскладка меняется не когда отпускаешь кнопки, а когда нажимаешь, это эпический баг. Плюс хоткеи в русской раскладке (так что лучше поставить например правый win на eng на время нажатия, и жать хоткеи вместе с правым win (в FF3 пофиксили, но в других приложениях могло остаться))

anonymous ()
Ответ на: Re: Глюк с раскладками. Не переключаются. от anonymous

Re: Глюк с раскладками. Не переключаются.

> раскладка меняется не когда отпускаешь кнопки, а когда нажимаешь, это эпический баг.

В Fedora этого эпического бага почему-то не было.

VirRaa ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.