LINUX.ORG.RU

нужно чтобы scp не запрашивал пароль для ввода


0

0

Всем привет. Подскажите как сделать, чтобы scp команда не требовала ввода пароля руками.

Я пробовал сгенерить rsa ключи,закрытый оставил в месте куда я буду копировать, а открытый -откуда буду вызывать scp команду. но он всё равно спрашивает пароль. ещё пробовал echo 'пароль' | и далее scp команда. не помогает.

заранее, спасибо за помощь.

Re: нужно чтобы scp не запрашивал пароль для ввода

>закрытый оставил в месте куда я буду копировать, а открытый -откуда буду вызывать scp команду

все наоборот. .pub надо засунуть в authorized-keys на удаленной машине.

И настрой запуск ssh-agent вместе с сессией.

http://www.gatsby.ucl.ac.uk/~iam23/compnotes/passwordless_ssh.html

anonymous ()

Re: нужно чтобы scp не запрашивал пароль для ввода

ssh-copy-id user@host

anonymous ()

Re: нужно чтобы scp не запрашивал пароль для ввода

то есть правильно ли я понял:

1сначало я делаю ssh-keygen -t rsa 2далее копирую pub key на компьютер, куда с помощью scp буду копировать данные. только уже переименнованный в authorized_keys. 3потом scp -p -r -i~/public_html/.ssh/identity ./index.txt логин@хост:~/public_html/?

sniper-9 ()

Re: нужно чтобы scp не запрашивал пароль для ввода

Сделал всё как в статье: В результате после коннекта по ssh вот что появилось на экране:

The authenticity of host 'host.net (195.42.160.18)' can't be established. RSA1 key fingerprint is e8:25:ca:77:40:e3:7e:01:9d:b8:2b:2c:78:36:1d:69. Are you sure you want to continue connecting (yes/no)? yes Warning: Permanently added 'host.net,195.42.160.18' (RSA1) to the list of known hosts.

и дальше опять начал спрашивать пароль..

при генерации ключа нажимаю только enter

может что нить не так?

sniper-9 ()

Re: нужно чтобы scp не запрашивал пароль для ввода

OpenSSH_3.6.1p2, SSH protocols 1.5/2.0, OpenSSL 0x0090707f debug1: Reading configuration data /etc/ssh/ssh_config debug1: Applying options for * debug1: Rhosts Authentication disabled, originating port will not be trusted. debug1: Connecting to shaman.dataforce.net [195.42.160.5] port 22. debug1: Connection established. debug1: identity file /home/clients/bgsk/.ssh/identity type -1 debug1: identity file /home/clients/bgsk/.ssh/id_rsa type -1 debug1: identity file /home/clients/bgsk/.ssh/id_dsa type -1 debug1: Remote protocol version 1.99, remote software version OpenSSH_3.6.1p2 debug1: match: OpenSSH_3.6.1p2 pat OpenSSH* debug1: Local version string SSH-1.5-OpenSSH_3.6.1p2 debug1: Waiting for server public key. debug1: Received server public key (768 bits) and host key (1024 bits). debug1: Host host.net' is known and matches the RSA1 host key. debug1: Found key in /home/clients/bgsk/.ssh/known_hosts:1 debug1: Encryption type: blowfish debug1: Sent encrypted session key. debug1: Installing crc compensation attack detector. debug1: Received encrypted confirmation. debug1: Doing challenge response authentication. debug1: No challenge. debug1: Doing password authentication.

вот такая информация отображается в случае ssh коннекта с атрибутом -v

sniper-9 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.