LINUX.ORG.RU

Проблема с Flash в Opera


0

0

Поздравляю всех с окончанием тяжелого для печени периода.
Назрел вопрос. У меня Arch, opera 9.23. Поставил флэш плагин 9, но что то не работает. Вот что вываливается в терминал:

[m1rag3@darkstar ~]$ opera
ERROR: ld.so: object 'libjvm.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libawt.so' from LD_PRELOAD cannot be preloaded: ignored.

(process:5802): GLib-GObject-CRITICAL **: gtype.c:2242: initialization assertion failed, use IA__g_type_init() prior to this function

(process:5802): Gtk-CRITICAL **: gtk_clipboard_get_for_display: assertion `GDK_IS_DISPLAY (display)' failed
Adobe Flash Player: gtk_clipboard_get(GDK_SELECTION_PRIMARY); failed. Trying to call gtk_init(0,0);
[m1rag3@darkstar ~]$


Помогите разобраться пожалуйста в чем тут дело. Заранее спасибо!

★★

Re: Проблема с Flash в Opera

может надо запустить оперу с LD_PRELOAD="/путь к библиотеке libawt" а саму библиотеку найти findом

fury3 ()

Re: Проблема с Flash в Opera

как поставил расскажешь, или нам самим придумывать?

в /usr/lib/opera/plugins/ что лежит? и что в конфиге оперы по поводу плагина написано?

maloi ★★★★★ ()

Re: Проблема с Flash в Opera

Насколько мне известно, отвалился флеш в опере после обновления. Ставьте 9.5 бета - там работает.

Greshnik ()

Re: Проблема с Flash в Opera

packman -S gnash ;)

asc ()

Re: Проблема с Flash в Opera

pacman -S firefox

asc ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.