LINUX.ORG.RU

Ubuntu 7.10 не ставиться build-essential


0

0

Обновился на 7.10 - поотваливалось все нафиг, WiFi карта, 
разрешение экрана, выход на TV, менеджер проприет. драйверов...
Грузиться в 2 раза дольше. Косяк на косяке вообщем.

Снес всю систему, поставил 7,10 на чистый винт - такая 
же ерунда. На кой так рано выпустили 7.10 ??? 8(

Самое смешное что даже g++ поставить не получается!!!

$ sudo apt-get install build-essential 
Чтение списков пакетов... Готово
Построение дерева зависимостей       
Reading state information... Готово                       
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.

Так как вы просили выполнить только одну операцию, то вероятнее всего, что
пакет просто не может быть установлен из-за ошибок в самом пакете.
Необходимо послать отчёт об этой ошибке.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
  build-essential: Зависит: libc6-dev но он не будет установлен или
                                   libc-dev
                   Зависит: g++ (>= 4:4.1.1) но он не будет установлен
E: Сломанные пакеты


Вот мой sources.list
$ cat /etc/apt/sources.list

deb http://ru.archive.ubuntu.com/ubuntu/ gutsy main restricted
deb http://ru.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
deb http://ru.archive.ubuntu.com/ubuntu/ gutsy universe
deb http://ru.archive.ubuntu.com/ubuntu/ gutsy-updates universe
deb http://ru.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
deb http://ru.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb http://archive.canonical.com/ubuntu gutsy partner
deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb http://security.ubuntu.com/ubuntu gutsy-security universe
deb http://security.ubuntu.com/ubuntu gutsy-security multiverse

Re: Ubuntu 7.10 не ставиться build-essential

Попробуй вместо apt-get использовать aptitude

LokiAs2 ()
Ответ на: Re: Ubuntu 7.10 не ставиться build-essential от LokiAs2

Re: Ubuntu 7.10 не ставиться build-essential

Не помогло. Делал так: sudo aptitude install libc6-dev поругался на то что будет установлена старая версия ну а затем sudo apt-get install build-essential

Не нравиться мне что то этот релиз...

coderinside ()
Ответ на: Re: Ubuntu 7.10 не ставиться build-essential от coderinside

Re: Ubuntu 7.10 не ставиться build-essential

Ты явно чего-то с зависимостями не асиливаешь.
1. Запускаешь aptitude. Просто sudo aptitude безо всяких опций.
2. Смотришь какие пакеты от каких зависят.
3. Думаешь что надо обновлять, чтобы установить нужную тебе версию нужного пакета.

Совершенно несложная логическая задачка, честное слово.

root_at_localhost ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.