LINUX.ORG.RU

xsane запускается только под рутом


0

0

сканер Mustek 2448TA PLUS и Ubuntu

работал, после перезагрузки перестало запускаться

я новичок ... под обычным юзером пишет: Segmentation fault (core dumped)

Запустил в gdb: user@kredit:~$ gdb xsane GNU gdb 6.6-debian Copyright (C) 2006 Free Software Foundation, Inc. GDB is free software, covered by the GNU General Public License, and you are welcome to change it and/or distribute copies of it under certain conditions. Type "show copying" to see the conditions. There is absolutely no warranty for GDB. Type "show warranty" for details. This GDB was configured as "i486-linux-gnu"... (no debugging symbols found) Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1". (gdb) run Starting program: /usr/bin/xsane (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) [Thread debugging using libthread_db enabled] [New Thread -1219909952 (LWP 5652)] (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) ---Type <return> to continue, or q <return> to quit--- (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) ---Type <return> to continue, or q <return> to quit--- (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found)

Program received signal SIGSEGV, Segmentation fault. [Switching to Thread -1219909952 (LWP 5652)] 0xb7137bf5 in ?? () from /usr/lib/libmfp.so

Что это за ошибка?

anonymous

Re: xsane запускается только под рутом

незнаю. попробуй chmod -R 666 /dev/usb*

скорее всего

scyld ()

Re: xsane запускается только под рутом

Обновись, заработает.

Gharik ()
Ответ на: Re: xsane запускается только под рутом от dn2010

Re: xsane запускается только под рутом

Смысл в том, что некогда мастеки законтрибутили спеки на ряд своих моделей, включая ту что в топике, и по сих скрижалям доблестные перцы из опенсорц-комьюнити наваяли модуль. Но как известно альфа без сегфолтов - не альфа, модуль получился ужасно кривой в начальных версиях, а в одном из последних sane-backends его пофиксили.

Gharik ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.