LINUX.ORG.RU

Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне!


0

0

Всем привет! Не так давно в генте "стабилизировались" дрова для нвидии сотой версии, в которой поддержки моей любимой видюхи нету! :'(
Я поставил nvidia-legacy-drivers (7184) и увидел страшные глюки:
Битность стала принудительно 8, при нажатии на рамку окна kwin сразу умирает, при нажатии Alt+Ctrl+F1 вместо консоли вижу кучу раноцветных квадратиков!!!
С версией 8776 таких глюков нет!
Хотелось бы заставить работать версию дровов 7184, но если это не возможно, то скажите, как сделать так, чтобы у меня принудительно стояла версия 8776 и при обновлении emerge не намеревался поставить более новую...
Всем большое спасибо! :)

Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне!

Почитать про portage.

GeForce4 MX 440 поддерживается и 9755, в которых есть Texture From Pixmap, нужные для берила и компиза.

Deleted ()
Ответ на: Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне! от LordZero

Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне!

>Мне нах не сдался компиз с берилом...

Не очень понятно, зачем так отвечать человеку, который тебе сообщает последнюю версию подходящего для твоей видеокарточки драйвера.

По теме. Сделать что-то вроде

emerge =x11-drivers/nvidia-drivers-1.0.9755-r1

религия не позволяет?

genmaxxx ()
Ответ на: Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне! от kostian

Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне!

>могу ошибаться но вроде для mx440 дрова 1.0.963*. по крайней мере у меня 1.0.9639

Я в своем примере полагался на информацию Dimez. Лезть и проверять как-то лень. Я думаю, автор ветки догадается циферки по своему желанию подставить.

genmaxxx ()
Ответ на: Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне! от kostian

Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне!

Да, Вы правы:

http://us.download.nvidia.com/XFree86/Linux-x86/1.0-9755/README/appendix-a.html

.......................................................
The 1.0-96xx driver supports the following set of GPUs:
NVIDIA chip name 	Device PCI ID
.......................................................
GeForce4 MX 440 	0x0171
.......................................................

genmaxxx ()
Ответ на: Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне! от genmaxxx

Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне!

Значит, нужно сделать

emerge =x11-drivers/nvidia-drivers-1.0.9639

и замаскировать все версии выше этой:

echo '>x11-drivers/nvidia-drivers-1.0.9639' >> /etc/portage/package.mask

genmaxxx ()
Ответ на: Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне! от genmaxxx

Re: Genoo, nvidia-legacy-drivers и gf4mx-440: Я в западне!

О чёрт, не промотал на автомате абзац-дополнение про 96хх. Всем сорри. Действительно, 9636 последняя версия

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.