LINUX.ORG.RU

Russian lyx


0

0

Хочу набирать диплом в Lyx version 1.1.6 fix 2, Suse 7.3 По-русски с горем пополам LyX запечатал, но когда переключаешся на английский (стандартной комбинацией клавиш которой в других приложениях тоже пользуюсь), то по английски не печатает. Все шрифты и раскладки клавиатур вродебы установлены. Причем даже по-русски не ставит запятые, точки и прочее. Suse свежеустановленный, ничего не менял не перенастраивал. МОжет кто сталкивался с такой проблемой и знает как бороться? Отвечать лучше по почте.

Заранее спасибо, serjik@ac-sw.com Sergey Lukichev

anonymous

Re: Russian lyx

У него внутренние keyboardmap (lyx/kbd/*). Можно выбрать 2 (в Edit/Preferences). Переключаться M-k-1 M-k-2. Чтоб точки и тд печатались добавь в lyx/kbd/koi8-r.kmap строчки
\kmap \& \.
\kmap \^ \,
\kmap \* \;
\kmap \% \:
\kmap \@ \"
\kmap \~ \?
(те Shift+7 (&) будет точкой и тд)

geekkoo

anonymous ()

Re: Russian lyx

Недавно на www.softtera.ru было 2 статьи про LyX - все подробно объяснено. Поищи.

Norder ()

Re: Russian lyx

А еще проще - использовать хакерскую раскладку (динамически подключается из xruskb) - проверенно, хотя LyX и "правильное" приложение, но неправильная раскладка в нем - как родная.

gennik ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.