LINUX.ORG.RU

devel-пакет от GStreamer в archlinux

 ,


0

1

Добрый вечер всем!

а кто общался с Archlinux? вещь в себе, нужно сказать, но занятная :)

в целом интересует вопрос, как побороть такую беду:

configure: error: 
      You need to install or upgrade the GStreamer development
      packages on your system. On debian-based systems these are
      libgstreamer1.0-dev; on RPM-based systems gstreamer1.0-devel.
      The minimum version required is 1.0.0.


'sudo sudo pacman -S gstreamer' делал, но, видимо, нужны dev-пакеты...

Ответ на: комментарий от arax

хочу собрать https://github.com/stefanpartheym/archlinux-ipu6-webcam
но ./install.sh обрывается на поиске gstreamer'a

metawishmaster ★★★★★
() автор топика
Последнее исправление: metawishmaster (всего исправлений: 1)
Ответ на: комментарий от metawishmaster

Выглядит как какой-то жуткий колхоз, а что пакеты intel-ipu6* из AUR не работают?
Их вроде обновляют, что обычно является признаком работоспособности.

arax ★★
()
Последнее исправление: arax (всего исправлений: 1)
Ответ на: комментарий от krasnh

В install.sh прописаны gst-plugin-pipewire gst-plugins-good, может дело в них?

сейчас попробую их удалить, а devel-пакеты все, оказывается, на месте:

sbauer@archlinux ~/devel/archlinux-ipu6-webcam main$ pkg-config --cflags --libs gstreamer-1.0
-I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sysprof-4 -pthread -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 
sbauer@archlinux ~/devel/archlinux-ipu6-webcam main$ ls /usr/include/gstreamer-1.0 
gst

metawishmaster ★★★★★
() автор топика
mesa-1:23.1.7-1-x86_64.pkg.tar.zst failed to download

error: failed retrieving file 'mesa-1:23.1.7-1-x86_64.pkg.tar.zst' from mirror.cspacehostings.com : The requested URL returned error: 404
error: failed retrieving file 'mesa-1:23.1.7-1-x86_64.pkg.tar.zst' from mirror.osbeck.com : The requested URL returned error: 404
error: failed retrieving file 'mesa-1:23.1.7-1-x86_64.pkg.tar.zst' from mirror.ubrco.de : The requested URL returned error: 404
...

судя по логам у тебя не с gstreamer проблемы, а с репами. Актуальная меса сейчас 23.1.8

Lrrr ★★★★
()