LINUX.ORG.RU

Ответ на: комментарий от antianon

Это все выпилили давно или сломали.

У меня арч и плазма, установлен штатный kdesu. Пробовал и напрямую спокойно запустить, умвр.
Запустил скрипт запуска виртуалки (где он не прописан напрямую) и вылезло окошко «Требуется аутентификация - Агент PolicyKit1 от KDE» того самого kdesu с текстом «System policy prevents management of local virtualized systems» «Приложение пытается выполнить действие, которое требует дополнительных привелегий. Требуется аутентификация.».
Так что у меня всё работает и так, и так, я даже не копался и не настраивал системную политику, хотя можно.

fehhner ★★★★★ ()
Последнее исправление: fehhner (всего исправлений: 3)
Ответ на: комментарий от fehhner

Я слышал, что kdesu сломали в апстриме и только в Сусе патчами починили. gksu выпилили в дебиане 10 и убунте 18.04
https://packages.debian.org/search?keywords=gksu
https://packages.ubuntu.com/search?keywords=gksu
Но у меня в ALT p9 он есть. Судя по всему он есть в Mageia (gksu-polkit: command line utility to run programs as root, оно?). А в Сусе тоже официально нет https://software.opensuse.org/package/gksu

antianon ()