LINUX.ORG.RU

На что намекает лог сборки?

 


0

1

/usr/lib64/qt5/bin/qdbusxml2cpp: relocation error: /usr/lib64/libQt5DBus.so.5: symbol _ZN14QMetaCallEventC2EttPFvP7QObjectN11QMetaObject4CallEiPPvEPKS0_iiPiS5_P10QSemaphore version Qt_5_PRIVATE_API not defined in file libQt5Core.so.5 with link time reference

Пытаюсь промёржить =app-editors/kile-2.9.93::gentoo

На что намекает лог сборки?

На то, что тебе нужно наконец-то перестать заниматься ерундой и поставить бинарный дистрибутив.

Если серьезно, то ошибка намекает на Qt libraries version mismatch. Так что бегом пересобирать весь Qt и про Qt WebEngine не забудь.

EXL ★★★★★ ()
Ответ на: комментарий от EXL

Это принципиально неверный ответ. Я белый и пушстый и виноват быть не могу. Это или портаж должен быть переделан, или в билде зависимости неточно прописаны. Так что другие должны быть действия.

Einstok_Fair ★★☆ ()
$ echo "_ZN14QMetaCallEventC2EttPFvP7QObjectN11QMetaObject4CallEiPPvEPKS0_iiPiS5_P10QSemaphore" | c++filt 
QMetaCallEvent::QMetaCallEvent(unsigned short, unsigned short, void (*)(QObject*, QMetaObject::Call, int, void**), QObject const*, int, int, int*, void**, QSemaphore*)
fluorite ★★★★★ ()
Ответ на: комментарий от fluorite
# qfile libQt5Core.so.5
dev-qt/qtcore: /usr/lib64/libQt5Core.so.5
# emerge -pv qtcore
[ebuild   R    ] dev-qt/qtcore-5.14.2:5/5.14.2::gentoo  USE="icu systemd -debug -old-kernel -test" 0 KiB

Einstok_Fair ★★☆ ()
Ограничение на отправку комментариев: только для зарегистрированных пользователей