LINUX.ORG.RU

# a2enmod php (или как его там)

# service apache2 restart

а вообще хз чего ты там накрутил - пхпмайадмин всегда нормпльно встает.

рассказывай как ставил и куда залезть успел.

deep-purple ★★★★★ ()
Последнее исправление: deep-purple (всего исправлений: 1)
Ответ на: комментарий от vvediteima

Набери в гугле «Как включить модуль php в apache?». Он тебе выдаст инструкцию, почитай, потыкай, посмотри, что он тебе напишет. Скорее всего это решит твою проблему.

Zhbert ★★★★★ ()
Ответ на: выдало это от vvediteima

Ясна...

Слуш, а может быть ну его нахрен этот пыхозашквар? М? Давай, вон, в сишечку, по человечески...

Ну-ка, дружок, лови (класный учебничек чтобы въехать, не то что все эти пыхофорумы с советами от васянов): http://www.opennet.ru/docs/RUS/zlp/

deep-purple ★★★★★ ()
Ответ на: комментарий от deep-purple

когда то же самое делаю на phpmyadmin весь код высвечивается красным, но в определенном месте он не красный. После этого момента как раз и показывается то что высвечивается при обычном просмотре

vvediteima ()

Есть идея.

У кого установлен phpmyadmin, зайдите на него, нажмите ctrl+U, скопируйте, короче код файла /usr/share/phpmyadmin/index.php и отправьте мне vk.com/vvediteima . Похоже там ошибка.

vvediteima ()
Ответ на: Вот скрины от vvediteima

Re: Вот скрины

Не подключен php к апачу. Ищи, где ошибся.

Подключение пхп к апачу состоит из трёх вещей:

  1. установка самого модуля к апачу (libapache2_php вроде, нет deb10 под рукой)

  2. подключение модуля в конфиге

  3. объяснение, чем php-файлы обрабатываеются.

Всё. Где там накосячить можно - непонятно.

anonymous ()

Когда набираю sudo a2enmod php7.3 выводит Considering dependency mpm_prefork for php7.3: Considering conflict mpm_event for mpm_prefork: ERROR: Module mpm_event is enabled - cannot proceed due to conflicts. It needs to be disabled first! Considering conflict mpm_worker for mpm_prefork: ERROR: Could not enable dependency mpm_prefork for php7.3, aborting

vvediteima ()