LINUX.ORG.RU

тормоза при выключении машины


0

0

SlackWare 10.2, kernel 2.6.13 (из коробки), КДЕ 3.4.2  отмазка конечно такая не канает, но действительно раньше работало (года полтора наверное) все нормально, а теперь при выключении непонятки. Говорю выключить компьютер - в ответ тишина. Говорю еще раз выключить (хоть сразу хоть через пару минут). Либо тишина в ответ, либо закрывается несколько приложений и опять же в ответ тишина. После третьего (иногда после второго раза) может пойти на выключение, а может и вообще перестать отвечать на нажатия клавиш и мышки, хотя при этом спокойно может играть музыка или выполняться любое из приложений. В логах (ни у X ни в системных) ничего подозрительного нет. Если повалить X через Ctrl+Alt+Bspase - X валятся, но не востанавливаются (у меня настроенно на запуск init 4). Если после того, как повалил Х нажать Ctrl+Alt+Del, то машина перезагружается моментально, без нормального завершения работы. Мож кто сталкивался с таким?

Теперь другой вопрос по поводу ядра. Собрал 2.6.16.27. Все нормально, кроме двух вещей: при попытке собрать дрова под нвидиа получаю 
/NV/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/os-interface.c:1284: error: st
   ructure has no member named `rlim'
   make[4]: *** [/NV/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv/os-interface.o]
   Ошибка 1
   make[3]: *** [_module_/NV/NVIDIA-Linux-x86-1.0-7676-pkg1/usr/src/nv] Ошибка
   2
   make[2]: *** [modules] Ошибка 2
   NVIDIA: left KBUILD.
   nvidia.ko failed to build!
   make[1]: *** [module] Ошибка 1
   make: *** [module] Ошибка 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed.  Please see the file
       '/var/log/nvidia-installer.log' for details.  You may find suggestions
       on fixing installation problems in the README available on the Linux
       driver download page at www.nvidia.com.

лечится ли это обновлением драйвера или как-то по другому?

И еще один косяк со звуком вылез после пересборки - при загрузке драйверов звука (SBLive Value [CT4832], независимо от установок alsamixer звук есть только на левом фронтовом динамике, а на остальных трех тишина. и все как-то хрипит и нормальное качество не могу настроить никак. 
Это у меня руки кривые или как?
★★★

Re: тормоза при выключении машины

А ты как выключаешь ПЭВМ? Посредством K -> Shutdown? Может с кедами проблема?

Пробуй halt, shutdown.

Насчет видео: у меня 7676 на 2.6.хх тоже не собирались. Катай новые дрова. Плюс ко всему 7676 очень древние, коль я не ошибаюсь.

scholz ()
Ответ на: Re: тормоза при выключении машины от scholz

Re: тормоза при выключении машины

> K -> Shutdown? Может с кедами проблема?

похоже что да. Только что делать с этим вопрос

> Пробуй halt, shutdown.

Это выключает нормально, но в таком случае сеанс в КДЕ не сохраняется. А это для меня частенько бывает очень принципиально.

> у меня 7676 на 2.6.хх тоже не собирались. Катай новые дрова. Плюс ко всему

на 2.6.13 они нормально собрались. А вот на 2.6.16.x и 2.6.17 уже отказались. Лан - сейчас новые скачаю.

deys ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.