LINUX.ORG.RU

Некорректное отображение текста в браузере IceCat

 , ,


0

1

В связи с просроченным сертификатом от мозиллы хочу перейти с фаерфокса на браузер IceCat в качестве основного браузера. На данный момент в последней версии IceCat 60.3.0 иногда не корректно отображается текст, вот пример https://b.radikal.ru/b19/1905/db/ce967977c2d5.png пробовал ставить эту же версию браузера на разные дистрибутивы, результат такой же. На данный момент 60.3.0 это единственная версия IceCat с движком Quantum и возвращатся на старый движок не хочу. Я один такой с проблемой отображения текста в браузере или нет? Кто знает как решить данную проблему?

Решения не знаю.

В связи с просроченным сертификатом от мозиллы

Еще вчера починили. Лучше дождись Debian 10 и перейди на Chromium, у него лучший браузерный движок, так же его очень хорошо собирают в Debian. Если все же не нравится Chromium, то советую посмотреть на Palemoon, он более живой и развивающийся.

Deleted ()

Я один такой с проблемой отображения текста в браузере или нет?

Стоит вторым браузером. Проблему не подтверждаю. Кастомные шрифты в настройках отключены.

Yorween ()
Ответ на: комментарий от Deleted

Еще вчера починили

Знаю, а вообще вчера, завтра или сегодня починили, мне по барабану, это очередной гвоздь со стороны мозилы, после которого окончательно решил уйти от этого браузера. Смотрю в сторону IceCat потому что это самый топовый обозреватель от сообщества GNU. То что ты предлагаешь тоже погуглю, но первым делом интересует решение проблем с текстом в IceCat.

MoonSP ()
Ответ на: комментарий от Yorween

Кастомные шрифты в настройках отключены.

У меня тоже дефолтный шрифт стоит DejaVu Sans

MoonSP ()
Ответ на: комментарий от MoonSP

IceCat плох, он отстает по версиям, по безопасности, он просто нужен что бы была версия «GNU Firefox», BolgenOS от мира браузеров.

Deleted ()
Ответ на: комментарий от vasyan

проверь какие растровые шрифты прописал в настройках

Подскажи как это проверить если не сложно.

А вообще скажу что эта проблема лезет у меня на любом дистрибутиве сразу после установки браузера.

MoonSP ()
Ответ на: комментарий от vasyan

летает быстрее огненного

Поставь плагины для отключения JS, рекламы итд в Firefox и будет так же быстро %) Даже быстрее, потому что в новый Firefox завезли Shadow DOM.

Deleted ()
Ответ на: комментарий от vasyan

попробуй явно указать в настройках свои шрифты для кириллицы в advanced меню

У меня кириллицы нету и по этому поводу я только что даже создал новую тему Руссификация браузера IceCat по руссификации IceCat так как с этим траблы.

MoonSP ()
Ответ на: комментарий от vasyan

попробуй явно указать в настройках свои шрифты для кириллицы в advanced меню

А еще прикол в том что в самом advanced меню тоже ломаются шрифты когда перематываю страницу вниз ))

MoonSP ()
Ответ на: комментарий от vasyan

ну вот зайди в Preferences>Fonts&Colors и нажми Advanced, укажи явно для кириллицы везде какой-нибудь DejaVu

Сделал так, нашел кириллицу, поставил DejaVu sans, проблему не решило.

MoonSP ()

А вот и первые перебежчики...

anonymous ()
Ответ на: комментарий от MoonSP

сделай как тут говорят, попробуй отключить все битмапы, парезапусти иксы и если проблема будет решена ищи какой шрифт тебе малину портит

~/.config/fontconfig/conf.d/20-no-embedded.conf

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <match target="font">
    <edit name="embeddedbitmap" mode="assign">
      <bool>false</bool>
    </edit>
  </match>
</fontconfig>

vasyan ()
Ответ на: комментарий от vasyan

сделай как тут говорят, попробуй отключить все битмапы, парезапусти иксы и если проблема будет решена ищи какой шрифт тебе малину портит

Как то сложновато это для меня. Я не знаю что такое битмапы и иксы и даже не понял что конкретно здесь нужно вводить в терминал. Сделал вот это Disable scaling of bitmap fonts

To disable scaling of bitmap fonts (which often makes them blurry), remove /etc/fonts/conf.d/10-scale-bitmap-fonts.conf. шрифты по прежнему корявые. Кстати сказать на этом же компе стоит фаерфокс и в нем никаких багов со шрифтами никогда не было.

MoonSP ()
Ответ на: комментарий от vasyan

сделай как тут говорят, попробуй отключить все битмапы, парезапусти иксы и если проблема будет решена ищи какой шрифт тебе малину портит

~/.config/fontconfig/conf.d/20-no-embedded.conf

<?xml version=«1.0»?> <!DOCTYPE fontconfig SYSTEM «fonts.dtd»> <fontconfig> <match target=«font»> <edit name=«embeddedbitmap» mode=«assign»> <bool>false</bool> </edit> </match> </fontconfig>

И еще, у меня в папке home есть скрытая подпапка .config но дальше папки fontconfig нету, соответственно терминал пишет что нет такого файла или каталога.

MoonSP ()
Ответ на: комментарий от MoonSP

создай эти папки и этот конфиг:

mkdir -p ${HOME}/.config/fontconfig/conf.d/
echo '<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
  <match target="font">
    <edit name="embeddedbitmap" mode="assign">
      <bool>false</bool>
    </edit>
  </match>
</fontconfig>' > ${HOME}/.config/fontconfig/conf.d/20-no-embedded.conf

vasyan ()
Ответ на: комментарий от vasyan

создай эти папки и этот конфиг:

Создал папки и конфиг, в папке /home/User/.config/fontconfig/conf.d появился файл 20-no-embedded.conf после чего запустил IceCat и шрифты снова посыпались как и раньше. Что можешь сказать по этому поводу?

MoonSP ()
Ответ на: комментарий от vasyan

я тебе написал что после перезапустить иксы, если не знаешь что это просто перезапусти комп.

Сорян за невнимательность. Перезапустил после этого комп и шрифты по прежнему некорректные.

MoonSP ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.