LINUX.ORG.RU

GCC linaro toolchain

 ,


0

1

Здравствуйте. скомпилировал тут модуль к ядру. но выдаёт ошибку.

asix: version magic '3.0.36+ mod_unload ARMv5 ' should be '3.0.36+ SMP preempt mod_unload ARMv7 '

Почему gcc linaro компилирует в armv5 как задать в armv7?

Команда компилирования

make M=drivers/net/usb ARCH=arm CROSS_COMPILE=~/gcc-linaro-4.9.4-2017.01-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf- -j4

Ответ на: комментарий от EXL

make include/ ARCH=arm CROSS_COMPILE=~/gcc-linaro-4.9.4-2017.01-x86_64_arm-linux-gnueabihf/bin/arm-linux-gnueabihf- -j4 -march=armv7-a make: invalid option — 'a' make: invalid option — 'c' make: invalid option — '=' make: invalid option — 'a' make: invalid option — '7' make: invalid option — '-' make: invalid option — 'a'

Apophis ()
Ответ на: комментарий от Apophis

Поищи в интернете как там задать CFLAGS для компиляции модулей ядра.

EXL ★★★★★ ()

Судя по архитектуре разговор идёт про android? Так вот под андрюшу ты все делаешь неправильно.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.