LINUX.ORG.RU

Помогите с настройкой curlftpfs, есть пара моментов так сказать

 ,


1

2

Мне нужно было примонтировать ftp, что бы работать с ним как с обычным каталогом: 1. Скачал Curlftpfs

2. Инструкция хорошо гуглилась и я по совету из неё прописал в файле /etc/fstab строку:

 curlftpfs#****user:******@*******.ru /mnt/ftpdir fuse auto,user,uid=1000,allow_other 0 0 

3. Сделал

 mount -a 

4. Был в восторге от того что всё работает... Но не долго

5. Если не вдаваться в детали, вообщем после второго

mount -a
упала такая ошибка:

fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option
fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option

но ftp продолжала работать. И здесь первый вопрос: Как с этим лучше бороться? Я же послушался совету из вывода и добавил в /etc/fstab опцию «nonempty»,вот как это выглядит:

curlftpfs#ftpuser:12345678@repo.safib.ru /mnt/repo.safib.ru fuse auto,user,uid=1000,nonempty,allow_other 0 0

6. Проблема решилась и я стал праздновать победу, но не тут то было...

7. После перезагрузки системы меня встретил такой экран, см скрин : https://drive.google.com/file/d/1lRmtu85GaEPhA15tRDL8nRzCVQFIfbWJ/view?usp=sh...

Строку в fstabe закомменчиваю и ось нормально загружается.

В общем, уважаемые более опытные друзья, у меня только один вопрос, что я делаю не так??)

тебе система белым по черному написала. зачем сюда прибежал?

Anoxemian ★★★★★ ()
Последнее исправление: Anoxemian (всего исправлений: 1 )

поддакну прдедыдущему оратору и немного переведу на человеческий.

fuse: mountpoint is not empty
fuse: if you are sure this is safe, use the 'nonempty' mount option
точка монтирования не пуста т.е. каталог, в который планируется смонтирать удаленную файловую систему не пуст, т.е в нем лежат какие-то данные. при монтировании эти данные скроются содержимым подключенной фс. Если ты считаешь это допустимым используй опцию «nonempty».
откель такое творится - твой смотированный фтп периодически отваливается, после отваливания все записывается в исходную файловую систему - оттого собственно и ругань. если такое поведение считаешь правильным то используй nonempty.

на скрине такое собственно и видно. там удаленка не может примонтироваться и система валится в режим восстановления. либо налаживаешь работу сети для нормального доступа к удаленному фтп, либо настраиваешь fstab чтобы он сиё монтирование считал не сильно важным. или вообще в автомонт превращаешь.

pfg ★★★★★ ()
Ответ на: комментарий от pfg

Спасибо что не поленились описать по подробнее. Но к сожалению у меня слишком мало опыта чтобы сразу понять что к чему, если не сложно можете разжевать еще пару моментов:

Каталог был пуст когда я первый раз делал. И первый раз собственно ошибки и не было. У меня в системе еще сетевые папки примонтированны через цифсутилс, и мной в .bashrc прописано «mount -a», я подумал лишним не будет,типо когда я захожу как суперпользователь оно применяется, и раньше это было незаметно. Я вот не оч понял система говорит что каталог не пустой потому что там уже как бы файлы из ftp чтоль, получается так это работает?

«либо настраиваешь fstab чтобы он сиё монтирование считал не сильно важным. или вообще в автомонт превращаешь.» А можно еще чуть чуть по подробнее по этому вопросу, чтобы хотя бы погуглить было что.

sergei111 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.