LINUX.ORG.RU

Ответ на: комментарий от Deleted

А это называется soname. Сделано для гибкого версионирования.
Когда не меняют API, меняют минорный номер версии, линковка сохраняется.
Когда меняют API, меняют мажорный номер версии, линковка с неправильной библиотекой ломается.
Удобно.

См. https://ru.m.wikipedia.org/wiki/Soname

bormant ★★★★★ ()
Последнее исправление: bormant (всего исправлений: 2)
Ответ на: комментарий от bormant

А если программу устраивают версии библиотеки разных мажорных версий? Например, inkscape из гит и gsl-2.3 и 2.4, либы libgsl.so.19.x и libgsl.so.23.x соответственно. Как понять? Стоит заморачиваться с обходом?

Deleted ()
Ответ на: комментарий от Deleted

Если есть надежда на обратную совместимость несмотря на смену мажорной версии, проще бросить симлинки:

# ln -s libgsl.so.23.x libgsl.so.19.x 
Если будет падать или работать криво, придется положить libgsl.so.19.x рядом (пакетом или просто файлами — не суть).

bormant ★★★★★ ()