LINUX.ORG.RU

tor

 


0

2

Не могу установить tor

cap@debian:~$ torbrowser-launcher
Traceback (most recent call last):
  File "/usr/bin/torbrowser-launcher", line 29, in <module>
    import torbrowser_launcher
  File "/usr/lib/python2.7/dist-packages/torbrowser_launcher/__init__.py", line 33, in <module>
    from .common import Common, SHARE
  File "/usr/lib/python2.7/dist-packages/torbrowser_launcher/common.py", line 55, in <module>
    from twisted.internet import gtk2reactor
  File "/usr/lib/python2.7/dist-packages/twisted/internet/gtk2reactor.py", line 23, in <module>
    from twisted.internet import _glibbase
  File "/usr/lib/python2.7/dist-packages/twisted/internet/_glibbase.py", line 20, in <module>
    from twisted.internet import base, posixbase, selectreactor
  File "/usr/lib/python2.7/dist-packages/twisted/internet/base.py", line 27, in <module>
    from twisted.internet._resolver import (
  File "/usr/lib/python2.7/dist-packages/twisted/internet/_resolver.py", line 25, in <module>
    from twisted.internet.address import IPv4Address, IPv6Address
  File "/usr/lib/python2.7/dist-packages/twisted/internet/address.py", line 23, in <module>
    class IPv4Address(object):
  File "/usr/lib/python2.7/dist-packages/twisted/internet/address.py", line 37, in IPv4Address
    type = attr.ib(validator=attr.validators.in_(["TCP", "UDP"]))
AttributeError: 'module' object has no attribute 'in_'

Ответ на: комментарий от FoxMulder

ftp://ftp.amalofeev.ru/tor-browser-linux64-8.0.2_ru.tar.xz

это отсюда

https://www.torproject.org/dist/torbrowser/8.0.2/tor-browser-linux64-8.0.2_ru...

https://www.torproject.org/dist/torbrowser/8.0.2/tor-browser-linux64-8.0.2_ru...

-----BEGIN PGP SIGNATURE-----

iQIcBAABCgAGBQJbs/+QAAoJEOt3RJHZ/wbiKp4QAKN7cpptHTx5Cjvs1fI/w7Cv
ZAz9gCwC4iTzG+AdPYVj9D9LH8WZ1umaEqdBIy6solkMcZ+k70y0xX9RwA35dHXy
UFrfqU9rlTpbsblipvBaOhYOYBkeaoZCr1X+GtpmrxNkDYKORgaeqSSeW+TEPUOi
VUtiAIrRniY/YcXcAATeo2FXphmo2xM95OwtdcWYbi0EkA6A7TWum3MqDeycWJ7V
Ph57xDEV7M3np07PU5L4g94j/Xj38o7+3mrxj0LiXsI5gsY0R7nGOePH4Wlehuvx
olFtusbLoGYuaQaffuIiUxLM2UP4GbV8cTYIV5EFFY1DBJppGeFfQe6tF5jzzYdt
BduM2j7wrANvFCpUu6inkpIMuCaBOBf6SC6oQu66d0Xn43kxZPqESKlrH7+v/YOP
M0DsUpb+bF1ELOcBMLcSSYwnxVPFVJkaY+oIyVAdtrafGNUCgvfzWrf62NuN4m5y
qOGb4WHivHe0hIvZfMxPw1BS8s2HWHNw1k9kImIa3OkaB02wc1LnhuTaVWhugeHp
uPREdo/dLzlyGfevIfqDcT+3ITEaSxFr+YVf43ZVOJKzpfODz8JeMIpv+wY7gL0+
ycHUz7sB/u+B9JXI7bJOjvPIDWsTye6wd0BOwbJScczG4S8smqlAIDcuZZVRAQAJ
Rm0bLYnIx5+Tk0VTKaow
=M1V9
-----END PGP SIGNATURE-----

Проверишь, anonymous подтвердит что не лажа.

mandala ★★★★ ()
Ответ на: комментарий от FoxMulder

Я предложил тебе решение проблемы. Еще пара человек ниже дали тебе более развернутый ответ, который развивает ту же идею. Не знаю как оно в дебиане, но в доках генты настоятельно рекомендуют использовать tor-browser с офф. сайта.

otto ()
Ответ на: комментарий от FoxMulder

Не нужно, это всё хомячковые мифы. Если софт должен самообновляться, лучше положить его в хомяк. Как образец такого софта можешь, взять стим. Ты только что сказал, тебе нужен браузер, а не тор, тогда вообще никаких причин с реп ставить.

anonymous ()
Ответ на: комментарий от FoxMulder

/me сидит на сборке лисы с сайта, а не из репы, так как мейнтейнеры укурыши, уж простите.

Когда мы говорим о tor — тут еще веселее, я б мейнтейнерам дистра корежить браузер уж совсем бы не доверил.

Не нравиться мой линк, так делай как тебе говорят: ставь не тор-браузер, а сам тор, локальный прокси и пользуйся любым браузером/программой подключаясь к свою локальному прокси которая идет в интернет через тор.

mandala ★★★★ ()
Ответ на: комментарий от FoxMulder

Мне нужно

Зачем ?
этот установщик тащил торбраузер с оффсайта, но то ли ссылка поменялась, то ли что-то сломали и установщик из репы перестал работать.

bdfy ★★★★ ()
Ответ на: комментарий от FoxMulder

У тебя вебсайт тора заблочен, ты его так не установишь, блин, ему нужен офф.сайт всё равно, хоть и из репы...

Вот же написал tor (комментарий)

А дальше выберешься в свободный интернет и делай как тебе хочется.

mandala ★★★★ ()
Ответ на: комментарий от FoxMulder

Включить бекпорты — добавить строку в /etc/apt/sources.list (пример для stretch, это debian 9)

deb http://ftp.debian.org/debian stretch-backports main

Обновить индекс

apt update

Установить

apt install torbrowser-launcher -t stretch-backports
mandala ★★★★ ()
Ответ на: комментарий от mandala

Доброе утро! Я уже установил его, но он не запускатся. Singularity нашёл такую же проблему, тс того поста удалил конфигурационные файлы, только я не знаю какие и где они?

FoxMulder ()