LINUX.ORG.RU

Удалить LibreOffice4.2 на АльтЛинуксе

 , , ,


0

2

Проблема управлять пакетами в АльтЛинукс. LibreOffice не запускается, а удалить и установить заново не получается. При установке с офф. сайта 6 версия работает, но нужно установить из репов Альта (сертифицированное).

# lsb_release -a
LSB Version:	n/a
Distributor ID:	ALT
Description:	ALT Linux 7.0.5 SPT  (silo)
Release:	7.0.5
Codename:	silo

# whereis libreoffice
libreoffice: /usr/bin/libreoffice4.2


# apt-get remove libreoffice
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Выбрано LibreOffice4 для 'libreoffice'
Пакет LibreOffice4 не установлен, и не может быть удалён.
0 будет обновлено, 0 новых установлено, 0 пакетов будет удалено и 1 не будет обновлено.

# echo $PATH
/home/okno14/bin:/usr/libexec/lightdm:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games:/usr/X11R6/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

В меню Система - Администрирование - Центр управления системой - Программное обеспечение - Источники установки ПО был добавлен источник: ftp://ftp.altlinux.org/pub/distributions/ALTLinux и ПО, ставится. Как только удалить непонятно.

У тебя пакет LibreOffice не установлен. Выполни apt-cache search libreoffice и посмотри список релевантных пакетов. Затем выполни команду apt list --installed libreoffice или другой релевантный пакет.

Quasar ★★★★★ ()
Последнее исправление: Quasar (всего исправлений: 1)

LibreOffice шёл вместе с системой при установке AltLinux. Ничего дополнительно не ставилось.

При запуске через консоль выглядит так:

$ lowriter
$

При этом показывается загрузка LO на 2 секунды с индикатором загрузки и потом сразу падает. Сообщений, как видите, нет.

apt, aptitude тоже нет. Вот что показывает поиск

# apt-cache search libreoffice
LibreOffice4 - LibreOffice Productivity Suite
LibreOffice4-common - Basic installation of LibreOffice4
LibreOffice4-extensions - Additional extensions for LibreOffice4
LibreOffice4-gnome - GNOME Extensions for LibreOffice4
LibreOffice4-integrated - Binaries, icons and desktop files for LibreOffice4
LibreOffice4-kde4 - KDE4 Extensions for LibreOffice4
LibreOffice4-langpack-de - German language pack for LibreOffice4
LibreOffice4-langpack-es - Espanian language pack for LibreOffice4
LibreOffice4-langpack-fr - French language pack for LibreOffice4
LibreOffice4-langpack-kk - Kazakh language pack for LibreOffice4
LibreOffice4-langpack-pt-BR - Brazilian language pack for LibreOffice4
LibreOffice4-langpack-ru - Russian language pack for LibreOffice4
LibreOffice4-langpack-uk - Ukrainian language pack for LibreOffice4
LibreOffice4-standalone - Renamed binaries, icons and desktop files for LibreOffice4
libcdr - A library providing ability to interpret and import Corel Draw drawings
libmspub - A library providing ability to interpret and import Microsoft Publisher files
libodfgen - An ODF generator library
libreoffice-languagetool - LibreOffice/OpenOffice.org extension for proofreading
libvisio - A library providing ability to interpret and import visio diagrams
LibreOffice4-mimetypes - Mimetype keys support for LibreOffice4
hunspell-ru-lebedev - Словарь русского языка для myspell/hunspell, разрешена замена "ё" на "е"
hunspell-ru-lebedev-ie - Словарь русского языка для myspell/hunspell без поддержки буквы "ё"
hunspell-ru-lebedev-io - Словарь русского языка для myspell/hunspell с обязательным употреблением буквы "ё"
unoconv - Tool to convert between any document format supported by LibreOffice
writer2latex - Flexible tool to convert OpenOffice documents into LaTeX2e and XHTML formats

# 

# apt-list --installed libreoffice
bash: apt-list: команда не найдена

# apt list --installed libreoffice
bash: apt: команда не найдена

# apt-get install LibreOffice4 LibreOffice4-common LibreOffice4-extensions
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Последняя версия LibreOffice4-common уже установлена.
Последняя версия LibreOffice4-extensions уже установлена.
Следующие НОВЫЕ пакеты будут установлены:
  LibreOffice4
0 будет обновлено, 1 новых установлено, 0 пакетов будет удалено и 1 не будет обновлено.
Необходимо получить 0B/5502B архивов.
После распаковки потребуется дополнительно 0B дискового пространства.
Совершаем изменения...
Preparing...                 ########################################### [100%]
Running /usr/lib/rpm/posttrans-filetriggers
Завершено.

# apt-get install LibreOffice4-standalone
Чтение списков пакетов... Завершено
Построение дерева зависимостей... Завершено
Следующие пакеты будут УДАЛЕНЫ:
  LibreOffice4 LibreOffice4-integrated
Следующие НОВЫЕ пакеты будут установлены:
  LibreOffice4-standalone
0 будет обновлено, 1 новых установлено, 2 пакетов будет удалено и 1 не будет обновлено.
Необходимо получить 7288B архивов.
После распаковки будет освобождено 29,0MB дискового пространства.
Продолжить? [Y/n] y
Получено: 1 ftp://ftp.altlinux.org i586/classic LibreOffice4-standalone 4.2-alt2.M70C.6 [7288B]
Получено 7288B за 0s (14,8kB/s).         
Совершаем изменения...
Preparing...                 ########################################### [100%]
1: LibreOffice4-standalone   ########################################### [100%]
Running /usr/lib/rpm/posttrans-filetriggers
Завершено.

# whereis libreoffice
libreoffice: /usr/bin/libreoffice4.2

$ /usr/bin/libreoffice4.2
$

Не запускается, сообщений нет. Как удалить не знаю, что доставить, не знаю.

comoestasyan ()