LINUX.ORG.RU

Игнор пакетов

 ,


0

1

Только что поставил дебиан 9.3 + пакет sudo.

Уже траблы, игнорируется один реп, как исправить?

Никак, это вообще не проблема.

anonymous ()
Ответ на: комментарий от outsider

/etc/apt/sources.list

Bapen1k ()
Ответ на: комментарий от Bapen1k

добавь после каждого main еще contrib и non-free
должно получится что-то типа

deb http://deb.debian.org/debian/ stretch main contrib non-free

src тебе вряд ли понадобится, закоменть

потом apt-get update && apt-get upgrade

outsider ★★ ()
Ответ на: комментарий от Bapen1k

тогда поменяй источник, зеркала найдешь на сайте дебиана

outsider ★★ ()

Всё нормально у тебя. Это не ошибка. Это означает, что будет игнорироваться реп т.к. нет изменений в нём.

yrii2121 ()
Ответ на: комментарий от anonymous

Хм, да, есть такой вариант. С debian 9 apt настойчиво требовал создания этого файла для своих реп. Вот и вздумалось, что это уже обязательная вещь и файл там должен быть точно. А в «/debian/dists/stretch» его нету...

yrii2121 ()
Ответ на: комментарий от yrii2121

А в «/debian/dists/stretch» его нету...

The file «dists/$DIST/InRelease» shall contain meta-information about the distribution and checksums for the indices, possibly signed with a GPG clearsign signature (for example created by «gpg -a -s --clearsign»). For older clients there can also be a «dists/$DIST/Release» file without any signature and the file «dists/$DIST/Release.gpg» with a detached GPG signature of the «Release» file, compatible with the format used by the GPG options "-a -b -s".

(https://wiki.debian.org/DebianRepository/Format#A.22Release.22_files)

Значит, там есть Release. А у тебя требовали InRelease как предпочтительный в условиях, когда не было ни того, ни другого, могу предположить.

anonymous ()
Ответ на: комментарий от anonymous

Этот абзац wiki я читал. Да, конечно там (http://cdn-fastly.deb.debian.org/debian/dists/stretch/) есть Release.

А у тебя требовали InRelease как предпочтительный в условиях, когда не было ни того, ни другого, могу предположить.

Release файл у меня был. Я тогда делал всё так же, как и для Jessie, но в Stretch apt уже начал ругаться.
Ну и в "release-notes" сказали, что при использовании строронних реп. apt будет ругаться. Просто, как я написал выше, вздумалось, что для оф. репы тоже требуется InRelease. Забыл, что нет.
А по поводу:

Это означает, что будет игнорироваться реп т.к. нет изменений в нём.

Я «прошёлся» по англ. интернету (англ. у меня со словарём, может неправильно что-то понял). По первым ссылкам пишут тоже самое. Но это не отнимает замечание анона, что такое поведение есть и при отсутствие файла InRelease.

yrii2121 ()
Ответ на: комментарий от Bapen1k

Тебе не нужно ничего отключать, всё работает правильно. Если будут проблемы, apt об этом скажет прямо.

anonymous ()
Ответ на: комментарий от outsider

что такое lnRelease?

Это Release + Release.gpg, собранные в один файл. Нужно, чтобы исключить ситуацию, когда во время обновления зеркала один из файлов Release/Release.gpg обновился, а другой нет.

i-rinat ★★★★★ ()

Уже траблы, игнорируется один реп, как исправить?

Это не траблы. Из репозитория нужен Release или InRelease. Если уже есть один из файлов, нет смысла качать другой. Плюс там ещё могут быть какие-то внутренние предпочтения у отдельных утилит.

i-rinat ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.