LINUX.ORG.RU

mgetty+pppd ...


0

0

Проблема с настройкой Dial-in сервера под RH 7.1 Перечитал кучу способов. Настроил mgetty.config - при входящем звонке модем поднимает трубку и устанавливает соединение. Но дальше начинаются проблемы - не хочет подниматься pppd. Хотя в login.config расскомментарено - "* - - /bin/login@" и "Auto PPP", изменены права на выполнение самого pppd. Соответственно у звонящего клиента в терминале не появляется приглашение для ввода имени пользователя и пароля а проскакивает несколько произвольных символов. Буду очень любезен за консультацию, или ссылку на соответствующие ресурсы.

anonymous

Re: mgetty+pppd ...

Наверное nologin где-то в options стоит.

anonymous ()

Re: mgetty+pppd ...

Если /AutoPPP/ раскомментировано, то логина и пароля и не будут спрашивать. А "случайные" символы - это прглашение протокола PPP. Нужно пользователей занести в pap-secrets, в файле options указать -chap +pap lock modem crtscts nodetach proxyarp asyncmap 0

Если же хочется с логином и паролем (клиент должен использовать скрипт), то убрать из options опции pap,chap и закомментировать назад /AutoPPP/ Пользователи при этом сидят в /etc/passwd; shell = /usr/sbin/pppd (не забыл chmod u+s /usr/sbin/pppd ? Linuxconf обычно любит снимать флаги) home dir можно по умолчанию (/home/user) или /tmp

anonymous ()

Re: mgetty+pppd ...

Да нет! Здесь что то не так. Если идет мусор попробуй поиграться со скоростью в порту

ash ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.