LINUX.ORG.RU
ФорумAdmin

Dial-in в RedHat, Help!!!


0

0

Помогите пожалуйста, неделю бьюсь...
Кто сможет четко, по шагам объяснить, как установить dial-in в RedHat70, чтобы модем (3Com US Robotics) трубку поднимал при звонке с виндузов и чтобы можно было выходить а инет (линукс на выделенке).
Я установил mgetty, в ядре, судя по всему есть модульная поддержка ppp
появилось несколько вопросов:
Какую роль играет mgetty и pppd ? Кто из них срабатываеть первым при входящем звонке? Какую роль они играют?

Пересмотрел кучу HOWTO, полазил в форумах.... Настраивал по-разному файлы /etc/ppp/options
etc/inittab
etc/default/mgetty.ttyS1 (модем на ком2)
etc/mgetty+sendfax/...
не помогает ничего.
при команде ifup ppp0 не находит устройства, а если в гноме в графике добавляю новое инет соединение(где соответствующие фойлы конфигурации, чтобы руками все делаТЬ?), то эта команда начинает дозваниваться, т е pppd paботает, но мне нужно его настроить на _входящие_ звонки...
Заранее благодарен

anonymous

Re: Dial-in в RedHat, Help!!!

Для начала я бы тебе посоветовал 1. зайти в minicom и настроить модем на автоответ 2. потом зайти в /etc/default и подпачить файло mgetty добавь туда ALTLOCK=ttyS1 и для всех модемов тоже самое S0,S2,S3... 3. зайди в /etc/ppp/ и исправь options так: -pap -chap -auth остальное по умолчанию. 4. попробуй позвонить с терминалки 98 на этот модем и залогинься напиши что получилось.

harlam ()

Re: Dial-in в RedHat, Help!!!

mgetty слушает модем. Именно она снимает трубку (смотри параметр -n у mgetty). Эту mgetty надо положить в /etc/inittab. Не забудь демона init перезапустить. Так вот, как только mgetty сняла трубу она слушает чего это к нам такое привалило. Если это LCP пакеты от ppp-соединения, то запускает демона pppd и передает ему номер порта по которому это случилось. Демон pppd запускается, читает настройки из файла /etc/ppp/options.ttyX , где X - номер порта (например S0) и начинает работать. Дальше читай доки про mgetty и ppp. Не забудь в options.ttyX указать опцию -auth. Иначе у тебя ppp-шка для виндузей не подымется. Рекомендую сходить на linuxnews.ru в разделе документации лежит статья по организации call-back на Линухе для Windows клиентов. Думаю много прояснится.

anonymous ()
Ответ на: Re: Dial-in в RedHat, Help!!! от anonymous

Re: Re: Dial-in в RedHat, Help!!!

Почти все получилось, спасибо. Виндуза дозванивается, линукс трубку берет, в виндузе соединение проходит.
Но инет не работает, соединение есть а инета нет.
В виндузе можно открыть окно терминала после соединения, могу зайти под всеми юзерами кроме root
Без открытия терминала тоже соединяется
Как мне настроить инет?
опция -auth в options.ttyS1 приводит к тому, что соединение сразу рвется

anonymous ()

А TCP/IP в Виндах настроен, DNS-ы всякие?

Сам мучался с этой проблемой.
Пока в настройках соединения все правильно 
не прописал - инет не шел.
Кроме того надо снять флажок "Вход в сеть" или как-то похоже.
Не разбирался почему, но у меня Винды по терминалу нормально 
работали с этим флажком. Пинговались, коннектились по ftp из 
терминала,но www не шло. Снял флажок - все нормально.
Вадим.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.