LINUX.ORG.RU

kde neon, конфликты обновления. помогите разобраться

 , ,


0

1

уже много-много месяцев не могу обновить кеды. тупо фигова туча конфликтов вываливается. написал на форуме неона. всем насрать. тема висит несколько месяцев, никто даже коммент не дал. вот выхлоп апта

слишком длинное сообщение... поэтому полный выхлоп с перечнем конфликтов тут: https://pastebin.com/4fePLs7L

The following packages have been kept back:
  ark bluedevil breeze breeze-cursor-theme dolphin frameworkintegration gtk3-engines-breeze kaccounts-providers kactivities-bin kactivitymanagerd kamera kde-cli-tools kde-cli-tools-data kde-config-gtk-style kde-config-sddm kde-style-breeze kde-style-breeze-qt4 kded5
  kdeplasma-addons-data kdialog kgamma5 khotkeys khotkeys-data kimageformat-plugins kinfocenter kinit kio kio-extras kio-extras-data kmenuedit konsole kpackagelauncherqml kpackagetool5 kross ksshaskpass ksysguard-data ksysguardd ktexteditor-data ktexteditor-katepart
  kwalletmanager kwayland-data kwayland-integration kwin-addons kwin-data kwin-style-breeze kwrite kwrited latte-dock libkdecorations2-5v5 libkf5activities5 libkf5attica5 libkf5auth-data libkf5baloo5 libkf5balooengine5 libkf5baloowidgets-bin libkf5baloowidgets5
  libkf5bluezqt-data libkf5bluezqt6 libkf5bookmarks-data libkf5bookmarks5 libkf5calendarevents5 libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5
  libkf5coreaddons-data libkf5coreaddons5 libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5 libkf5declarative-data libkf5declarative5 libkf5dnssd-data libkf5emoticons-data libkf5emoticons5 libkf5filemetadata-data libkf5filemetadata3 libkf5globalaccel-data
  libkf5globalaccel5 libkf5guiaddons5 libkf5holidays-data libkf5holidays5 libkf5i18n-data libkf5iconthemes-bin libkf5iconthemes-data libkf5idletime5 libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5jsembed-data
  libkf5jsembed5 libkf5kcmutils-data libkf5kcmutils5 libkf5kdcraw5 libkf5kdelibs4support-data libkf5kdelibs4support5 libkf5khtml-bin libkf5khtml-data libkf5kiofilewidgets5 libkf5kiontlm5 libkf5kiowidgets5 libkf5kipi32.0.0 libkf5kirigami2-5 libkf5krosscore5
  libkf5modemmanagerqt6 libkf5networkmanagerqt6 libkf5newstuff-data libkf5newstuff5 libkf5notifications-data libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data libkf5package5 libkf5parts-data libkf5people-data libkf5people5 libkf5peoplebackend5
  libkf5peoplewidgets5 libkf5plasma5 libkf5prison5 libkf5pty-data libkf5pty5 libkf5quickaddons5 libkf5runner5 libkf5screen7 libkf5service-bin libkf5service-data libkf5service5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5style5 libkf5su-data libkf5su5
  libkf5syntaxhighlighting-data libkf5syntaxhighlighting5 libkf5sysguard-bin libkf5sysguard-data libkf5texteditor5 libkf5textwidgets-data libkf5textwidgets5 libkf5threadweaver5 libkf5unitconversion-data libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5waylandclient5
  libkf5waylandserver5 libkf5widgetsaddons-data libkf5windowsystem-data libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libkscreenlocker5 libksgrd7 libksignalplotter7 libkwalletbackend5-5 libkwineffects11 libkwinglutils11 libkworkspace5-5 libplasma-geolocation-interface5
  libpowerdevilui5 libprocesscore7 libqgsttools-p1 libqmobipocket2 libqt5concurrent5 libqt5dbus5 libqt5designercomponents5 libqt5gui5 libqt5help5 libqt5multimedia5 libqt5multimedia5-plugins libqt5multimediaquick-p5 libqt5multimediawidgets5 libqt5printsupport5 libqt5qml5
  libqt5quickcontrols2-5 libqt5quicktemplates2-5 libqt5quickwidgets5 libqt5script5 libqt5sql5-sqlite libqt5svg5 libqt5test5 libqt5texttospeech5 libqt5waylandclient5 libqt5waylandcompositor5 libqt5webchannel5 libqt5webengine-data libqt5webenginewidgets5 libqt5webkit5
  libqt5widgets5 libqt5x11extras5 libqt5xml5 libtaskmanager6 milou okular plasma-dataengines-addons plasma-desktop plasma-desktop-data plasma-look-and-feel-org-kde-breezedark-desktop plasma-nm plasma-pa plasma-runners-addons plasma-wallpapers-addons plasma-workspace
  powerdevil-data print-manager qml-module-org-kde-activities qml-module-org-kde-bluezqt qml-module-org-kde-draganddrop qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-newstuff qml-module-org-kde-purpose
  qml-module-org-kde-qqc2desktopstyle qml-module-org-kde-runnermodel qml-module-org-kde-solid qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings qml-module-qtqml-models2 qml-module-qtquick-controls qml-module-qtquick-controls-styles-breeze
  qml-module-qtquick-controls2 qml-module-qtquick-dialogs qml-module-qtquick-layouts qml-module-qtquick-privatewidgets qml-module-qtquick-window2 qml-module-qtquick-xmllistmodel qml-module-qtquick2 qml-module-qtwebkit qt5-gtk-platformtheme qtchooser qtvirtualkeyboard
  qtwayland5 sonnet-plugins systemsettings user-manager xorg
0 upgraded, 0 newly installed, 0 to remove and 245 not upgraded.
[~] $ 

У тебя же всё написано: неон поставляет слишком новые пакеты с Qt, убунтушные пакеты хотят чего постарше

XMs ★★★★★ ()
Ответ на: комментарий от ilinsky

везде в source.list поменял artful на xenial в lsb-release изменил все с последней убунты на 16.04 xenial как теперь пересобраться? do-release-upgrade ничего не находит apt upgrade опять же рисует конфликты

linux-vo1d ()
Ответ на: комментарий от ilinsky

взял щас первый пакет, который не обновляется - ark install ark он предложил часть кутешных пакетов апгейднуть.. посмотрим.. может щас всё пойдет пучком. и все конфликтующие которые сами не обновляются через `apt upgrade` таким образом пересоберутся

linux-vo1d ()
Ответ на: комментарий от ilinsky
[~] $ upd
...                
Reading package lists... Done
Building dependency tree       
Reading state information... Done
281 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Entering ResolveByKeep 10%
  Dependencies are not satisfied for gnupg:amd64 < 2.1.15-1ubuntu8 @ii mK Ib >
Keeping package gnupg:amd64
  Dependencies are not satisfied for gnupg:amd64 < 2.1.15-1ubuntu8 @ii mK Ib >
Package gnupg:amd64 gnupg:amd64 Breaks on software-properties-common:amd64 < 0.96.24.17 -> 0.96.20.7 @ii mD > (<= 0.96.24.3)
  Keeping Package software-properties-common:amd64 due to Breaks
  Dependencies are not satisfied for python3-software-properties:amd64 < 0.96.24.17 -> 0.96.20.7 @ii mD NPb Ib >
Keeping package python3-software-properties:amd64
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  libokular5core7 libre2-3 qml-module-org-kde-kirigami
Use 'sudo apt autoremove' to remove them.
The following NEW packages will be installed:
  drkonqi libcfitsio2 libchm1 libkf5xmlrpcclient-data libkf5xmlrpcclient5 libmarkdown2 libokular5core8 nodejs-legacy okular-extra-backends qtvirtualkeyboard-plugin
The following packages will be upgraded:
  baloo-kf5 bluedevil breeze breeze-cursor-theme dolphin frameworkintegration gtk3-engines-breeze gwenview kaccounts-providers kactivities-bin kactivitymanagerd kamera kde-cli-tools kde-cli-tools-data kde-config-gtk-style kde-config-plymouth kde-config-screenlocker
  kde-config-sddm kde-spectacle kde-style-breeze kde-style-breeze-qt4 kded5 kdeplasma-addons-data kdialog kgamma5 khotkeys khotkeys-data kimageformat-plugins kinfocenter kinit kio kio-extras kio-extras-data kmenuedit konsole konsole-kpart kpackagelauncherqml kpackagetool5
  kross kscreen ksshaskpass ksysguard ksysguard-data ksysguardd ktexteditor-data ktexteditor-katepart kwalletmanager kwayland-data kwayland-integration kwin-addons kwin-common kwin-data kwin-style-breeze kwin-x11 kwrite kwrited latte-dock libdolphinvcs5 libkaccounts1
  libkdecorations2-5v5 libkdecorations2private5v5 libkf5activities5 libkf5activitiesstats1 libkf5archive5 libkf5attica5 libkf5auth-data libkf5auth5 libkf5baloo5 libkf5balooengine5 libkf5baloowidgets-bin libkf5baloowidgets5 libkf5bluezqt-data libkf5bluezqt6
  libkf5bookmarks-data libkf5bookmarks5 libkf5calendarevents5 libkf5codecs-data libkf5codecs5 libkf5completion-data libkf5completion5 libkf5config-bin libkf5config-data libkf5configcore5 libkf5configgui5 libkf5configwidgets-data libkf5configwidgets5 libkf5coreaddons-data
  libkf5coreaddons5 libkf5crash5 libkf5dbusaddons-bin libkf5dbusaddons-data libkf5dbusaddons5 libkf5declarative-data libkf5declarative5 libkf5dnssd-data libkf5dnssd5 libkf5doctools5 libkf5emoticons-bin libkf5emoticons-data libkf5emoticons5 libkf5filemetadata-bin
  libkf5filemetadata-data libkf5filemetadata3 libkf5globalaccel-bin libkf5globalaccel-data libkf5globalaccel5 libkf5globalaccelprivate5 libkf5guiaddons5 libkf5holidays-data libkf5holidays5 libkf5i18n-data libkf5i18n5 libkf5iconthemes-bin libkf5iconthemes-data
  libkf5iconthemes5 libkf5idletime5 libkf5itemmodels5 libkf5itemviews-data libkf5itemviews5 libkf5jobwidgets-data libkf5jobwidgets5 libkf5jsapi5 libkf5jsembed-data libkf5jsembed5 libkf5kcmutils-data libkf5kcmutils5 libkf5kdcraw5 libkf5kdelibs4support-data
  libkf5kdelibs4support5 libkf5kdelibs4support5-bin libkf5kexiv2-15.0.0 libkf5khtml-bin libkf5khtml-data libkf5khtml5 libkf5kiocore5 libkf5kiofilewidgets5 libkf5kiontlm5 libkf5kiowidgets5 libkf5kipi32.0.0 libkf5kirigami2-5 libkf5krosscore5 libkf5krossui5
  libkf5modemmanagerqt6 libkf5networkmanagerqt6 libkf5newstuff-data libkf5newstuff5 libkf5newstuffcore5 libkf5notifications-data libkf5notifications5 libkf5notifyconfig-data libkf5notifyconfig5 libkf5package-data libkf5package5 libkf5parts-data libkf5parts-plugins
  libkf5parts5 libkf5people-data libkf5people5 libkf5peoplebackend5 libkf5peoplewidgets5 libkf5plasma5 libkf5plasmaquick5 libkf5prison5 libkf5pty-data libkf5pty5 libkf5purpose-bin libkf5purpose5 libkf5quickaddons5 libkf5runner5 libkf5screen7 libkf5service-bin
  libkf5service-data libkf5service5 libkf5solid5 libkf5solid5-data libkf5sonnet5-data libkf5sonnetcore5 libkf5sonnetui5 libkf5style5 libkf5su-bin libkf5su-data libkf5su5 libkf5syntaxhighlighting-data libkf5syntaxhighlighting5 libkf5sysguard-bin libkf5sysguard-data
  libkf5texteditor5 libkf5textwidgets-data libkf5textwidgets5 libkf5threadweaver5 libkf5unitconversion-data libkf5unitconversion5 libkf5wallet-bin libkf5wallet-data libkf5wallet5 libkf5waylandclient5 libkf5waylandserver5 libkf5widgetsaddons-data libkf5widgetsaddons5
  libkf5windowsystem-data libkf5windowsystem5 libkf5xmlgui-bin libkf5xmlgui-data libkf5xmlgui5 libkfontinst5 libkfontinstui5 libkscreenlocker5 libksgrd7 libksignalplotter7 libkwalletbackend5-5 libkwin4-effect-builtins1 libkwineffects11 libkwinglutils11
  libkwinxrenderutils11 libkworkspace5-5 libplasma-geolocation-interface5 libpowerdevilcore2 libpowerdevilui5 libprocesscore7 libprocessui7 libqgsttools-p1 libqmobipocket2 libqt5concurrent5 libqt5designercomponents5 libqt5help5 libqt5multimediaquick-p5 libqt5test5
  libqt5texttospeech5 libqt5x11extras5 libtaskmanager6 libweather-ion7 milou okular plasma-dataengines-addons plasma-desktop plasma-desktop-data plasma-framework plasma-integration plasma-look-and-feel-org-kde-breezedark-desktop plasma-nm plasma-pa plasma-runners-addons
  plasma-wallpapers-addons plasma-widgets-addons plasma-workspace polkit-kde-agent-1 powerdevil powerdevil-data print-manager qml-module-org-kde-activities qml-module-org-kde-bluezqt qml-module-org-kde-draganddrop qml-module-org-kde-kconfig qml-module-org-kde-kcoreaddons
  qml-module-org-kde-kholidays qml-module-org-kde-kio qml-module-org-kde-kirigami2 qml-module-org-kde-kquickcontrols qml-module-org-kde-kquickcontrolsaddons qml-module-org-kde-kwindowsystem qml-module-org-kde-newstuff qml-module-org-kde-purpose
  qml-module-org-kde-qqc2desktopstyle qml-module-org-kde-runnermodel qml-module-org-kde-solid qml-module-qt-labs-folderlistmodel qml-module-qt-labs-settings qml-module-qtmultimedia qml-module-qtqml-models2 qml-module-qtquick-controls-styles-breeze
  qml-module-qtquick-layouts qml-module-qtquick-virtualkeyboard qml-module-qtquick-window2 qml-module-qtquick-xmllistmodel qml-module-qtquick2 qtchooser qtvirtualkeyboard sddm sonnet-plugins systemsettings user-manager
281 upgraded, 10 newly installed, 0 to remove and 2 not upgraded.
Need to get 115 MB of archives.
After this operation, 11,7 MB of additional disk space will be used.
Do you want to continue? [Y/n] 

вооо. уже получше выглядит ;-)

linux-vo1d ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.