LINUX.ORG.RU

Ошибка при загрузке модуя ядра «g_mass_storage» при старте системы

 , ,


0

2

Приветствую!

Работаю сейчас над эмуляцией USB-флэшки с помощью Raspberry Pi Zero W по руководству https://gist.github.com/gbaman/50b6cca61dd1c3f88f41#file-howtootg-md .


1) Там надо было добавить строку g_mass_storage в файл /etc/modules

Но это приводит к ошибке во время старта системы

g_mass_storage 20980000.usb: failed to start g_mass_storage: -22
[FAILED] Failed to start Load Kernel Modules.

И подключив к компьютеру по USB такой Raspberry Pi распознается как «неизвестное устройство»


2) НО! Если если вызвать или добавить в /etc/rc.local строку sudo modprobe g_mass_storage file=/virt-fs.img stall=0

то сразу же ситуация меняется, и появляется сообщение о подключенном внешнем USB-накопителе


Прошу помощи! Хотелось бы чтобы пункт 1) отрабатывал без ошибки

Ответ на: комментарий от ZenitharChampion

Спасибо, только ... в каком конфигуратионном файле это добавить? Или это должны быть переменные среды?

кстати, еще такой непонятный момент, забыл сказать:
нигде не нашел ни одного файла с именем g_mass_storage

kroiksm ()
Ответ на: комментарий от kroiksm

В файл /etc/modules. Если там уже есть параметр modules="Мудуль_1 модуль_2 модуль_3", то лучше дописать свой модуль туда.

«Модулями» называют «модули ядра» для краткости. А «модуль ядра» - это то же саоме, что и «драйвер».

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

хммм толь ко вот файл /etc/modules несколько другой формат имеет.
Вобщем то из-за него я и завел топик, из-за строки g_mass_storage
Мой /etc/modules:

# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

i2c-dev

# ==== my ====
dwc2
g_mass_storage
kroiksm ()
Ответ на: комментарий от kroiksm

Понятно. Не знал. У меня в Gentoo - именно такой формат, который я описал.

ZenitharChampion ★★★★★ ()
Ответ на: комментарий от Radjah

спасибо, но не помогает я как рыба об лед, не могу нагуглить внятной документации/примеров

в некоторых нагугленных форумах проскакивала информация, что надо положить конфигурационный файл в директорию /etc/modprobe.d/, сделал:

#/etc/modprobe.d/g_mass_storage.conf

file=/virt-fs.img stall=0
эффекта ноль

kroiksm ()
Ответ на: комментарий от ZenitharChampion

По идее в /etc/modules надо тогда добавить g_mass_storage.

Но это опять моя в вера интуитивность настроек.

Radjah ★★★★★ ()
Ответ на: комментарий от ZenitharChampion

нда, что то ничего не получается начинаю медитировать над японским форумом http://qiita.com/mt08/items/838a2a0e42d4dbc9fba7

кстати, кое что изменилось. Код ошибки стал не -22, a -2 после создания файла:

#/etc/modprobe.d/g_mass_storage.conf

options g_mass_storage "file=/virt-fs.img stall=0"
код ошибки поменялся (в 1-ом посте старая версия)
g_mass_storage 20980000.usb: failed to start g_mass_storage: -2
[FAILED] Failed to start Load Kernel Modules.

kroiksm ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.