LINUX.ORG.RU

помощь с настройкой принтера в ubuntu

 , ,


0

1

всем привет! помогите с настройкой принтера, подключенного по usb и доступного через протокол сifs скрин

сразу скажу, что если комп на винде, там установка достаточно простая:

  • вбить в проводнике адрес \\10.0.0.1
  • выбрать принтер и нажать - подключить (обычно сам находит все дрова)

Когда стояла убунту 16.04, как-то получилось настроить в пару кликов А сейчас ubuntu 16.10 и что-то не получается

Возможно, не подключается, т.к. поменял имя рабочей группы, но учел это и поменял строчку (рабочей группы) в конфиге samba (вроде больше нигде не нужно что-то менять)

  • Пытался настроить через утилиту hp-setup, но он не находит принтера по адресу 10.0.0.1
  • Если открывать nautilus и открывать адрес smb://10.0.0.1 (или cifs://10.0.0.1)
  • Пробовал еще настроить принтер через cups (пробовал 1. HP Printer (HPLIP) и 2. Хост или принтер LPD/LPR socket://hostname)

Логи cups достаточно скромные и ничего не отображают

access_log
localhost - allex [09/May/2017:15:01:31 +0300] "POST /admin HTTP/1.1" 200 75 - -
localhost - allex [09/May/2017:15:01:31 +0300] "POST /admin HTTP/1.1" 200 3117 - -
error_log
E [07/May/2017:11:32:27 +0300] [Job 5] Принтер не отвечает.
E [07/May/2017:11:33:27 +0300] [Job 5] Принтер не отвечает.
E [07/May/2017:11:34:27 +0300] [Job 5] Принтер не отвечает.

Как можно продиагностировать, в чем проблема? не отвечает какой-то порт или что-то в этом роде. с настройкой принтеров сталкивался больше на винде

Спасибо за советы

вот, что показывает nmap к роутеру

nmap 10.0.0.1

Starting Nmap 7.12 ( https://nmap.org ) at 2017-05-09 15:38 MSK
Nmap scan report for 10.0.0.1
Host is up (0.0065s latency).
Not shown: 995 closed ports
PORT    STATE SERVICE
23/tcp  open  telnet
53/tcp  open  domain
80/tcp  open  http
139/tcp open  netbios-ssn
445/tcp open  microsoft-ds
AnAlexey ()

ты для начала установи все необходимые библиотеки

$ hp-doctor

krang ★★ ()
Ответ на: комментарий от krang

доктор сказал, что пациент ни жив, ни мертв)

вот вывод:


------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

No Scanner found.

--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
lpstat
------
Type: Unknown
Device URI: Нет добавленных назначений.


--------------
| PERMISSION |
--------------

 

Checking for Configured Queues....
No Queue added

warning: No Queue(s) configured.


Checking for HP Properitery Plugin's....
No plug-in printers are configured.
 
Diagnose completed...

AnAlexey ()
Ответ на: комментарий от kostik87

avahi нет, есть какие-то ответвления

cups-filters был установлен

просто avahi нет. есть такие:

avahi-autoipd            avahi-daemon             avahi-publish            avahi-resolve            avahi-set-host-name
avahi-browse             avahi-discover           avahi-publish-address    avahi-resolve-address    
avahi-browse-domains     avahi-dnsconfd           avahi-publish-service    avahi-resolve-host-name  

немного потыкался:

avahi-resolve-address 10.0.0.1
Не удалось преобразовать адрес «10.0.0.1»: Время ожидания истекло
allex@allex-K501LB:~$ nslookup 10.0.0.1
Server:		127.0.1.1
Address:	127.0.1.1#53

** server can't find 1.0.0.10.in-addr.arpa: NXDOMAIN

allex@allex-K501LB:~$ avahi-browse-domains 
^CGot SIGINT, quitting.
allex@allex-K501LB:~$ avahi-publish
Не указана команда.
allex@allex-K501LB:~$ avahi-discover 
видит только что-то локальное

Проблема в ОС? в роутере? или какой-то утилиты не хватает? как понять, в чем проблема?

вот еще, хотя nautilus этого не видит:

llex@allex-K501LB:~$ smbclient -L //10.0.0.1
WARNING: The "syslog" option is deprecated
Enter allex's password: 
Domain=[H1] OS=[NDM Keenetic] Server=[NQ 6.2]

	Sharename       Type      Comment
	---------       ----      -------
	IPC$            IPC       IPC Service
	Hewlett-Packard hp LaserJet 1010 Printer   
Domain=[H1] OS=[NDM Keenetic] Server=[NQ 6.2]

	Server               Comment
	---------            -------

	Workgroup            Master
	---------            -------

AnAlexey ()
Ответ на: комментарий от kostik87

да

#======================= Global Settings =======================

[global]

## Browsing/Identification ###

# Change this to the workgroup/NT-domain name your Samba server will part of
   workgroup = H1
AnAlexey ()
Ответ на: запущен от AnAlexey

Всё же запускать надо не так, а через init сценарий.

Попробуй смени рабочую группу для теста на умолчальную, если сомневаешься, что проблема в этом.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

ничего не поменялось(

рабочую группу поменял, но ничего не поменялось (проверил установку через hp-setup, стандартные средства добавление принтера и установку из консоли)

AnAlexey ()

настройка принтера через cups и smb

вроде не было раньше строчки в настройках cups (Windows Printer via SAMBA)

принтер добавил, но не печатает с ошибкой: «Bad URI - need printer name!»

AnAlexey ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.