LINUX.ORG.RU

Проблема с отображением некоторых символов в WPS/Libreoffice

 , , ,


1

2

Добрый день. Возникла проблема с печатью редких иероглифов. Например, вот такой 𢦏 без проблем печатается в браузере или gedit, но в WPS и Libreoffice начинаются проблемы.

WPS-office в самом документе вместо иероглифа показывает квадратики, но нормально отображает его в строке поиска и результатах.

Libreoffice - наоборот, не отображает иероглиф в строке поиска и результатах, но отображает в документе. Причем делает это только если сменить размер шрифта - при автоматическом размере будет все тот же квадратик.

Кто-нибудь знает, с чем это может быть связано? Заранее благодарю.

Новичок, Linux Mint 17.2, LibreOffice 4.4.3.2, WPS-office 10.1.0.5672

скорее всего со шрифтами. Нужный тебе иероглиф содержат гдето 2.5 шрифта, и скорее всего только один из них установлен у тебя в системе. Попробуй его найти и сделать его по умолчанию для всего чего можно. Если мне не изменяет память то нужный тебе шрифт содержит в имени «Unicode».

cvv ★★★★★ ()

Кажется в либреофис была галочка внедрять шрифты в файл, не знаю как оно работает, но может поможет если работает только на конкретном шрифте.

orm-i-auga ★★★★★ ()
Ответ на: комментарий от cvv

После загрузки доп шрифтов и изменения настроек, Libre Office стал показывать все без проблем. WPS Spreadsheets - все как раньше, WPS Writer - если выделить иероглиф и поменять шрифт, то иероглиф он показывает, но сбоку от него появляется квадратик. Если попробовать этот квадратик удалить, программа вылетает.

jinmu93 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.