LINUX.ORG.RU

Gave up waiting for root device при загрузке

 , , ,


0

3

Всем доброго времени суток! Видел здесь похожие темы, но ответа для себя не нашёл. Проблема:

Gave up waiting for root device. Common problems:

- Boot args (cat /proc/cmdline)

- Check rootdelay= (did the system wait long enought?)

- Check root= (did the system wait for the right device?)

- Missing modules (cat /proc/modules; ls /dev)

ALERT! /dev/disk/by-uuid/ca......................747 does not exist.

Dropping to a shell!

modprobe: module ehci-orion not found in modules.dep

Далее загрузка BusyBox.

На борту debian 8.5. Жесткий диск определяется в BIOS (UEFI) и в grub2, но после загрузки с liveusb - жесткого как и не было...

Нифига не понял. Откуда возникла проблема? debian 8.5 на этом жёстком диске или на liveusb? Система вобще загружалась с этого жёсткого диска на этой материнке или это сразу после установки?

mky ★★★★★ ()
Ответ на: комментарий от mky

Нифига не понял. Откуда возникла проблема?

Исправляюсь.

Проблема возникла из-за отключения питания во время загрузки. Debian 8.5 на жёстком диске. Система загружалась с этого диска, на этой материнке, служила верой и правдой продолжительное время (не задавался целью ушатать). При загрузке с liveusb ОС не видит жесткого диска, поэтому исправить с помощью живого дистра не получается. При загрузке запускается grub2 (все как положено), долгое время (секунд 10) висит сообщение «Loading, wait...», далее сообщение: Gave up waiting for root device. Common problems:... Т.е., главная загрузочная запись не повреждена (я думаю), но передать управление системе загрузчик не может (отсутствует каталог /dev/disk/). При этом, через консоль grub2 можно посмотреть на разделы, каталоги, файлы. Достать ничего не получается.

aharsisis ()
Ответ на: комментарий от mandala

Не видит диска совсем?

Совсем. fdisk -l - только флэшка (/dev/sda).

Gparted - аналогично.

Утилитка вроде gnome disk utility - только usb.

Жёсткий диск определяется, как устройство только в BIOS (UEFI) и в grub2. Операционка (linuxы) его не видит.

aharsisis ()
Ответ на: Не видит диска совсем? от aharsisis

скорее всего диску каюк.
попробуй его ручками проинициализоровать из livecd

echo "- - -" >/sys/class/scsi_host/hostX/scan

перебери все варианты hostX, потом посмотри не появилось ли чего.

bdfy ★★★★★ ()
Ответ на: комментарий от bdfy

скорее всего диску каюк.

Ткните носом, пож. Что вместо X в hostX подставить?

aharsisis ()
Ответ на: комментарий от bdfy

циферки от 0 и далее

Подскажи, что я не так сделал:

sudo -i echo "---«>/sys/class/scsi_host/host0/scan

bash: /sys/class/scsi_host/host0/scan: Permission denied

aharsisis ()

попробуй для начала хардварно сбросить биос (замкни контакты, если знаешь, какие, или тупо вытащи батарейку биоса секунд на 30).

иногда при нештатном выключении биос слетает и машина вообще никак не грузится. видела такие материнки, которые юзеры возвращали, как «сломанные». у меня работают до сих пор :)

Iron_Bug ★★★★ ()
Ответ на: комментарий от Iron_Bug

попробуй для начала хардварно сбросить биос

Пробовал. Батарейку доставал, ставил на место. Изменений нет. Грузится, зараза, с liveusb, да и с жесткого диска загрузчик стартует, но ОС с диска не загружается.

aharsisis ()
Ответ на: комментарий от iliyap

дельный совет. проверить настройки контроллера в биосе тоже не помешает.

Iron_Bug ★★★★ ()

ALERT! /dev/disk/by-uuid/ca......................747 does not exist.

в генте вроде тут недавно новость пролетала:

2016-11-04-important_fstab_and_localmount_update
  Title                     Important fstab and localmount update
  Author                    William Hubbs <williamh@gentoo.org>
  Author                    Ian Stakenvicius <axs@gentoo.org>
  Posted                    2016-11-04
  Revision                  2

Recent updates to service scripts in OpenRC and (e)udev have removed the
requirement for udev to "settle" before its startup completes.  The
result of this is that services which used to wait for udev to finish
processing all kernel events will now start earlier.  One such service
is localmount.

If "/dev/disk/by-*" device paths are used for mount points in
fstab, it is possible that those symbolic links  will not exist when
localmount starts and attempts to mount them.

The recommended solution is to convert fstab from using
"/dev/disk/by-*" to the LABEL=, UUID=, PARTLABEL= or PARTUUID= syntax.
This syntax is supported directly by both util-linux and busybox's mount
commands and has no dependency on any device manager. More information
on this syntax can be found in the fstab(5) and mount(8) man pages.

To force the old behaviour, instead of converting fstab, you can add
rc_want="dev-settle" to /etc/conf.d/localmount or add udev-settle to the
sysinit runlevel.

Deleted ()
Ответ на: циферки от 0 и далее от aharsisis

sudo -i echo "---«>/sys/class/scsi_host/host0/scan

это и не должно работать.
надо

sudo echo "- - -" > /sys/class/scsi_host/host0/scan
просто скопируйте эту команду, потом выполните с цифрой 1 и т.д.

bdfy ★★★★★ ()
Ответ на: комментарий от Iron_Bug

дельный совет. проверить настройки контроллера в биосе

Всё было установлено:
SATA Mode ...............................AHCI Mode
При просмотре параметров обнаружено:
Процессор очень быстро нагрелся выше 70 градусов (хотя простаивал, я только зашел в BIOS и смотрел параметры, раньше такого не наблюдал).
А как сюда скрин вставить?

aharsisis ()
Ответ на: комментарий от bdfy

это и не должно работать.

Всё равно, сообщение:
bash: /sys/class/scsi_host/host0/scan: Доступ запрещён.

aharsisis ()
Ответ на: комментарий от bdfy

Попробуйте через sudo su - далее echo "- - -" > /sys/class/scsi_host/host0/scan (т.е. без sudo)

Дрянь какая-то...
sudo echo "- - -" > /sys/class/scsi_host/host0/scan
доступа нет;
sudo su echo "- - -" > /sys/class/scsi_host/host0/scan
доступа нет;
su echo "- - -" > /sys/class/scsi_host/host0/scan
доступа нет;
Минут 15 назад сделал liveusb:
sudo dd и т.д. и т.п. - всё сработало, а счас нет...

aharsisis ()
Ответ на: комментарий от bdfy

ls -la /sys/class/scsi_host/

Блин, только что выключил комп.
Смотрел содержимое, там ссылки на каталоги host0 - host5.

aharsisis ()
Ответ на: комментарий от bdfy

ls -la /sys/class/scsi_host/

Всем огромное спасибо за помощь.
Закругляюсь, иначе разнесу нафиг этот винт.

aharsisis ()

Re: Попробуйте через sudo su - далее echo "- - -" > /sys/class/scsi_host/host0/scan (т.е. без sudo)

Прикалываетесь?

Ясно же, что перенаправление срабатывает в шелле пользователя, до того, как запустится sudo и появятся права суперпользователя. Либо запускать команду из root'ового шела (получаемого, допустим через ″sudo -i″), либо ″echo "- - -" | sudo tee /sys/class/scsi_host/host0/scan

В bios зачастую нагрузка на проц большая, там максимально простой код, непрерывно ожидающий нажатия на клавишу, но, если раньше проц не грелся так сильно, значит, либо пылью радиатор забило, либо ослаб прижим радиатора к процессору.

И, если комп давно не чистили, то проблемы с винтом могуть быть, помимо плохого напряжения с БП, из-за пыли на ножках чипсета. Изучите вывод dmesg при загрузки с liveusb, может там есть какие сообщения об ошибках про винт/контроллер винта.

mky ★★★★★ ()
Ответ на: комментарий от Iron_Bug

дельный совет. проверить настройки контроллера

Всем доброго времени суток и хорошего настроения. iliap оказалась права, надеюсь, как всегда! Сегодня почистил комп (два ведра пыли), потом полез играться с uefi. Вчера этого не заметил, но, оказалось sata mode был отмечен Disable, сменил флажок на Enable и всё заработало. Тупо слетели настройки... Ещё раз всех благодарю за советы. Тему закрываю.

aharsisis ()

Re: Попробуйте через sudo su - далее echo "- - -" > /sys/class/scsi_host/host0/scan (т.е. без sudo)

У тебя с правами рута только echo выполняется (которому пофиг), а перенаправление в системный файл всё равно с правами юзера выполняется. Такое надо или залогинившись под рутом выполнять, или su -c 'вся команда'

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.