LINUX.ORG.RU

Проблемы с роутером asus RT-N66U

 , ,


0

2

Имеется роутер Asus RT-N66U. Есть неприятная особенность, а именно периодически на разных устройствах (ноутбук, планшет) отваливается подключение по Wi-Fi 5 GHz, т.е. на самих девайсах сеть отключается и пропадает из списка доступных, а если зайти в админку роутера, то в системном журнале отвалившееся устройство отображается как до сих пор подключенное и пока не перезагрузить роутер или не выключить/включить радиомодуль 5 GHz роутера (т.е. не сбросить это соединение на стороне роутера) на девайсах сеть будет недоступна (точнее может стать доступна через какое-то время, от нескольких десятков секунд до часа). При этом это проблема не зависит от интенсивности использования подключения и загрузки роутера, и может проявляться через случайные промежутки времени (хотя на ноуте проявляется регулярно раз в несколько часов, на планшете asus не очень часто, а на планшете samsung почти никогда). Т.к. на стороне роутера стояла дефолтная прошивка asuswrt последней версии и в доступных логах нет ничего интересного, поставил прошивку от merlin-а, что не исправило ситуации, но теперь на роутер можно зайти по ssh (правда еще не пробовал). Кроме того, по умолчанию в роутере для 5 GHz была включена опция «Автоматический выбор канала, включая каналы DFS», с которой Wi-Fi на ноуте отваливался почти сразу, после поиска на форумах и отключения этого параметра Wifi 5G теперь работает как описано выше (отваливается через случайные промежутки времени, но может работать стабильно на протяжении длительного количества часов).

Лог на ноуте:

янв 15 19:49:22 ctgx wpa_supplicant[511]: wlp2s0: SME: Trying to authenticate with e0:3f:49:04:c5:ec (SSID='vrotebat_5G' freq=5200 MHz)
янв 15 19:49:36 ctgx NetworkManager[488]: <warn>  [1484498976.6404] device (wlp2s0): Activation: failed for connection 'vrotebat_5G'
янв 15 19:49:36 ctgx plasmashell[684]:  New Notification:  "vrotebat_5G" "Соединение «vrotebat_5G» отключено." -1 & Part of: 0
янв 15 19:52:21 ctgx NetworkManager[488]: <info>  [1484499141.7761] policy: auto-activating connection 'vrotebat_5G'
янв 15 19:52:21 ctgx NetworkManager[488]: <info>  [1484499141.7796] device (wlp2s0): Activation: starting connection 'vrotebat_5G' (0226d987-9ada-47a2-a2d8-b39fccfa3057)
янв 15 19:52:21 ctgx NetworkManager[488]: <info>  [1484499141.8015] device (wlp2s0): Activation: (wifi) access point 'vrotebat_5G' has security, but secrets are required.
янв 15 19:52:21 ctgx NetworkManager[488]: <info>  [1484499141.8179] device (wlp2s0): Activation: (wifi) connection 'vrotebat_5G' has security, and secrets exist.  No new secrets needed.
янв 15 19:52:21 ctgx NetworkManager[488]: <info>  [1484499141.8179] Config: added 'ssid' value 'vrotebat_5G'
янв 15 19:52:22 ctgx wpa_supplicant[511]: wlp2s0: SME: Trying to authenticate with e0:3f:49:04:c5:ec (SSID='vrotebat_5G' freq=5200 MHz)
янв 15 19:52:22 ctgx wpa_supplicant[511]: wlp2s0: Trying to associate with e0:3f:49:04:c5:ec (SSID='vrotebat_5G' freq=5200 MHz)
янв 15 19:52:22 ctgx NetworkManager[488]: <info>  [1484499142.7408] device (wlp2s0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'vrotebat_5G'.
янв 15 19:52:23 ctgx plasmashell[684]:  New Notification:  "vrotebat_5G" "Соединение «vrotebat_5G» установлено." -1 & Part of: 0
янв 15 19:52:48 ctgx NetworkManager[488]: <info>  [1484499168.5538] policy: set 'vrotebat_5G' (wlp2s0) as default for IPv4 routing and DNS
янв 15 19:52:48 ctgx NetworkManager[488]: <info>  [1484499168.6333] policy: set 'vrotebat_5G' (wlp2s0) as default for IPv6 routing and DNS
02:00.0 Network controller: Intel Corporation Wireless 3165 (rev 79)

Как пофиксить проблему, может что подкрутить в настройках роутера или на ноуте?


New Notification: «vrotebat_5G» «Соединение «vrotebat_5G» установлено.»

зачем же ты так с своей точкой доступа?

kiotoze ★★★★ ()
Ответ на: комментарий от tm4ig

Я тебе советую не абы что, а проверенный вариант, у меня есть такая же железка.

King_Carlo ★★★★★ ()
Ответ на: комментарий от King_Carlo

Везде пишут что требуется для прошивки asus firmware restoration, но при запуске через wine он не находит роутер. Есть руководство как правильно прошивать не из под винды?

tm4ig ()
Ответ на: комментарий от King_Carlo

Ага, все верно, просто походу ван провод не вытащил плюс рекомендуют 4 лан порт использовать

tm4ig ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.