LINUX.ORG.RU

Запретить даунгрейд пакета.

 ,


0

1

Добра, ЛОР-пони.

Имеем Parabola GNU/Linux-libre, т.е. свободный Arch, и пакет xfce-theme-greybird, установленный из AUR (aur/xfce-theme-greybird-3.22.0-1), который при апгрейде системы зачем-то замещается из репозитория Parabola версией ниже (pcr/xfce-theme-greybird-3.20.1-1), что совсем не хорошо. Я, конечно, добавил этот пакет в IgnorePkg, но это уже какой-то костыль. Есть вариант запретить снижать версию пакета, не добавляя его в игнор и не отключая репозиторий?

Ответ на: комментарий от HashDerpy

Вот скажи честно ты читал справку прежде, чем применять эти ключи? В частности uu ?

За беспричинное yy я бы тоже применял жесткие санкции.

surefire ★★★ ()
Последнее исправление: surefire (всего исправлений: 1)
Ответ на: комментарий от surefire

Ах, да, Я дурак, в мане ведь это описано.

Во всяком случае, ещё такой вопрос: от ворнинга никак не избавиться?

Warning: xfce-theme-greybird: local (3.22.0-1) is newer than pcr (3.20.1-1)

HashDerpy ()
Ответ на: комментарий от HashDerpy

Нужно проверять, скорее всего если сделать локальный репозиторий с этим пакетом, и поставить его раньше официальных.

surefire ★★★ ()

мб в

/etc/pacman.conf

Найти строчку

#IgnorePkg   = 

Раскомментировать и вписать туда нужный пакет

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.