LINUX.ORG.RU

Сборка пакета, с определенной версией библиотеки.

 ,


0

2

Добрый день.
Подскажите пожалуйста, хочу собрать пакет xfce4-notifyd из sid в stable.
Поставил все зависимости. В debian/control исправил 3.20 на 3.14
Проблема как раз в этом, если я правильно понял README, то этот пакет можно собрать с gtk+ 3.14.0.
, но во время сборки пакета происходит ошибка. Как я понял, сборщик пытается собрать используя библиотеки версии 3.20. Посмотрев исходный код я понял, что там можно передать как-то параметры, чтобы использовать 3.14 (ну и по README логично, что собрать с 3.14 можно).
Вопрос, как это сделать?
Спасибо.

Ответ на: комментарий от rezedent12

Я там ни чего не меняю. Все стандартно. Ставлю зависимости и далее debuild -us -uc
там как-то можно передать параметры, а вот как не понятно.

h784214 ()

./configure --help - может GTK_LIBS можно настроить (посмотреть на выхлоп pkg-config --libs gtk => поправить для 3.14)

anonymous ()

На unixforum.org написали, что это сделать нельзя.
может это и так. Как использовать pkg-config я не знаю и как настроить GTK_LIBS тоже (пробовал только экспортировать, как переменную с разными значениями).

h784214 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.