LINUX.ORG.RU

squid, проблема с присвоением DNS у клиентов

 ,


0

1

Добрый день. Столкнулся с такой проблемой. Настроен squid на Debian. Интернет раздается через несколько роутеров. Какое-то время все было нормально. Но недавно при подключении к Интернет вылезает «Не удается найти DNS Adress сервера». Работает все (скайп, вайбер и т.п.) кроме браузеров и почтового клиента. Посмотрел что выдает DHCP сервер - IP-адрес, шлюз - ок, но DNS выглядит так: 192.168.100.3 либо, если несколько раз включить-выключить сеть, 192.168.100.7. Должно же быть 192.168.100.251, 192.168.0.249. При выставлении DNS у клиента вручную все конечно же работает нормально. 192.168.100.3 и 192.168.100.7 - это IP-адреса роутеров в сети (при этом я подключаюсь к роутеру 192.168.100.6). Во всех роутерах DHCP-сервера отключены. Такая беда проявляется не на всех компьютерах. Замечены 1 под Win XP, 2-Win 7, 1-Win 8. На андроидах пока не замечал. Часто спустя какое-то время через браузеры можно ходить в интернет. Иногда при этом DNS не меняется (у клиента) иногда изменяется на тот, что настроен на сервере. Кто может подсказать в чем проблема?

Ответ на: комментарий от daemonpnz

При том, что он не дает нужный DNS, и на роутерах отключено все - и DHCP и DNS и они просто как точки доступа работают. Отключать на них уже больше нечего. Нужно решить это на squid.

drugojandrew ()
Ответ на: комментарий от drugojandrew

При том, что он не дает нужный DNS

Потому, что это не его дело. Я вам скажу даже более вы можете вообще не указывать DNS, а в настройках браузера только указать IP адрес прокси сервера и порт и всё будет работать.

kostik87 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.