LINUX.ORG.RU

Установка Fedora Core 4 на RAID


0

0

Просьба не пинать сильно (тока учусь)
Есть материнка gygabyte 8i915pl на ней raid via vt6410
скачал для нее VIA RAID Linux driver делаю как в инструкции
make и получаю следующее:
[root@altair driver]# make
gcc -c -DVIA_LINUX -DMULTIPLE_CARD_SUPPORT -DMODULE -D__KERNEL__=1 -O -DMODVERSIONS -I/usr/src/linux/include -I/usr/src/linux/include/asm -I/usr/src/linux/drivers/scsi -Wall  viapubraid.c
In file included from viapubraid.h:9,
                 from viapubraid.c:21:
/usr/include/linux/modversions.h:1:2: error: #error Modules should never use kernel-headers system headers,
/usr/include/linux/modversions.h:2:2: error: #error but rather headers from the appropriate kernel package.
/usr/include/linux/modversions.h:3:2: error: #error Change -I/usr/src/linux/include (or similar) to
/usr/include/linux/modversions.h:4:2: error: #error -I/lib/modules/$(uname -r)/build/include
/usr/include/linux/modversions.h:5:2: error: #error to build against the currently-running kernel.
In file included from /usr/src/linux/include/linux/irq.h:21,
                 from /usr/src/linux/include/asm/hardirq.h:6,
                 from /usr/src/linux/include/linux/hardirq.h:6,
                 from /usr/src/linux/include/linux/interrupt.h:11,
                 from /usr/src/linux/include/asm/highmem.h:24,
                 from /usr/src/linux/include/linux/highmem.h:12,
                 from /usr/src/linux/include/linux/pagemap.h:10,
                 from /usr/src/linux/include/linux/blkdev.h:10,
                 from /usr/include/linux/blk.h:4,
                 from viapubraid.h:23,
                 from viapubraid.c:21:
и так далее по порядку
Если нужно то могу скинуть продолжение сообщений об ошибках (оно большое)

Re: Установка Fedora Core 4 на RAID

Есили у тебя стоит kernel-devel поставь лучше kernel-x.x.x.src.rpm из сорцов в devel находятся только headers так как raid надо собрать новый модуль.

anonymous ()

Re: Установка Fedora Core 4 на RAID

>Просьба не пинать сильно (тока учусь)

Ну, держи несильно. Научись сначала читать:-)

>#error Modules should never use kernel-headers system headers ... Change -I/usr/src/linux/include (or similar) to -I/lib/modules/$(uname -r)/build/include

Что непонятно? Замени в Makefile-е указаное указаным.

DonkeyHot ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.