LINUX.ORG.RU

kali linux make[1]: *** /lib/modules/4.3.0-kali1-amd64/build: Нет такого файла или каталога. Останов.

 ,


0

1

Установил Kali linux 2.0 когда пытаюсь установить драйвера для rtl8812 Выдаёт: root@hack:~/rtl8812au_rtl8821au# make make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.3.0-kali1-amd64/build M=/root/rtl8812au_rtl8821au modules make[1]: *** /lib/modules/4.3.0-kali1-amd64/build: Нет такого файла или каталога. Останов. Makefile:1565: ошибка выполнения рецепта для цели «modules» make: *** [modules] Ошибка 2 Обыскал весь интернет нигде не нашёл ответа. Помогите пожайлусто а то уже несколько часов пытаюсь это исправить.

/lib/modules/4.3.0-kali1-amd64/build сделай эту ссылку build, на исходники ядра должна указывать.

irton ★★★★★ ()

Установи пакет с заголовочными файлами ядра

apt-get install linux-headers-`uname -r`

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

после ввода выдаёт root@hack:~# apt-get install linux-headers-`uname -r` Чтение списков пакетов… Готово Построение дерева зависимостей Чтение информации о состоянии… Готово E: Не удалось найти пакет linux-headers-4.3.0-kali1-amd64 E: Не удалось найти пакет с помощью glob «linux-headers-4.3.0-kali1-amd64» E: Не удалось найти пакет с помощью regex «linux-headers-4.3.0-kali1-amd64»

tetrinol ()
Ответ на: комментарий от tetrinol

Обнови список пакетов перед установкой их.

apt-get update

Да и вообще удосужься уж почитать документацию по Debian-based дистрибутивам вообще и apt в частности.

Посмотри где находится файл настроек с источниками пакетов, репозиториями, почитай как работать с пакетным менеджером.

А то без этого из тебя хакера не получится.

kostik87 ★★★★★ ()
Ответ на: комментарий от tetrinol

Репозиторий подключен?

В репозитории пакет есть: http://http.kali.org/kali/pool/main/l/linux/linux-headers-4.3.0-kali1-amd64_4...

Так что проверяй какие репозитории подключены, подключай их и обновляй список пакетов.

http://docs.kali.org/general-use/kali-linux-sources-list-repositories

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

после добавления репозиториев тоже самое sources.lits: #

# deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20160$

#deb cdrom:[Debian GNU/Linux 2016.1 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 201601$

deb http://http.kali.org/kali kali-rolling main non-free contrib # deb-src http://http.kali.org/kali kali-rolling main non-free contrib deb http://packages.linuxmint.com/ nadia main upstream import deb http://archive.ubuntu.com/ubuntu/ quantal main restricted universe multiverse deb http://archive.ubuntu.com/ubuntu/ quantal-updates main restricted universe multiverse deb http://security.ubuntu.com/ubuntu/ quantal-security main restricted universe multiverse deb http://archive.canonical.com/ubuntu/ quantal partner deb http://packages.medibuntu.org/ quantal free non-free #deb http://archive.getdeb.net/ubuntu quantal-getdeb apps #deb http://archive.getdeb.net/ubuntu quantal-getdeb games deb http://http.kali.org/kali sana main non-free contrib deb http://security.kali.org/kali-security sana/updates main contrib non-free deb http://http.kali.org/kali kali-rolling main contrib non-free deb-src http://http.kali.org/kali kali-rolling main contrib non-free deb-src http://http.kali.org/kali sana main non-free contrib deb-src http://security.kali.org/kali-security sana/updates main contrib non-free

tetrinol ()
Ответ на: комментарий от tetrinol

Так, пакет в репозитории есть, разбирайся.

Ты пишешь, что у тебя Kali Linux 2.0, зачем в таком случае подключил репозиторий от kali-rolling?

kostik87 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.