LINUX.ORG.RU

Не корректно работают команды рестарта

 ,


0

1

Привет, форум. Стоит Ubuntu 14.04.4 amd64. Все обновления накатаны. Команды:

shutdown -r X
reboot (-f)
init 6
Alt+SysRq+REISUB
не работают адекватно. После использования доходит до:
reboot: restarting system
reboot: machine restart
а потом ничего. Бук просто застывает. Никаких ошибок в логах нет, кроме этой:
sp5100_tco: unexpected close, not stopping watchdog!
Связана ли она с проблемой, я не знаю. Очень мало информации о проблемах с вочдогом. Из того, что уже поробовал: 1. В /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT добавлял параметры:
reboot=warm(cold,bios,smp,triple.kdb,efi,acpi,pci,force)
. и апдейтил граб. Граб, кстати, 2ой. Пробовал:
acpi=force reboot=acpi
При этом бук просто выключается. 2. Запускал мемтест дефолтный и отдельную прогу с загрузочной. Никаких ошибок не нашло. 3. Пробовал переключаться между проприетарщиной и осс. 4. Переустанавливал 2 раза систему. Гуглил много времени. Проблему с рестартом в целом находил, но решалось все кверками. У меня же от них толку нет. Вот скрин с ребута: http://storage8.static.itmages.ru/i/16/0324/h_1458829278_8344522_f444756286.jpg Буду очень признателен за помощь. Проблема хоть и не критичная, но каждый раз выключать/включать в ручную не удобно.


Попробуй на каком-нибудь другом лайвсиди-дистре поновее. На Арчике, например. Ещё в биосе какие-нибудь настройки ACPI глянь.

Чтобы быть уверенным, что, например 'acpi=force' передаётся грабом, можно, во-первых, при загрузке, в меню граба нажать E для редактирования строки параметров и записать туда этот параметр вручную, если его там ещё нет, а во-вторых, после загрузки можно проверить 'cat /proc/cmdline' на наличие этого параметра.

anonymous ()
Ответ на: комментарий от anonymous

Пробовал на 15.10 и дебе пару часов назад, везде все одно. В принципе все варианты стандартные из гугла я попробовал, потому и пишу. Вывод cmdline подтверждает наличие бут параметров. Бьюсь уже сколько времени с этой проблемой.

B4M ()

Поставил kexec. И холодный, и «ядерный» ребут работают без проблем. Тем не менее, проблема актуальна.

B4M ()
Ответ на: комментарий от slamd64

Asus. Не в модели дело... Ребут работал идеально до какого то момента. Ниразу за полотора года сидения на линях не было проблем. А потом что то произошло (что?????), и теперь на любом дистре не работает рестарт. Я сперва сделал вывод, что раз на разных дистрах одно и то же, проблема в железе или в биосе. Но все проверив, ничего не нашел. Теперь ищу костыли.

B4M ()
Ответ на: комментарий от slamd64

Старый вариант чего? Если ОСи, то ее пол года уже нет. Успел посидеть на трех других, увы. И даже возврат к тому дистру, с которым ребут работал, не помог. Попробовал сейчас еще лайв сиди с сусом, дебом, хубунту, федорой. Все одно. Рестарт не работает...

B4M ()
Ответ на: комментарий от B4M

Может, всё-таки, проблема аппаратная? ACPI/PM помер...

slamd64 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.