LINUX.ORG.RU

Compton и функция повер всех окон!

 ,


0

1

Добрый день/ночь! У меня Lubuntu 15.10 установил compton захотелось мне тени, затухание и самое главное из-за чего поставил compton это прозрачность HE активных окон! Все работает, спасибо инету легко найти инструкции по настройке и много разных готовых compton.conf-ов. Но, ни где не могу найти решение как сделать исключение для Compton, что бы он не затемнял окно если в нем включена функция «по верх всех окон»! Есть подобные решения для conky, что бы compton не затемнял conky на заднем плане то пишеться в файле compton.conf такая строка

focus-exclude = [ «class_g = 'conky'» ];

Или можно сделать исключение на не/прозрачность определенного/ных окна/н

opacity-rule = [ 'class_g = «conky»:1.00' ]

так же на примере для conky, что бы conky всегда имели прозрачность 100%...

А вот как «прикрутить» подобное/ые исключения для того, что бы compton не затемнял окна с включенной функцией «по верх всех окон» я не знаю! PLEAS HELP!!!

спроси в репе, chjj парнишка отзывч, отбой, там и так 120 issues, только что глянул, даже драма есть.

kep ()

Добавь в wintypes правило:

wintypes:{
	desktop = { opacity = false; };
};
Естественно, если у тебя коньки имеют тип десктоп, иначе работать не будет.

r3lgar ★★★★★ ()
Ответ на: комментарий от sudopacman

вряд ли как-то возможно

Выше я привёл реализацию, вполне себе рабочую, при этом я даже не открывал ман. Ты стараешься набить себе скора, но не путём 4.2 это делай, пожалуйста.

r3lgar ★★★★★ ()
Ответ на: комментарий от kep

chjj отзывчив, но он не справляется. Ему лучше не хотелки хотеть в иссуях, а пулл-реквесты слать.

А насчёт количества иссуй: у qutebrowser их порой больше, но ничо, чел справляется. Тут зависит от того, насколько девелопер способен решать определённую нагрузку. Питонокодерам проще, особенно, если они пишут свои костыли на PyQt, лол.

r3lgar ★★★★★ ()
Ответ на: комментарий от sudopacman

Сможешь пересказать его хотелку нормальным языком и без ошибок? А то я кроме коньков ничерта не понял. В тайтле написано про какую-то силу окон, в ОП — про их верх, куча ненужных восклицательных знаков, код в кучу. (%

r3lgar ★★★★★ ()
Последнее исправление: r3lgar (всего исправлений: 1)
Ответ на: комментарий от r3lgar

Короче: он включил функцию, что когда окно не в фокусе, оно становится прозрачным (ну или затемняется, я так и не понял, что именно). И он не хочет, чтобы окна, котороым он назначил «Always on top», затемнялись, если с них убрать фокус (но при этом они останутся висеть поверх всех окон). Хотя если окно становится прозрачным, то это даже фича, чтобы было видно окна, которые под ним.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

в комптоне можно смотреть на любой атом, т.е. можно подобрать условие для любого подмножества окон, которое может отличать какая-либо другая программа.

f1u77y ★★★ ()
Ответ на: комментарий от r3lgar

она не рабочая, потому что чувак хочет выделить подмножество окон с _NET_WM_STATE_ABOVE

«не открывал ман» — настолько низкий уровень хвастовства, что даже мои одноклассники не заценивают

f1u77y ★★★ ()
Ответ на: комментарий от f1u77y

Спасибо всем ответившим!

opacity-rule = [«_NET_WM_STATE@:a *= 'ABOVE':1.00»]

Попробовал добавить эту строчку в код compton.conf не помогает! Сделал скриншот, что бы было наглядно видно проблему! http://i053.radikal.ru/1603/01/1b6c05693021.png Как видно на скриншоте активное окно сейчас это браузер в котором открыта странничка google. По верх googlе открыт файловый менеджер и у него активирована функция «Always on top» функция то работает и окно всегда поверх других окон но, Compton делает его полупрозрачным а должен оставлять его не прозрачным так же как и активное окно! Подскажите как решить эту проблему?

Yashalta ()
Ответ на: комментарий от Yashalta

Добавляю код фалйла "compton.conf"

# Shadow shadow = true; #shadow = false; no-dnd-shadow = true; no-dock-shadow = true; #clear-shadow = true; shadow-radius = 7; shadow-offset-x = 3; shadow-offset-y = 3; shadow-opacity = 0.7; # shadow-red = 0.0; # shadow-green = 0.0; # shadow-blue = 0.0;

## Remove Shadow from CONKY WINDOW ## ## compliments mrpeachy and falldown # use wininfo to determine window name -OR- in the conky: # own_window_class conky_logo # Then just simply use: # shadow-exclude = «i:e:window-name»; # Use brackets and comma for more then one window # shadow-exclude = [«i:e:conky_logo»,«i:e:conkyw»,«i:e:S11»,«i:e:test»]; # shadow-exclude = «i:e:Conky»; ############## try this ################# # shadow-exclude = [«i:e:Conky»,«i:e:interactiveconky»,«i:e:click_log»]; shadow-exclude = «i:e:conky_logo»; opacity-rule = [«_NET_WM_STATE@:a *= 'ABOVE':1.00»]

shadow-ignore-shaped = false;

# Opacity menu-opacity = 1; # The opacity for menus. (default 1.0) inactive-opacity = 0.5; # Default opacity of inactive windows. (0.0 - 1.0) # active-opacity = 0.8; # Default opacity for active windows. (0.0 - 1.0) frame-opacity = 0.7; # Opacity of window titlebars and borders. (0.1 - 1.0) inactive-opacity-override = false; # Let inactive opacity set by 'inactive-opacity' overrides focus-exclude = [ «class_g = 'conky_logo'» ]; # value of _NET_WM_OPACITY. Bad choice. alpha-step = 0.06; # XRender backend: Step size for alpha pictures. Increasing # it may result in less X resource usage, # Yet fading may look bad. #inactive-dim = 0.5; # Dim inactive windows. (0.0 - 1.0) # inactive-dim-fixed = true; # Do not let dimness adjust based on window opacity. # blur-background = true; # Blur background of transparent windows. # Bad performance with X Render backend. # GLX backend is preferred. # blur-background-frame = true; # Blur background of opaque windows with transparent # frames as well. #blur-background-fixed = false; # Do not let blur radius adjust based on window opacity. #blur-background-exclude = [ «window_type = 'dock'», «window_type = 'desktop'» ]; # Exclude conditions for background blur.

# Fading fading = true; # fade-delta = 30; fade-in-step = 0.015; fade-out-step = 0.03; # no-fading-openclose = true;

# Other mark-wmwin-focused = true; mark-ovredir-focused = true; detect-rounded-corners = true; detect-client-opacity = true; #refresh-rate = 0; #vsync = «none»; dbe = false; paint-on-overlay = false; sw-opti = false;

# Window type settings wintypes: { tooltip = { fade = true; shadow = false; opacity = 0.85; }; };

Yashalta ()
Ответ на: комментарий от f1u77y

Ни чего не происходит! Ниже текст из терминала, я и «sudo» добавлял...

zerg@zerg-swarm:~$ xprop _NET_WM_STATE
_NET_WM_STATE(ATOM) = 
zerg@zerg-swarm:~$ sudo xprop _NET_WM_STATE
[sudo] пароль для zerg: 
_NET_WM_STATE(ATOM) = 
zerg@zerg-swarm:~$ 

У меня есть идея. Когда я добавлял функцию «Поверх всех окон»/ «AlwaysOnTop» то я файле «lubuntu-rc.xml» добавил одну лишь строчку <action name=«ToggleAlwaysOnTop»/> как сказанно в этой инструкции http://www.lubuntu.ru/forum/viewtopic.php?f=15&t=2538 Так может написать исключение для Compton, что мол когда он обнаружит действие «ToggleAlwaysOnTop» то применить к этому окну правило например: opacity-rule = [ 'class_g = «ToggleAlwaysOnTop»:1.00' ] или focus-exclude = [ «class_g = 'ToggleAlwaysOnTop'» ];

Yashalta ()
Ответ на: комментарий от Yashalta

не нужно тут sudo

ок, тогда покажи полный вывод xprop по этому окну

Так может написать исключение для Compton, что мол когда он обнаружит действие «ToggleAlwaysOnTop»

я это и хотел. при этом, ЕМНИП, окна, которые всегда наверху, имеют атом _NET_WM_STATE_ABOVE, что и должно было позвоить определить эти окна

f1u77y ★★★ ()
Последнее исправление: f1u77y (всего исправлений: 1)
Ответ на: комментарий от f1u77y

ок, тогда покажи полный вывод xprop по этому окну

Так нет ни чего! вот я

zerg@zerg-swarm:~$ xprop _NET_WM_STATE
_NET_WM_STATE(ATOM) = 
zerg@zerg-swarm:~$ xprop _NET_WM_STATE
_NET_WM_STATE(ATOM) = 
zerg@zerg-swarm:~$ 
zerg@zerg-swarm:~$ xprop _NET_WM_STATE
_NET_WM_STATE(ATOM) = 
zerg@zerg-swarm:~$ xprop _NET_WM_STATE
_NET_WM_STATE(ATOM) = 
zerg@zerg-swarm:~$ 
после ввода соманды xprop _NET_WM_STATE курсор становиться «крестиком» я кликаю на открытое окно терминала или файлового менеджера и мне выдает только это «_NET_WM_STATE(ATOM) =» после чего снова ждет команды...

Yashalta ()
Ответ на: комментарий от f1u77y

нет, я имел в виду вывод xprop без параметров

Сори не догнал! Ниже код после ввода команды «xprop» и щелкнул на открытом файловом менеждере. [spoiler=]

zerg@zerg-swarm:~$ xprop
_NET_WM_ICON_GEOMETRY(CARDINAL) = 572, 876, 150, 24
WM_STATE(WM_STATE):
		window state: Normal
		icon window: 0x0
_NET_WM_DESKTOP(CARDINAL) = 0
_NET_WM_ALLOWED_ACTIONS(ATOM) = _NET_WM_ACTION_CHANGE_DESKTOP, _NET_WM_ACTION_SHADE, _NET_WM_ACTION_CLOSE, _NET_WM_ACTION_MOVE, _NET_WM_ACTION_MINIMIZE, _NET_WM_ACTION_RESIZE, _NET_WM_ACTION_FULLSCREEN, _NET_WM_ACTION_MAXIMIZE_HORZ, _NET_WM_ACTION_MAXIMIZE_VERT, _NET_WM_ACTION_ABOVE, _NET_WM_ACTION_BELOW, _OB_WM_ACTION_UNDECORATE
_KDE_NET_WM_FRAME_STRUT(CARDINAL) = 1, 1, 26, 4
_NET_FRAME_EXTENTS(CARDINAL) = 1, 1, 26, 4
_NET_WM_STATE(ATOM) = 
_OB_APP_TYPE(UTF8_STRING) = "normal"
_OB_APP_TITLE(UTF8_STRING) = "zerg"
_OB_APP_GROUP_CLASS(UTF8_STRING) = "Pcmanfm"
_OB_APP_GROUP_NAME(UTF8_STRING) = "pcmanfm"
_OB_APP_CLASS(UTF8_STRING) = "Pcmanfm"
_OB_APP_NAME(UTF8_STRING) = "pcmanfm"
_OB_APP_ROLE(UTF8_STRING) = 
_NET_WM_VISIBLE_ICON_NAME(UTF8_STRING) = "Загрузки"
_NET_WM_VISIBLE_NAME(UTF8_STRING) = "Загрузки"
WM_HINTS(WM_HINTS):
		Client accepts input or input focus: True
		Initial state is Normal State.
		bitmap id # to use for icon: 0x18007cb
		bitmap id # of mask for icon: 0x18007cc
		window id # of group leader: 0x1800001
XdndAware(ATOM) = BITMAP
_MOTIF_DRAG_RECEIVER_INFO(_MOTIF_DRAG_RECEIVER_INFO) = 0x6c, 0x0, 0x5, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x10, 0x0, 0x0, 0x0
_NET_WM_ICON(CARDINAL) = 	Icon (32 x 32):
                                                

	Icon (128 x 128):
	                                                       
	Icon (256 x 256):
	(not shown)	Icon (16 x 16):
	   
                       
	Icon (24 x 24):
	                    
_NET_WM_SYNC_REQUEST_COUNTER(CARDINAL) = 25167818
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_NORMAL
_NET_WM_USER_TIME(CARDINAL) = 3295637
_NET_WM_USER_TIME_WINDOW(WINDOW): window id # 0x18007c9
WM_CLIENT_LEADER(WINDOW): window id # 0x1800001
_NET_WM_PID(CARDINAL) = 1755
WM_LOCALE_NAME(STRING) = "ru_RU.UTF-8"
WM_CLIENT_MACHINE(STRING) = "zerg-swarm"
WM_NORMAL_HINTS(WM_SIZE_HINTS):
		program specified minimum size: 496 by 142
		window gravity: NorthWest
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW, WM_TAKE_FOCUS, _NET_WM_PING, _NET_WM_SYNC_REQUEST
WM_CLASS(STRING) = "pcmanfm", "Pcmanfm"
WM_ICON_NAME(COMPOUND_TEXT) = "Загрузки"
_NET_WM_ICON_NAME(UTF8_STRING) = "Загрузки"
WM_NAME(COMPOUND_TEXT) = "Загрузки"
_NET_WM_NAME(UTF8_STRING) = "Загрузки"
zerg@zerg-swarm:~$ 
[/spoiler]

Yashalta ()
Ответ на: комментарий от Yashalta

Могу сделать тоже самое только для самого терминала т.к. он является активным окном, на момент наведения крестикообразного курсора.

Yashalta ()
Ответ на: комментарий от Yashalta

я уж даже подумал, может с опенбоксом что не то.

пускаю я, значит, openbox, и делаю на окне «layers -> always on top». затем мне xprop _NET_WM_STATE по окну говорит:

$ xprop _NET_WM_STATE
_NET_WM_STATE(ATOM) = _NET_WM_STATE_ABOVE

ты ведь совершаешь те же действия?

и на всякий случай openbox --version

f1u77y ★★★ ()
Последнее исправление: f1u77y (всего исправлений: 2)
Ответ на: комментарий от region51

Не знаю, несколько лет назад он точно был отзывчив.

r3lgar ★★★★★ ()
Ответ на: комментарий от f1u77y

Вот что я делаю. Активирую функцию «по верх всех окон» далее в терминале ввожу код «xprop _NET_WM_STATE» и кликаю крестикообразным курсором по окну в котором активирована функция «по верх всех окон». Сделал 2 раза первый раз на автивированном терминале 2-й раз на файловом менеджере. Ниже ввел код «openbox --version» [spoiler=]

zerg@zerg-swarm:~$ xprop _NET_WM_STATE _NET_WM_STATE(ATOM) = _NET_WM_STATE_ABOVE 
zerg@zerg-swarm:~$ xprop _NET_WM_STATE _NET_WM_STATE(ATOM) = _NET_WM_STATE_ABOVE 
zerg@zerg-swarm:~$ openbox --version Openbox 3.6.1 Copyright (c) 2004 Mikael Magnusson Copyright (c) 2002 Dana Jansens

This program comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to redistribute it under certain conditions. See the file COPYING for details.

zerg@zerg-swarm:~$
[/spoiler] PS - раньше делал то же самое только не было включена функция «Always on top», sorry!

Yashalta ()
Ответ на: комментарий от Yashalta

Вот, что выдает если ввести в терминале команду «xprop» и кликнуть по терминалу и в окне терминала включена функция «Always on top»

[spoiler=]


zerg@zerg-swarm:~$ xprop
_NET_WM_USER_TIME(CARDINAL) = 1052015
_NET_WM_ICON_GEOMETRY(CARDINAL) = 572, 876, 150, 24
WM_STATE(WM_STATE):
		window state: Normal
		icon window: 0x0
_NET_WM_DESKTOP(CARDINAL) = 0
_NET_WM_ALLOWED_ACTIONS(ATOM) = _NET_WM_ACTION_CHANGE_DESKTOP, _NET_WM_ACTION_SHADE, _NET_WM_ACTION_CLOSE, _NET_WM_ACTION_MOVE, _NET_WM_ACTION_MINIMIZE, _NET_WM_ACTION_RESIZE, _NET_WM_ACTION_FULLSCREEN, _NET_WM_ACTION_MAXIMIZE_HORZ, _NET_WM_ACTION_MAXIMIZE_VERT, _NET_WM_ACTION_ABOVE, _NET_WM_ACTION_BELOW, _OB_WM_ACTION_UNDECORATE
_KDE_NET_WM_FRAME_STRUT(CARDINAL) = 1, 1, 26, 4
_NET_FRAME_EXTENTS(CARDINAL) = 1, 1, 26, 4
_NET_WM_STATE(ATOM) = _NET_WM_STATE_ABOVE
_OB_APP_TYPE(UTF8_STRING) = "normal"
_OB_APP_TITLE(UTF8_STRING) = "LXTerminal"
_OB_APP_GROUP_CLASS(UTF8_STRING) = "X-terminal-emulator"
_OB_APP_GROUP_NAME(UTF8_STRING) = "x-terminal-emulator"
_OB_APP_CLASS(UTF8_STRING) = "X-terminal-emulator"
_OB_APP_NAME(UTF8_STRING) = "x-terminal-emulator"
_OB_APP_ROLE(UTF8_STRING) = 
_NET_WM_VISIBLE_ICON_NAME(UTF8_STRING) = "zerg@zerg-swarm: ~"
_NET_WM_VISIBLE_NAME(UTF8_STRING) = "zerg@zerg-swarm: ~"
WM_HINTS(WM_HINTS):
		Client accepts input or input focus: True
		Initial state is Normal State.
		bitmap id # to use for icon: 0x2a00027
		bitmap id # of mask for icon: 0x2a0002a
		window id # of group leader: 0x2a00001
XdndAware(ATOM) = BITMAP
_MOTIF_DRAG_RECEIVER_INFO(_MOTIF_DRAG_RECEIVER_INFO) = 0x6c, 0x0, 0x5, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x0, 0x10, 0x0, 0x0, 0x0
_NET_WM_ICON(CARDINAL) = 	Icon (128 x 128):
	                                                                                                                                

	Icon (24 x 24):
	                        

_NET_WM_SYNC_REQUEST_COUNTER(CARDINAL) = 44040198
_NET_WM_WINDOW_TYPE(ATOM) = _NET_WM_WINDOW_TYPE_NORMAL
_NET_WM_USER_TIME_WINDOW(WINDOW): window id # 0x2a00005
WM_CLIENT_LEADER(WINDOW): window id # 0x2a00001
_NET_WM_PID(CARDINAL) = 2092
WM_LOCALE_NAME(STRING) = "ru_RU.UTF-8"
WM_CLIENT_MACHINE(STRING) = "zerg-swarm"
WM_NORMAL_HINTS(WM_SIZE_HINTS):
		program specified minimum size: 34 by 60
		program specified resize increment: 8 by 17
		program specified base size: 2 by 26
		window gravity: NorthWest
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW, WM_TAKE_FOCUS, _NET_WM_PING, _NET_WM_SYNC_REQUEST
WM_CLASS(STRING) = "x-terminal-emulator", "X-terminal-emulator"
WM_ICON_NAME(STRING) = "zerg@zerg-swarm: ~"
_NET_WM_ICON_NAME(UTF8_STRING) = "zerg@zerg-swarm: ~"
WM_NAME(STRING) = "zerg@zerg-swarm: ~"
_NET_WM_NAME(UTF8_STRING) = "zerg@zerg-swarm: ~"


[/spoiler] zerg@zerg-swarm:~$

Yashalta ()
Ответ на: комментарий от Yashalta

да, хорошо, значит compton с той строкой в конфиге должен работать. ещё раз спрошу: compton работает?

f1u77y ★★★ ()
Ответ на: комментарий от f1u77y

К сожалению все по прежнему! Что было мною сделано: Я добавил эту строчку «opacity-rule = [»_NET_WM_STATE@:a *= 'ABOVE':1.00"]" в фаил compton.conf и даже перезагрузился, но результат прежний, compton продолжает делать прозрачными не активные окна даже если у них активированна функция «Always on top». Ниже привел код для проверки, может я не туда «сую» нужную строку или может, что еще т.п. делаю не правильно.

[spoiler=]

# Shadow
shadow = true;
#shadow = false;
no-dnd-shadow = true;
no-dock-shadow = true;
#clear-shadow = true;
shadow-radius = 7;
shadow-offset-x = 3;
shadow-offset-y = 3;
shadow-opacity = 0.7;
# shadow-red = 0.0;
# shadow-green = 0.0;
# shadow-blue = 0.0;

## Remove Shadow from CONKY WINDOW ##
## compliments mrpeachy and falldown
# use wininfo to determine window name -OR- in the conky:
#		own_window_class conky_logo
# Then just simply use:
#               shadow-exclude = "i:e:window-name";
# Use brackets and comma for more then one window
#		shadow-exclude = ["i:e:conky_logo","i:e:conkyw","i:e:S11","i:e:test"];
#		shadow-exclude = "i:e:Conky";
############## try this #################
# shadow-exclude = ["i:e:Conky","i:e:interactiveconky","i:e:click_log"];
shadow-exclude = "i:e:conky_logo";
# focus-exclude = [«class_g = 'ToggleAlwaysOnTop'»];


shadow-ignore-shaped = false;

# Opacity
menu-opacity = 1;			# The opacity for menus. (default 1.0)
inactive-opacity = 0.5;			# Default opacity of inactive windows. (0.0 - 1.0)
# active-opacity = 0.8;			# Default opacity for active windows. (0.0 - 1.0)
frame-opacity = 0.7;			# Opacity of window titlebars and borders. (0.1 - 1.0)
inactive-opacity-override = false;	# Let inactive opacity set by 'inactive-opacity' overrides
focus-exclude = [ "class_g = 'conky_logo'" ];    # value of _NET_WM_OPACITY. Bad choice.
alpha-step = 0.06;			# XRender backend: Step size for alpha pictures. Increasing
opacity-rule = ["_NET_WM_STATE@:a *= 'ABOVE':1.00"]
					# it may result in less X resource usage,
					# Yet fading may look bad.
#inactive-dim = 0.5;			# Dim inactive windows. (0.0 - 1.0)
# inactive-dim-fixed = true;		# Do not let dimness adjust based on window opacity.
# blur-background = true;		# Blur background of transparent windows.
					# Bad performance with X Render backend.
					# GLX backend is preferred.
# blur-background-frame = true;		# Blur background of opaque windows with transparent
					# frames as well.
#blur-background-fixed = false;		# Do not let blur radius adjust based on window opacity.
#blur-background-exclude = [ "window_type = 'dock'", "window_type = 'desktop'" ];
					# Exclude conditions for background blur.


# Fading
fading = true;
# fade-delta = 30;
fade-in-step = 0.015;
fade-out-step = 0.03;
# no-fading-openclose = true;

# Other
mark-wmwin-focused = true;
mark-ovredir-focused = true;
detect-rounded-corners = true;
detect-client-opacity = true;
#refresh-rate = 0;
#vsync = "none";
dbe = false;
paint-on-overlay = false;
sw-opti = false;

# Window type settings
wintypes:
{
  tooltip = { fade = true; shadow = false; opacity = 0.85; };
};
[/spoiler]

Yashalta ()
Ответ на: комментарий от Yashalta

ой, сорри, я строку написал неправильно. надо так:

opacity-rule = ["99:_NET_WM_STATE@:a *= 'ABOVE'"]
теперь вроде должно работать

99 потому что 100% ничего не меняет(см. man compton, если интересно)

f1u77y ★★★ ()
Ответ на: (РЕШЕНО) Compton и функция повер всех окон! от Yashalta

Продолжаю эту ветку т.к. выявилась новая проблемка с «Compton и функцией повер всех окон». Сегодня подключил второй монитор к ноуту... На Lubuntu 15.10 легко настраиватеся где и какой рабочий стол будет отображаться... И вот тут-то и выяснилось, что если на втором мониторе включить браузер или что нибудь другое но главное на весь экран то оно становиться полупрозрачным! (т.к. в настройках «compton» у меня настроено так, что если окно становиться не активным то оно становиться полупрозрачным!) И не важно включена ли функция «по верх всех окон» или нет! В этой ветке ранее мне помогли найти решение

opacity-rule = ["99:_NET_WM_STATE@:a *= 'ABOVE'"]
И это решение исправно работает если окно открыто не на весь экран! Но сейчас на двух мониторах необходимо открывать, что-то на одном мониторе на весь экран и что-то на другом мониторе тоже на весь экран! И вот тут-то и проявляется проблемка с прозрачностью активных окон! Думаю тут как-то нужно добавить исключение прозрачности активных окон открытых на весь экран!

Yashalta ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.