LINUX.ORG.RU

qemu и libvirt

 ,


0

1

Всем привет!

Для использования в ubuntu qemu мне требуется вот такая команда

apt-get install qemu-kvm libvirt-bin

Но компоненты ставятся старые

я принял решение поставить последние версии, но самостоятельно

qemu вроде поставился и работает нормально... а вот libvirt-bin нет

https://libvirt.org/compiling.html

wget https://libvirt.org/sources/libvirt-1.3.2.tar.gz

gunzip -c libvirt-1.3.2.tar.gz | tar xvf - cd libvirt-1.3.2

./configure && make && make install

НО! после выполнения команды.. и make install

virsh все равно не работает... система его не видит

virsh -c qemu:///system version --daemon

пишет, что not found directory.....

я попробовал из гита поставить

git clone git://libvirt.org/libvirt.git

cd libvirt/

./autogen.sh –system

./configure && make && make install

эффект 1.... система его не видит

явно я что то упустил, либо нужно указать что я ставлю в систему а не в папку только.. или что то еще...


Вопрос вдогонку - насколько qemu-kvm годна на десктопе в качестве замены virtualbox? Достали уже косяки с vbox при обновлении. Сценарий применения - linux-хост, гостевая win, изредка используется для запуска специфичных прог, типа офиса. Слышал про virt-manager, насколько он хорош? Можно ли использовать только его в качестве гуя, не обращаясь к консольке? Как там со звуком, 3d-ускорением, сложно ли сделать папку обмена?

anonymous ()

пишет, что not found directory.....

ты бы хоть целиком сообщение скопи-пастил что ли.

вообще, для начала я бы сделал apt-get purge всех кусков либвирта старых, а потом новые ставил. + там следует учесть, что по умолчанию из гита ставится все в /usr/local, там же создаются сокеты и хранится состояние, так что если например у тебя запускается старый virsh из /usr/bin, который идет раньше /usr/local/bin, а либвирт запущен новый, то вирш пойдет в неправильный сокет.

короче, точную ошибку давай.

Novel ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.