LINUX.ORG.RU

Нет звука в XFCE

 , , ,


0

2

OS: Arch Linux DE: XFCE4

alsa-lib alsa-utils установлено, пробовал поставить звук по вики, не вышло, а именно путем подкручивания каналов в alsamixer

 aplay -l

**** List of PLAYBACK Hardware Devices **** card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 0: ALC269VC Analog [ALC269VC Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

Следуя вики «Нет звука на установленной S/PDIF видеокарте»:

cat /proc/asound/modules

0 snd_hda_intel
1 snd_hda_intel

«Если оба устройства используют одинаковый модуль, можно включить параметр enable в модуле snd_hda_intel; это массив логических значений что разрешают/запрещают работу желаемой звуковой карты.
options snd_hda_intel enable=1,0 »

Не могу понять куда именно прописывать этот параметр и вообще тем ли путем я иду. Буду благодарен любой конструктивной критике.

А может ты не то устройство в микшере крутишь?

$ alsamixer
<F6>
Что говорит?

deep-purple ★★★★★ ()

А ты включил вообще канал? Когда запускаешь alsamixer, под master случайно нет букв MM? Если есть - нажми M, чтобы убрать mutable.

aarexer ()
Ответ на: комментарий от deep-purple

У меня там:
0 HDA ATI HDMI
1 HD-Audio Generic

Кручу 1, когда выбираю 0 ничего не выходит, остается <S/PDIF> открытый и шкала в нем не меняется.
В 1 Master 100, Headphones 100, Speaker 100, Mic 56, Internal 56 и все открыты

danya_stdfx ()

Проблема решилась, в настройках к audio mixer plugin не была выбрана карта

danya_stdfx ()

options snd_hda_intel enable=1,0 »

Не могу понять куда именно прописывать этот параметр и вообще тем ли путем я иду. Буду благодарен любой конструктивной критике.

В Debian строки такого формата (чтобы аудио было аналоговое, а не цифровое) прописываются в /etc/modprobe.d/alsa-base.conf.

AVRS ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.