LINUX.ORG.RU

https://www.archlinux.org/pacman/pacman.conf.5.html

Вот тебе образец на основу:

[options]
HoldPkg      = pacman glibc
Architecture = auto

# Misc options
Color
CheckSpace

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional

SigLevel = PackageRequired

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

#[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

[multilib]
Include = /etc/pacman.d/mirrorlist

[archlinuxfr]
Server = http://repo.archlinux.fr/$arch

najlus ★★★★★ ()
Последнее исправление: najlus (всего исправлений: 1)
Ответ на: комментарий от najlus

этого будет достаточно, ничего не нужно будет дописывать?

NightFobos ()
Ответ на: комментарий от NightFobos

Пока что запустил обновление системы. Вопрос на будущее. Возможно будет ругаться pacman на отсутствие ключей как то так warning: Public keyring not found. как бы это поправить?

NightFobos ()
Ответ на: комментарий от NightFobos

этого будет достаточно, ничего не нужно будет дописывать?

Это с моего конфига. Он практически дефолтный, так что хватит.

Пока что запустил обновление системы. Вопрос на будущее. Возможно будет ругаться pacman на отсутствие ключей как то так warning: Public keyring not found. как бы это поправить?

Если хочешь, можешь вообще отклбчить проверку ключей. В конфиге строку

SigLevel = PackageRequired
поменяй на
SigLevel = Never

А зачем ты вообще pacman.conf снёс?

najlus ★★★★★ ()
Ответ на: комментарий от najlus

Как бы это объяснить. Давно в арче не копался. Ну и хотел сгенерировать pacman.conf.new. Проделал необходимые операци, а потом глянул в /etc/ а там нет ни того ни другого. Ну да ничего страшного.

NightFobos ()
Ответ на: комментарий от NightFobos

SigLevel поправил. Далее pacman -Suy, выдало вот что:

error:failed to commit trasaction(conflicting files)
dcadec:usr/lib/libdcadec.so.0 exists in filesystem
Errors occured, no packages were upgraded
Что конфликтует.

NightFobos ()
Ответ на: комментарий от NightFobos

Вопрос решил после googla,

sudo pacman -Rdd dcadec
и обновиться заново. По крайней мере мне и некоторым товарищам в нет это помогло.

NightFobos ()
Ответ на: комментарий от NightFobos

Ещё можно просто вручную снести данный файл.

najlus ★★★★★ ()

Удалил специально pacman.conf

Но зачем?
Можешь скопировать из Live-USB твоего ArchBang

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Ок. Сейчас проблема уже другая, т.к этот дистрибутив тестирую в VBOXe, то естественно нужно поставить дополнения VBOXADDITIONS, нашел, установил через pacman, команды:

modprobe vboxvideo
,
modprobe vboxguest
,
modprobe vboxsf
прошли без ошибок. А вот разрешение и соответственно видео ускорение не поднялось, пока думаю куда копать.

NightFobos ()
Ответ на: комментарий от sudopacman

Конечно включено, уменя ж там чистый арч, gentoo и slackware крутяться. Скорее всего нет ускорения и не меняется разрешение из-за несоответсвия версий VBOXa. Ибо в ArchBANGе все версии модулей включая VBOX 5.0. А на хосте работает VBOX 4.3.32. Думаю в этом то как раз и зарыта собака.

NightFobos ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.