LINUX.ORG.RU

mount USB винчестера


0

1

не могу совладать с Trancend на 80Г.

mount -t vfat /dev/sda /mnt/flash
mount: /dev/sda is not a valid block device

ядро 2.6.12-1.1380asp

tail /var/log/messags

Jan 10 19:37:17 samurai kernel: ehci_hcd 0000:00:1d.7: port 4 reset error -110
Jan 10 19:37:17 samurai kernel: hub 1-0:1.0: hub_port_status failed (err = -32)
Jan 10 19:37:18 samurai kernel: ehci_hcd 0000:00:1d.7: port 4 reset error -110
Jan 10 19:37:18 samurai kernel: hub 1-0:1.0: hub_port_status failed (err = -32)
Jan 10 19:37:19 samurai kernel: ehci_hcd 0000:00:1d.7: port 4 reset error -110
Jan 10 19:37:19 samurai kernel: hub 1-0:1.0: hub_port_status failed (err = -32)
Jan 10 19:37:19 samurai kernel: hub 1-0:1.0: Cannot enable port 4. Maybe the USB cable is bad?
Jan 10 19:37:20 samurai kernel: ehci_hcd 0000:00:1d.7: port 4 reset error -110
Jan 10 19:37:20 samurai kernel: hub 1-0:1.0: hub_port_status failed (err = -32)
Jan 10 19:37:20 samurai kernel: ehci_hcd 0000:00:1d.7: port 4 reset error -110
Jan 10 19:37:20 samurai kernel: hub 1-0:1.0: hub_port_status failed (err = -32)
Jan 10 19:37:21 samurai kernel: hub 1-0:1.0: Cannot enable port 4. Maybe the USB cable is bad?
Jan 10 19:37:22 samurai kernel: ehci_hcd 0000:00:1d.7: port 4 reset error -110
Jan 10 19:37:22 samurai kernel: hub 1-0:1.0: hub_port_status failed (err = -32)
Jan 10 19:37:22 samurai kernel: ehci_hcd 0000:00:1d.7: port 4 reset error -110
Jan 10 19:37:22 samurai kernel: hub 1-0:1.0: hub_port_status failed (err = -32)
Jan 10 19:37:23 samurai kernel: hub 1-0:1.0: Cannot enable port 4. Maybe the USB cable is bad?
Jan 10 19:37:24 samurai kernel: ehci_hcd 0000:00:1d.7: port 4 reset error -110
Jan 10 19:37:24 samurai kernel: hub 1-0:1.0: hub_port_status failed (err = -32)
Jan 10 19:37:25 samurai kernel: ehci_hcd 0000:00:1d.7: port 4 reset error -110
Jan 10 19:37:25 samurai kernel: hub 1-0:1.0: hub_port_status failed (err = -32)
Jan 10 19:37:25 samurai kernel: hub 1-0:1.0: Cannot enable port 4. Maybe the USB cable is bad?

куда хоть смотреть?

★★★

Ответ на: Re: mount USB винчестера от Rain

Re: mount USB винчестера

да я пробовал и sda1 или надо все номера там перебирать? :) питание должно хватать я два шнура через USB засадил

vaborg ★★★ ()
Ответ на: Re: mount USB винчестера от sdio

Re: mount USB винчестера

lsmod
Module Size Used by
vfat 13505 0
fat 55645 1 vfat
sd_mod 20161 0
scsi_mod 149769 1 sd_mod
radeon 75713 1
drm 71381 2 radeon
md5 4161 1
ipv6 272705 12
parport_pc 28677 1
lp 13257 0
parport 41225 2 parport_pc,lp
autofs4 29253 0
dm_mod 60789 0
video 15685 0
button 4033 0
battery 9285 0
ac 4805 0
uhci_hcd 36177 0
ehci_hcd 40781 0
snd_intel8x0 34945 30
snd_ac97_codec 77497 1 snd_intel8x0
snd_pcm_oss 51952 0
snd_mixer_oss 18497 31 snd_pcm_oss
snd_pcm 104009 3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_timer 33605 1 snd_pcm
snd 59589 6 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_timer
soundcore 10913 31 snd
snd_page_alloc 9925 2 snd_intel8x0,snd_pcm
8139too 30145 0
mii 5441 1 8139too
floppy 65141 0
reiserfs 263989 3

dmesg
ehci_hcd 0000:00:1d.7: port 4 reset error -110
hub 1-0:1.0: hub_port_status failed (err = -32)
ehci_hcd 0000:00:1d.7: port 4 reset error -110
hub 1-0:1.0: hub_port_status failed (err = -32)
ehci_hcd 0000:00:1d.7: port 4 reset error -110
hub 1-0:1.0: hub_port_status failed (err = -32)
hub 1-0:1.0: Cannot enable port 4. Maybe the USB cable is bad?
ehci_hcd 0000:00:1d.7: port 4 reset error -110
hub 1-0:1.0: hub_port_status failed (err = -32)
ehci_hcd 0000:00:1d.7: port 4 reset error -110
hub 1-0:1.0: hub_port_status failed (err = -32)
hub 1-0:1.0: Cannot enable port 4. Maybe the USB cable is bad?
ehci_hcd 0000:00:1d.7: port 4 reset error -110
hub 1-0:1.0: hub_port_status failed (err = -32)
ehci_hcd 0000:00:1d.7: port 4 reset error -110
hub 1-0:1.0: hub_port_status failed (err = -32)
hub 1-0:1.0: Cannot enable port 4. Maybe the USB cable is bad?
ehci_hcd 0000:00:1d.7: port 4 reset error -110
hub 1-0:1.0: hub_port_status failed (err = -32)
ehci_hcd 0000:00:1d.7: port 4 reset error -110
hub 1-0:1.0: hub_port_status failed (err = -32)
hub 1-0:1.0: Cannot enable port 4. Maybe the USB cable is bad?
SCSI subsystem initialized

vaborg ★★★ ()
Ответ на: Re: mount USB винчестера от vaborg

Re: mount USB винчестера

Модуль usb-storage (или usb_storage, не помню) почему не прогружен?

Кроме того, попробуйте заводить не как usb2, а как usb1 (то бишь прибить ehci-модуль, оставив только uhci-).

Obidos ★★★★★ ()
Ответ на: Re: mount USB винчестера от vaborg

Re: mount USB винчестера

как вариант - проверить на другом компе/другой системе. чтобы исключить возможную проблему с самим винтом.

Rain ★★★★ ()
Ответ на: Re: mount USB винчестера от Obidos

Re: mount USB винчестера

Огромное спасибо! подгрузил usb-storage и удалил ehci-модуль всё заработало. Он стал монтироваться. А не подскажите, как его отформатировать под fat32?

vaborg ★★★ ()
Ответ на: Re: mount USB винчестера от vaborg

Re: mount USB винчестера

> подгрузил usb-storage и удалил ehci-модуль всё заработало

Таким образом, в usb1-режиме оно завелось. Попробуйте (если И устройство И материнка поддерживают usb2) завести как usb2 (скорость должна вырасти раз в 8-10). Для этого следует:

1. Выгрузить usb-storage, uhci-модуль.

2. Прогрузить ehci-модуль, usb-storage (следите, чтобы не вылезал uhci).

Obidos ★★★★★ ()
Ответ на: Re: mount USB винчестера от Obidos

Re: mount USB винчестера

у меня при выгружении uhci-модуля - мышь отрубается.

vaborg ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.