LINUX.ORG.RU

Проблемы при установке по

 , ,


0

1

Доброго времени суток

Помогите пожалуйста, второй день мучаюсь с установкой spamassassin и казалось бы при выполнении такой тривиальной задачи, постоянно вылетают костыли, то с менеджером пакетов, то еще.

Очередной костыль,

===>   spamassassin-3.4.1_5 depends on package: p5-Encode-Detect>=0 - not found
===>   p5-Encode-Detect-1.01_1 depends on package: p5-Module-Build>=0.4206 - not found
===>   p5-Module-Build-0.4214 depends on package: p5-CPAN-Meta>=2.142060 - not found
===>   p5-CPAN-Meta-2.150005 depends on package: p5-CPAN-Meta-Requirements>=2.121 - not found
===>  Installing for p5-CPAN-Meta-Requirements-2.133
===>   p5-CPAN-Meta-Requirements-2.133 depends on file: /usr/local/bin/perl5.16.3 - found
===>  Checking if p5-CPAN-Meta-Requirements already installed
===>   Registering installation for p5-CPAN-Meta-Requirements-2.133 as automatic
pkg-static: Unable to access file /usr/ports/devel/p5-CPAN-Meta-Requirements/work/stage/usr/local/lib/perl5/site_perl/man/man3/CPAN::Meta::Requirements.3.gz: No such file or directory
*** Error code 74

Stop in /usr/ports/devel/p5-CPAN-Meta-Requirements.
*** Error code 1

Stop in /usr/ports/devel/p5-CPAN-Meta.
*** Error code 1

Stop in /usr/ports/devel/p5-Module-Build.
*** Error code 1

Stop in /usr/ports/converters/p5-Encode-Detect.
*** Error code 1

Stop in /usr/ports/mail/spamassassin.
*** Error code 1

по указанному пути он не находит Requirements.3.gz что ж, его там и вправду нет.

В Updating написанно следующее:

20120108:                                         
  AFFECTS: users of devel/p5-CPAN-Meta and devel/p5-Version-Requirements
  AUTHOR: sunpoet@FreeBSD.org                     
                                                  
  Author of Version::Requirements (devel/p5-Version-Requirements) merged
  its function to CPAN::Meta::Requirements (part of devel/p5-CPAN-Meta).
  As a result, devel/p5-Version-Requirements is marked DEPRECATED.
  Please run the following commands to update p5-CPAN-Meta and remove
  p5-Version-Requirements:

  # portmaster -o devel/p5-CPAN-Meta devel/p5-Version-Requirements
  # pkg_delete p5-Version-Requirements-\*

Так этого пакета у меня в системе не установлено, как быть? Скажите пожалуйста, что из себя представляет архив Requirements.3.gz

Куда дальше копать, помогите советом.

Я бы сделал

touch /usr/ports/devel/p5-CPAN-Meta-Requirements/work/stage/usr/local/lib/perl5/site_perl/man/man3/CPAN::Meta::Requirements.3.gz

это всего лишь ман

unC0Rr ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.