LINUX.ORG.RU

Opentfire

 , , ,


0

1

День добрый если добрый. Помогите пожалуйста! Раньше без проблем ставил openfire под freebsd, сейчас останавливается сборка с ошибкой. Говорят нужно java (jdk) вручную докачивать но я не уверен судя по всему.

#uname -a FreeBSD jabber.localhost 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC amd 64

===> cario-1.16.0,2 depends on shared libintl.so - found (/usr/local/lib/libintl.so) ==> cario-1.16.0,2 depends on shared library: libGL.so -not found ==> mesa-libs-18.3.2 needs Python 2.7 at most, but 3.6 was specified. *** Error code 1

Stop. make [10]: stopped in /usr/ports/graphics/mesa-libs *** Error code 1

Stop. make [9]: stopped in /usr/ports/graphics/cario *** Error code 1

Stop. make [8]: stopped in /usr/ports/graphics/cario *** Error code 1

Stop. make[7]: stopped in /usr/ports/develgobject-introspection *** Error code 1

Stop. make[6]: stopped in /usr/ports/net/avahi-app *** Error code 1

Stop. make[5]: stopped in /usr/ports/print/cups *** Error code 1

Stop. make[4]: stopped in /usr/ports/print/cups *** Error code 1

Stop. make[3]: stopped in /usr/ports/java/openjdk8 *** Error code1

Stop. make[2]: stopped in /usr/ports/java/openjdk8 *** Error code1

Stop. make[1]: stopped in /usr/ports/net-im/openfire *** Error code1

Stop. make: stopped in /usr/ports/net-im/openfire

cario-1.16.0,2 depends on shared library: libGL.so -not found

libGL.so -not found


mesa-libs-18.3.2 needs Python 2.7 at most, but 3.6 was specified.

needs Python 2.7 at most

but 3.6 was specified


Что не понятно-то?

И да, не всё из портов собирается.

mord0d ()
Ответ на: комментарий от ini_any

установить сначала Python 2.7 потом начать сборку порта?

Я не понимаю, как тебе удалось упустить автоматический резольв зависимостей. И я не понимаю, чем тебя не устраивает бинарный пакет. Установи Python 2.7.16, или какой там доступен в 12.0-RELEASE на данный момент, и попробуй заново. Можешь попробовать собрать порт mesa-lib, может тогда разрулятся зависимости нормально.

я очень, очень ленивый админ

Твою работу за тебя делать никто не будет. Тебе за неё платят, ты её и делай.

Совет от IPR,

Сначала все пакеты обнови.

дополню: также обнови порты.

mord0d ()

mesa-libs-18.3.2 needs Python 2.7 at most, but 3.6 was specified

Мне кажется такое возможно только ты сделал какую-то невообразимую херню, типа указал PYTHON_VERSION в /etc/make.conf, потому что в обычной ситуации система портов нормально разруливает зависимости, и ставит 2.7 если нужен именно он даже если по умолчанию (что правильно делается через DEFAULT_VERSIONS) указан 3.6. Удаляй /etc/make.conf и пробуй снова.

slovazap ★★★★★ ()
Последнее исправление: slovazap (всего исправлений: 2)
Ответ на: комментарий от slovazap

хм, никакой дичи я не делал, стоковая система, репозитории обновляю первым делом всегда. В общем решил проблему установкой вручную пакета mesa-libs опосля порт собрался успешно. Спасибо Вам уважаемые админы за помощь.

ini_any ()