LINUX.ORG.RU

Ошибка при создании базы на сервере 1с 8.3+postgresql Debian 7

 , ,


0

2

Всем привет форумчане!

В общем я настроил сервер на базе debian 7 там установил сервер 1с 8.3 и базу данных postgresql, все работает! На своем компе в сети я установить оснастку адмиинстрирования сервера 1с, там же добавил центральный сервер,все хорошо, но при создании базы вылетает вот такая ошибка, может кто знает в чем проблема весь инет перерыл не нашел подобной ошибки!Скрин внутри https://yadi.sk/d/jhL1c5GRkPzYY


Надо читать первую ошибку. Возможно вторая исходит из первой. Убедитесь, что рабочие процессы созданы в этой оснастке?

petav ★★★★★ ()
Ответ на: комментарий от dor90

1) в файле hosts на винде добавили запись на ваш линуксовый сервер? 2) фаер на винде допускает соединение с линуксовым сервером?

kd75 ()
Ответ на: комментарий от dor90

а версия postgre какая? У меня нормально заработало только с вот этой-

PostgreSQL 9.2.1-eter1debian on i486-pc-linux-gnu, compiled by gcc (Debian 4.7.2-5) 4.7.2.
На более поздних версиях постгрес устанавливался но создать рабочуюю базу не удавалось ps:
Linux main 3.2.0-4-686-pae #1 SMP Debian 3.2.71-2 i686 GNU/Linux

kd75 ()
Ответ на: комментарий от kd75

у меня такая же стоит PostgreSQL 9.2.1-eter8debian on x86_64-pc-linux-gnu, compiled by gcc (Debian 4.7.2-5) 4.7.2, 64-bit

Система Linux postgres 2.6.32-19-pve #1 SMP Wed May 15 07:32:52 CEST 2013 x86_64 GNU/Linux

Интересно что при создании базы через сервер 1с установленный на виндовс, все нормально база поднимается!

dor90 ()
Ответ на: комментарий от dor90

Попробовал, у меня из линуксового толстого клиента 1С тоже не получается базу создать (сервер предприятия и постгре на лине). С винды всё добаляется. у 1с вроде бы даже баг на эту тему проскакивал, видимо не пофиксили.

kd75 ()
Ответ на: комментарий от dor90

да почему не будет, он работает, просто не надо дебианом пользоваться, а ставить red hat и его производные, качать постргре с сайта 1С и радоваться жизни

anonymous ()
Ответ на: комментарий от dor90

не слушайте анонимуса, у меня в настоящий момент сервер debian old stable на нем установлен постгресс и сервер предприятия 1С. На этом сервере крутится управление торговли «Управление торговлей», редакция 10.3 (10.3.31.1) и бухгалтерская база, нагрузка правда небольшая всего 5-6 человек одновременно. Минус один - с линуксовой 1с я не могу создать никакую базу. С виндовой машины нормально подключаюсь к серверу с линуксом, создаю всё что надо и дальше работаю хоть из линукса хоть из вин.

kd75 ()
Ответ на: комментарий от kd75

да в принципе у меня такие же потребности, небольшое количество подключений, только я так и не пойму как ты базы то создаешь на сервере 1с который у тебя на debiane? Т.е. у тебя сервер 1с стоит на виндовой машине? так?:)

dor90 ()
Ответ на: комментарий от dor90

У меня сейчас стоит сервер 1с на виндовой машине дык я могу создать базу на сервере с postgresql и она будет работать нормально!

dor90 ()
Ответ на: комментарий от dor90

Внимание! Это уничтожит всю информацию о существующем кластере. ЕСЛИ ЭТО ЕЩЕ НЕ В ПРОДАКШЕНЕ, может попробовать

1) из винды в консоли администрирования серверов 1с  удалить все что можно
2) на линуксячей машине с постгре и сервером 1с
# service srv1cv83 stop
# service postgresql stop
-останавливаем постгрес и сервер 1с
3) чистим директорию 1с 
удалить всё из директории /home/usr1cv8
4)На видовой машине посмотреть куда 1С пишет конфигурационные файлы и тоже снести их (давно не сталкивался, даже не подскажу где это)
5)запускаем постгрес и сервер 1С

# service postgresql start
# service srv1cv83 start

6)Из винды пробуем создать новую базу

kd75 ()
Ответ на: комментарий от kd75

к ним могу подключатся хоть с линуксовых хоть с видовых машин важно что бы версия клинтской и серверной части 1с совпадали на сервере и на клиенте, иначе подключится не получится

kd75 ()
Ответ на: комментарий от kd75

Удалил из директории home теперь не могу запустить сервер 1с

root@postgres:~# service srv1cv83 start Starting 1C:Enterprise 8.3 server: Каталог отсутствует или недоступен, вход в систему выполняется с HOME=/ Error: service failed to start! FAILED

Пробовал создать руками каталоги, не помогает. Значит сервер 1с у тебя не стоит на линуксе, он там просто напросто не нужен

dor90 ()
Ответ на: комментарий от dor90

сервер 1с у меня однозначно на линуксе, зуб даю :)

kd75 ()
Ответ на: комментарий от KOV

у меня из линя еслы пытаешся создать базу просто пишет «ошибка при создании информационной базы», из винды на этом сервере создается без проблем

kd75 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.